Ignore:
Timestamp:
May 16, 2008, 9:57:14 PM (12 years ago)
Author:
eridius@…
Message:

macfuse: change platform to macosx and stop using dummy variants

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/fuse/macfuse/Portfile

    r36749 r36860  
    66version             1.5
    77categories          fuse devel
    8 platforms           darwin
     8platforms           macosx
    99maintainers         eridius@macports.org
    1010description         A FUSE-Compliant File System Implementation Mechanism for Mac OS X
     
    3636# patchfiles          patch-project.pbxproj
    3737
    38 platform darwin 8 {
    39     # dummy for pre-fetch
    40 }
    41 platform darwin 9 {
    42     # dummy for pre-fetch
    43 }
    44 
    4538variant universal {
    4639    # provide a dummy variant since the script will actually build universal
     
    5043# ensure that user is running OS X 10.4 or higher
    5144pre-fetch {
    52     if {![variant_isset darwin_8] && ![variant_isset darwin_9]} {
     45    if {${os.platform} != "darwin" || [rpm-vercomp ${os.version} 8.0.0] < 0} {
    5346        return -code error "MacFUSE requires at least Mac OS X 10.4 to run"
    5447    }
Note: See TracChangeset for help on using the changeset viewer.