Changeset 4509


Ignore:
Timestamp:
Jan 7, 2004, 6:08:59 PM (17 years ago)
Author:
ssen
Message:

When building an RPM package, use rpmbuild(1) instead of rpm(1), since
the latter does not work with RPM 4.1.x. rpmbuild(1) works with
both RPM 4.0.x and RPM 4.1.x
Bug: 1384
Submitted by: Shantonu Sen <ssen@…>

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/base/src/port1.0/portrpmpackage.tcl

    r4453 r4509  
    104104    system "cd '${destpath}' && find . ! -type d | grep /etc/ | sed -e 's/\"/\\\"/g' -e 's/^./%config \"/' -e 's/$/\"/' >> '${workpath}/${portname}.filelist'"
    105105    write_spec ${specpath} $portname $portversion $portrevision $pkg_description $pkg_long_description $category $maintainer $destpath $dependencies $epoch
    106     system "DP_USERECEIPTS='${portdbpath}/receipts' rpm -bb -v ${rpmdestpath} ${specpath}"
     106    system "DP_USERECEIPTS='${portdbpath}/receipts' rpmbuild -bb -v ${rpmdestpath} ${specpath}"
    107107   
    108108    return 0
Note: See TracChangeset for help on using the changeset viewer.