Changeset 49007


Ignore:
Timestamp:
Apr 1, 2009, 8:59:06 PM (10 years ago)
Author:
ricci@…
Message:

change to not

1) install modules into the base perl-installed modules directories
2) requiring -f to install except for those that install binaries/scripts into ${prefix}/bin

resolves (most of) ticket #19112

Location:
trunk/dports/perl
Files:
6 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/perl/p5-extutils-install/Portfile

    r42856 r49007  
    1616                    rmd160 2391d02cfd9631eeae4dcc634b650e6cd2bade79
    1717
    18 # Perl searches vendor location last, so this won't
    19 # override the older version included with perl
    20 # if we install it in the vendor location
    21 set perl5.lib   ${prefix}/lib/perl5/${perl5.version}
    22 
    23 configure.args 
    24 
    25 post-destroot {
    26     ui_msg "You must install or activate this package with '-f' (force) as it needs to overwrite files installed by the perl5.8 port"
    27 }
     18## # Perl searches vendor location last, so this won't
     19## # override the older version included with perl
     20## # if we install it in the vendor location
     21## set perl5.lib   ${prefix}/lib/perl5/${perl5.version}
     22##
     23## configure.args 
     24##
     25## post-destroot {
     26##     ui_msg "You must install or activate this package with '-f' (force) as it needs to overwrite files installed by the perl5.8 port"
     27## }
  • trunk/dports/perl/p5-mime-base64/Portfile

    r47648 r49007  
    1616checksums           md5 f466b62afc4fec7f262b0910913293b3
    1717
    18 post-destroot {
    19     ui_msg "You must install or activate this package with '-f' (force) as it needs to overwrite files installed by the perl5.8 port"
    20 }
     18## post-destroot {
     19##     ui_msg "You must install or activate this package with '-f' (force) as it needs to overwrite files installed by the perl5.8 port"
     20## }
  • trunk/dports/perl/p5-podlators/Portfile

    r45875 r49007  
    1717depends_lib-append    port:p5-pod-simple
    1818
    19 # Perl searches vendor location last, so this won't
    20 # override the older version included with perl
    21 # if we install it in the vendor location
    22 set perl5.lib   ${prefix}/lib/perl5/${perl5.version}
    23 
    24 configure.args 
    25 
     19## # Perl searches vendor location last, so this won't
     20## # override the older version included with perl
     21## # if we install it in the vendor location
     22## set perl5.lib   ${prefix}/lib/perl5/${perl5.version}
     23##
     24## configure.args 
     25##
    2626post-destroot {
    2727    ui_msg "You must install or activate this package with '-f' (force) as it needs to overwrite files installed by the perl5.8 port"
  • trunk/dports/perl/p5-scalar-list-utils/Portfile

    r40819 r49007  
    1616platforms           darwin
    1717
    18 # Perl searches vendor location last, so this won't
    19 # override the older version included with perl
    20 # if we install it in the vendor location
    21 set perl5.lib       ${prefix}/lib/perl5/${perl5.version}
     18## # Perl searches vendor location last, so this won't
     19## # override the older version included with perl
     20## # if we install it in the vendor location
     21## set perl5.lib       ${prefix}/lib/perl5/${perl5.version}
    2222
    23 configure.args
     23## configure.args
    2424
    25 post-destroot {
    26     ui_msg "You must install or activate this package with '-f' (force) as it needs to overwrite files installed by the perl5.8 port"
    27 }
     25## post-destroot {
     26##     ui_msg "You must install or activate this package with '-f' (force) as it needs to overwrite files installed by the perl5.8 port"
     27## }
  • trunk/dports/perl/p5-test-harness/Portfile

    r42023 r49007  
    1919                rmd160  6c36428ba7cb01c5cb9e2f5906c5e93598073371
    2020
    21 # Perl searches vendor location last, so this won't
    22 # override the older version included with perl
    23 # if we install it in the vendor location
    24 set perl5.lib   ${prefix}/lib/perl5/${perl5.version}
     21## # Perl searches vendor location last, so this won't
     22## # override the older version included with perl
     23## # if we install it in the vendor location
     24## set perl5.lib   ${prefix}/lib/perl5/${perl5.version}
    2525
    26 configure.args
     26## configure.args
    2727
     28## Test-Harness includes the 'prove' binary, which is used to run tests.  Sigh.
    2829post-destroot {
    2930    ui_msg "You must install or activate this package with '-f' (force) as it needs to overwrite files installed by the perl5.8 port"
  • trunk/dports/perl/p5-tie-refhash/Portfile

    r42808 r49007  
    2020                    rmd160 8f4b2534b353ea9524f09d14c4df7827c5084ea8
    2121
    22 # Perl searches vendor location last, so this won't
    23 # override the older version included with perl
    24 # if we install it in the vendor location
    25 set perl5.lib   ${prefix}/lib/perl5/${perl5.version}
    26 
    27 configure.args 
    28 
    29 post-destroot {
    30     ui_msg "You must install or activate this package with '-f' (force) as it needs to overwrite files installed by the perl5.8 port"
    31 }
     22## # Perl searches vendor location last, so this won't
     23## # override the older version included with perl
     24## # if we install it in the vendor location
     25## set perl5.lib   ${prefix}/lib/perl5/${perl5.version}
     26##
     27## configure.args 
     28##
     29## post-destroot {
     30##     ui_msg "You must install or activate this package with '-f' (force) as it needs to overwrite files installed by the perl5.8 port"
     31## }
Note: See TracChangeset for help on using the changeset viewer.