Ignore:
Timestamp:
Apr 15, 2009, 12:48:40 AM (11 years ago)
Author:
devans@…
Message:

ffmpeg/ffmpeg-devel:

  • enable auto configuration of x86 asm optimizations by default
  • check for required XCode >= 3.1 and abort with message if not present
  • add +no_mmx variant to disable all x86 asm optimizations if desired.

Closes #19314.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/multimedia/ffmpeg/Portfile

    r49616 r49661  
    66name            ffmpeg
    77version         0.5
    8 revision        1
     8revision        2
    99epoch           1
    1010categories      multimedia
     
    7474build.cmd       gmake
    7575configure.compiler gcc-4.0
     76
     77#
     78# enable auto configure of mmx and related Intel optimizations by default
     79# requires XCode 3.1.2 or better on Leopard
     80#
     81
     82pre-extract {
     83    if {"darwin" == ${os.platform} && 9 == ${os.major}} {
     84        set minimum_xcodeversion 3.1
     85        set current_xcodeversion [exec defaults read /Developer/Applications/Xcode.app/Contents/Info CFBundleShortVersionString]
     86        if {[rpm-vercomp ${current_xcodeversion} ${minimum_xcodeversion}] < 0} {
     87            ui_error "On Mac OS X ${macosx_version}, ${name} ${version} requires Xcode ${minimum_xcodeversion} or later but you have Xcode ${current_xcodeversion}."
     88            return -code error "incompatible Xcode version"
     89        }
     90    }
     91}
    7692
    7793configure.cflags-append    -DHAVE_LRINTF ${configure.cppflags}
     
    91107        --mandir=${prefix}/share/man \
    92108        --enable-shared --enable-pthreads \
    93         --disable-mmx \
    94109        --cc=gcc-4.0
    95110
     
    112127}
    113128
    114 #
    115 # comments concerning mmx problems may be out of date
    116 # needs testing on i386 platform to verify
    117 #
    118 
    119 variant mmx description {enable mmx optimizations ; may not build in gcc-4.2 or xcode 3.0 gcc-4.0} {
    120 # make no-mmx default and allow mmx enabling for the brave.
    121     configure.args-delete --disable-mmx
    122 # Fix Leopard problems by disabling the cavs decoder for now (is this still required?)
    123     configure.args-append --disable-decoder=cavs
     129variant no_mmx description {disable all x86 asm optimizations} {
     130    configure.args-append --disable-mmx --disable-mmx2 --disable-sse --disable-ssse3 --disable-amd3dnow --disable-amd3dnowext
    124131}
    125132
Note: See TracChangeset for help on using the changeset viewer.