Ignore:
Timestamp:
Jun 22, 2009, 4:41:06 PM (8 years ago)
Author:
devans@…
Message:

gst-plugins-base: disable cdparanoia plugin by default as it appears to not be compatible with latest upgrade of cdparanoia to version 10.2 (see #19843.) Add +cdparanoia variant to re-enable if desired.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/gnome/gst-plugins-base/Portfile

    r50949 r52743  
    66name            gst-plugins-base
    77version         0.10.23
     8revision        1
    89description     This is gst-plugins, a set of plug-ins for GStreamer.
    910long_description        ${description}
     
    2930        port:libogg \
    3031        port:libtheora \
    31         port:libvorbis \
    32         port:cdparanoia
     32        port:libvorbis
    3333
    3434depends_build \
     
    3636        port:automake \
    3737        port:libtool
     38
    3839use_autoreconf  yes
    3940autoreconf.args -fvi
    4041
    41 configure.args   --enable-experimental --disable-libvisual --disable-gst_v4l --disable-alsa
     42configure.args \
     43        --enable-experimental \
     44        --disable-libvisual\
     45        --disable-gst_v4l \
     46        --disable-alsa \
     47        --disable-cdparanoia
    4248
    4349variant no_x11 {
     
    4551}
    4652
     53#
     54# current cdparanoia port (cdparanoia III 10.2) appears to not be API compatible
     55# with gst-plugsin-base.  See #19843.
     56# disable by default until this is rectified.
     57#
     58
     59variant cdparanoia description {Enable (currently broken) cdparanoia plugin} {
     60       depends_lib-append port:cdparanoia
     61       configure.args-delete --disable-cdparanoia
     62}
     63
    4764livecheck.check regex
    4865livecheck.url   http://gstreamer.freedesktop.org/src/${name}/
Note: See TracChangeset for help on using the changeset viewer.