Ignore:
Timestamp:
Jun 30, 2009, 11:11:17 AM (10 years ago)
Author:
ryandesign@…
Message:

libsdl: require Xcode 2.4.1 or later on Tiger; see #20087

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/devel/libsdl/Portfile

    r50100 r53151  
    5050
    5151set docdir      ${prefix}/share/doc/${name}-${version}
     52
     53pre-extract {
     54    if {"darwin" == ${os.platform} && 8 == ${os.major}} {
     55        set minimum_xcodeversion 2.4.1
     56        set current_xcodeversion [exec defaults read /Developer/Applications/Xcode.app/Contents/Info CFBundleShortVersionString]
     57        if {[rpm-vercomp ${current_xcodeversion} ${minimum_xcodeversion}] < 0} {
     58            ui_error "On Mac OS X ${macosx_version}, ${name} ${version} requires Xcode ${minimum_xcodeversion} or later but you have Xcode ${current_xcodeversion}."
     59            return -code error "incompatible Xcode version"
     60        }
     61    }
     62}
    5263
    5364post-configure {
Note: See TracChangeset for help on using the changeset viewer.