Changeset 53861


Ignore:
Timestamp:
Jul 15, 2009, 11:24:32 PM (10 years ago)
Author:
toby@…
Message:

nuke darwin 7 section

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/devel/libsdl/Portfile

    r53151 r53861  
    9999}
    100100
    101 platform darwin 7 {
    102     pre-fetch {
    103         set qt_header [open /System/Library/Frameworks/QuickTime.framework/Headers/QuickTime.h r]
    104 
    105         while {[gets $qt_header line] != -1} {
    106             if {[regexp {Version:} $line]} {
    107                 regexp {(\d+\.\d+(?:\.\d+))?$} $line qt_ver
    108 
    109                 if {[rpm-vercomp ${qt_ver} 7.0.3] > 0} {
    110                     ui_error ""
    111                     ui_error "Installation of libSDL is exiting because it believes you have"
    112                     ui_error "QuickTime version ${qt_ver} installed."
    113                     ui_error ""
    114                     ui_error "On Mac OS X 10.3/Xcode 1.5, you must have QuickTime 7.0.3 or lower if"
    115                     ui_error "you want to install the libSDL port."
    116                     ui_error ""
    117                     ui_error "If you actually have QuickTime 7.0.3 or below and you think you should not be"
    118                     ui_error "receiving this error message, you can report the problem here:"
    119                     ui_error "http://trac.macports.org/projects/macports/ticket/6533"
    120 
    121                     return -code 1 "${name} cannot build on Panther with QuickTime 7.0.4 or later."
    122                 }
    123 
    124                 break
    125             }
    126         }
    127 
    128         close $qt_header
    129     }
    130 }
    131 
    132101livecheck.check regex
    133102livecheck.url   ${homepage}download.php
Note: See TracChangeset for help on using the changeset viewer.