Changeset 53962


Ignore:
Timestamp:
Jul 17, 2009, 10:33:22 AM (10 years ago)
Author:
raimue@…
Message:

gnome/baobab:
Mark as deprecated and recommend gnome-utils instead, closes #20048

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/gnome/baobab/Portfile

    r35946 r53962  
    44
    55name            baobab
    6 version         2.4.2
     6version         0
     7epoch           1
    78categories      gnome
    89platforms       darwin
    9 maintainers     raimue
     10maintainers     nomaintainer
    1011
    11 description     Disk usage analyzer for GNOME
     12description     Disk usage analyzer for GNOME (deprecated port)
    1213long_description \
    1314                Baobab is a C/gtk+ application to analyse disk usage in any \
    14                 Gnome environment. Baobab can easily scan either the whole \
    15                 filesystem tree, or a specific user-requested directory branch \
    16                 (local or remote).
     15                Gnome environment. This application has been integrated into \
     16                the gnome-utils port.
    1717homepage        http://www.marzocca.net/linux/baobab.html
    1818
    19 master_sites    http://www.marzocca.net/linux/downloads/
    20 checksums       md5     5c99413e18a07b562fbfd7f8c707ae07 \
    21                 sha1    3236b8af640e385cc27de6814331b1ea5759e4cd \
    22                 rmd160  eaabdb4377dc656c8f32a7c604c517b96697b5d9
     19distfiles
    2320
    24 depends_build   bin:grep:grep \
    25                 bin:gawk:gawk
    26 depends_lib     port:libgtop \
    27                 port:gtk2 \
    28                 port:libglade2 \
    29                 port:gnome-vfs \
    30                 port:gconf \
    31                 port:libgnomeui \
    32                 port:gettext
    33 
    34 configure.args  --mandir=${prefix}/share/man
    35 
    36 build.post_args baobab_LDFLAGS=''
    37 
    38 livecheck.check regex
    39 livecheck.regex {<li class="smalltext">v. ([0-9.]+)}
     21pre-configure {
     22    ui_warn "This application has been integrated into gnome-utils, this port will be removed soon."
     23    ui_msg "\nPlease use the following commands to switch to gnome-utils:
     24    sudo port uninstall baobab
     25    sudo port install gnome-utils
     26"
     27    return -code error "${name} is superseded by gnome-utils, please use that port instead."
     28}
Note: See TracChangeset for help on using the changeset viewer.