Changeset 54522


Ignore:
Timestamp:
Jul 29, 2009, 5:14:07 AM (9 years ago)
Author:
ryandesign@…
Message:

transmission-x11: +aqua presumably requires Leopard or later, not Leopard exactly; see #16738

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/net/transmission-x11/Portfile

    r54489 r54522  
    4545  configure.args-delete --disable-darwin
    4646  configure.args-append --enable-darwin
    47 }
    48 
    49 pre-fetch {
    50   if { [variant_isset aqua] } {
    51     set comparison [string  compare "${os.platform} ${os.major}" "darwin 9"]
    52     if {$comparison != 0} {
    53       return -code error "The aqua front-end only builds on Mac OS X Leopard (10.5.x). try the gtk variant"
     47  pre-fetch {
     48    if {"darwin" == ${os.platform} && ${os.major} < 9} {
     49      ui_error "${name} +aqua requires Mac OS X 10.5 or greater. Try the +gtk variant instead."
     50      return -code error "incompatible Mac OS X version"
    5451    }
    5552  }
Note: See TracChangeset for help on using the changeset viewer.