Changeset 55356


Ignore:
Timestamp:
Aug 9, 2009, 9:22:35 PM (9 years ago)
Author:
blb@…
Message:

graphics/librsvg - make sure to use a MacPorts python that is less than 3.0; ticket #19442

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/graphics/librsvg/Portfile

    r53912 r55356  
    77name            librsvg
    88version         2.26.0
     9revision        1
    910set branch      [join [lrange [split ${version} .] 0 1] .]
    1011categories      graphics gnome
     
    2829                port:libart_lgpl \
    2930                port:libxml2
     31depends_run     port:python26
    3032
    3133configure.args  --enable-pixbuf-loader \
    3234                --with-svgz \
    3335                --disable-mozilla-plugin
     36
     37post-destroot {
     38    set python.branch 2.6
     39    set python.bin ${frameworks_dir}/Python.framework/Versions/${python.branch}/bin/python${python.branch}
     40    reinplace "s|^#!/usr/bin/env python|#!${python.bin}|g" \
     41        ${destroot}${prefix}/bin/rsvg
     42}
    3443
    3544post-activate {
Note: See TracChangeset for help on using the changeset viewer.