Changeset 58202


Ignore:
Timestamp:
Sep 24, 2009, 1:20:59 AM (10 years ago)
Author:
ryandesign@…
Message:

spawn-fcgi: advise the user to deactivate their existing lighttpd <= 1.4.22 before installing this port; see #21586

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/www/spawn-fcgi/Portfile

    r58197 r58202  
    2222use_parallel_build  yes
    2323
     24pre-extract {
     25    # As of version 1.4.23, the lighttpd port depends on the spawn-fcgi port,
     26    # but lighttpd 1.4.22 and earlier provided the same files spawn-fcgi now
     27    # installs. If lighttpd 1.4.22 or earlier is installed and the user \
     28    # upgrades to 1.4.23, spawn-fcgi will be installed first, which would cause
     29    # a conflict on these files at activation time. Therefore tell the user to
     30    # first deactivate their old lighttpd.
     31    # Note: lighttpd.1 is only installed by lighttpd 1.4.22 and earlier. In
     32    # lighttpd 1.4.23 the manpage was moved to lighttpd.8.
     33    if {[file exists ${prefix}/share/man/man1/lighttpd.1.gz]} {
     34        return -code error "Please deactivate your currently-installed lighttpd port, then try again"
     35    }
     36}
     37
    2438post-destroot {
    2539    set docdir ${destroot}${prefix}/share/doc/${name}
Note: See TracChangeset for help on using the changeset viewer.