Ignore:
Timestamp:
Oct 18, 2009, 12:57:15 PM (9 years ago)
Author:
jmr@…
Message:

libsdl: new snapshot, use xcodeversion group

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/devel/libsdl/Portfile

    r58478 r59641  
    44PortSystem 1.0
    55PortGroup muniversal 1.0
     6PortGroup xcodeversion 1.0
    67
    78conflicts       libsdl-devel
     
    1011set my_name     SDL
    1112version         1.2.14
    12 revision        6
     13revision        7
    1314categories      devel multimedia
    1415platforms       macosx freebsd
     
    2425
    2526homepage        http://www.libsdl.org/
    26 master_sites    macports_distfiles
     27master_sites    http://www.libsdl.org/tmp/
     28#master_sites    macports_distfiles
    2729dist_subdir     ${name}/${version}_${revision}
    2830distname        ${my_name}-${version}
    2931
    30 checksums           md5     28cc68d02952290c256ef1fc2fa74050 \
    31                     sha1    3364d81b755f29292dcae01f5f7fc24cfd8e5fdb \
    32                     rmd160  ea4e3afc48f61be5cba10d64e9687466002c0071
     32checksums           md5     b97acc1a1e96b6545e6a111de3ba769e \
     33                    sha1    1cd713ab15b4f9985152be18bb22df660a12dc58 \
     34                    rmd160  371bd417453ec4e09e4edf63551916f176d5bb21
    3335
    3436depends_lib \
     
    3638    port:xorg-libXrandr \
    3739    port:xrender
     40
     41minimum_xcodeversions {8 2.4.1}
    3842
    3943patchfiles      patch-SDL_x11gl_c.h.diff
     
    4549
    4650variant no_x11 {
     51        configure.args-delete --x-include=${prefix}/include \
     52                              --x-lib=${prefix}/lib
    4753        configure.args-append --without-x
    4854        depends_lib-delete \
     
    5561
    5662set docdir      ${prefix}/share/doc/${name}-${version}
    57 
    58 pre-extract {
    59     if {"darwin" == ${os.platform} && 8 == ${os.major}} {
    60         set minimum_xcodeversion 2.4.1
    61         set current_xcodeversion [exec defaults read /Developer/Applications/Xcode.app/Contents/Info CFBundleShortVersionString]
    62         if {[rpm-vercomp ${current_xcodeversion} ${minimum_xcodeversion}] < 0} {
    63             ui_error "On Mac OS X ${macosx_version}, ${name} ${version} requires Xcode ${minimum_xcodeversion} or later but you have Xcode ${current_xcodeversion}."
    64             return -code error "incompatible Xcode version"
    65         }
    66     }
    67 }
    6863
    6964post-configure {
Note: See TracChangeset for help on using the changeset viewer.