Changeset 61154


Ignore:
Timestamp:
Dec 3, 2009, 8:46:11 AM (10 years ago)
Author:
nox@…
Message:

Add Snow Leopard support to jakarta-taglibs-standard-11 (#22736)

jakarta-taglibs-standard-11 requires JDK 1.5 and cannot compile with
JDK 1.6, complaining that some abstract methods are not defined
in concrete classes. patch-JDK-1.6.diff fixes that.

Location:
trunk/dports/java/jakarta-taglibs-standard-11
Files:
2 added
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/java/jakarta-taglibs-standard-11/Portfile

    r35275 r61154  
    1515                                        to the JSP JSTL 1.1 specification. Requires a JSP 2.0 \
    1616                                        compatible web container, such as Tomcat5.
    17 homepage                        http://jakarta.apache.org/taglibs/doc/standard-doc/
     17homepage                        http://tomcat.apache.org/taglibs/standard/
    1818
    1919distname                        jakarta-taglibs-standard-${version}-src
     
    6262destroot {
    6363        # Ensure needed directories
    64         xinstall -m 755 -d \
     64        xinstall -d \
    6565                ${destroot}${prefix}/share/java \
    6666                ${destroot}${prefix}/share/doc \
     
    8484                ${destroot}${prefix}/share/examples/${name}     
    8585}
     86
     87platform darwin 10 {
     88        patchfiles-append patch-JDK-1.6.diff
     89}
Note: See TracChangeset for help on using the changeset viewer.