Changeset 61942


Ignore:
Timestamp:
Dec 24, 2009, 3:22:38 PM (10 years ago)
Author:
macsforever2000@…
Message:

Fix for Leopard. (#23007)

Location:
trunk/dports/fuse/macfuse
Files:
1 added
5 deleted
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/fuse/macfuse/Portfile

    r61907 r61942  
    3333                    patch-sdk-objc_GMUserFileSystem.m.diff \
    3434                    patch-sdk-objc_MacFuse.xcodeproj.diff \
    35                     patch-10.4_libfuse_fuse-2.7.3-macosx.patch.diff \
     35                    patch-10.5_fusefs_fusefs.xcodeproj_project.pbxproj.diff \
    3636                    patch-10.5_libfuse_fuse-2.7.3-macosx.patch.diff \
    3737                    patch-10.6_libfuse_fuse-2.7.3-macosx.patch.diff
     
    4747}
    4848
    49 # ensure that user is running OS X 10.4 or higher
     49# ensure that user is running OS X 10.5 or higher: MacFUSE requires XCode 3
    5050pre-fetch {
    51     if {${os.platform} != "darwin" || [rpm-vercomp ${os.version} 8.0.0] < 0} {
    52         return -code error "MacFUSE requires at least Mac OS X 10.4 to run"
     51    if {${os.platform} != "darwin" || [rpm-vercomp ${os.version} 9.0.0] < 0} {
     52        return -code error "MacFUSE requires at least Mac OS X 10.5 to build"
    5353    }
    5454}
     
    6565    reinplace s,/usr/local,${prefix},g ${worksrcpath}/macfuse_buildtool.sh
    6666    reinplace s,/usr/local,${prefix},g ${worksrcpath}/sdk-objc/MacFUSE.xcodeproj/project.pbxproj
     67    reinplace s,@@PREFIX@@,${prefix},g ${worksrcpath}/10.5/libfuse/fuse-2.7.3-macosx.patch
    6768    reinplace s,@@PREFIX@@,${prefix},g ${worksrcpath}/10.6/libfuse/fuse-2.7.3-macosx.patch
    6869    reinplace s,@@WORKPATH@@,${workpath},g ${worksrcpath}/macfuse_buildtool.sh
Note: See TracChangeset for help on using the changeset viewer.