Ignore:
Timestamp:
Jun 14, 2010, 1:33:20 PM (7 years ago)
Author:
ryandesign@…
Message:

cairo, cairo-devel: use xcodeversion portgroup

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/graphics/cairo-devel/Portfile

    r68810 r68811  
    44PortGroup                   muniversal 1.0
    55PortGroup                   archcheck 1.0
     6PortGroup                   xcodeversion 1.0
    67
    78name                        cairo-devel
     
    4849                            lib/libexpat.dylib
    4950
     51minimum_xcodeversions       {8 2.4.1}
     52
    5053pre-configure {
    51     if {"darwin" == ${os.platform} && 8 == ${os.major}} {
    52         set minimum_xcodeversion 2.4.1
    53         set current_xcodeversion [exec defaults read /Developer/Applications/Xcode.app/Contents/Info CFBundleShortVersionString]
    54         if {[rpm-vercomp ${current_xcodeversion} ${minimum_xcodeversion}] < 0} {
    55             ui_error "On Mac OS X ${macosx_version}, ${name} ${version} requires Xcode ${minimum_xcodeversion} or later but you have Xcode ${current_xcodeversion}."
    56             return -code error "incompatible Xcode version"
    57         }
    58     }
    5954    set pixman_minimum_version 0.12.0
    6055    set pixman_installed_version [exec pkg-config pixman-1 --modversion]
Note: See TracChangeset for help on using the changeset viewer.