Ignore:
Timestamp:
Aug 6, 2010, 2:17:27 AM (9 years ago)
Author:
ryandesign@…
Message:

php5extension-1.0.tcl: only require bundled extensions to match the PHP branch version, not the entire PHP version; see #25789

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/_resources/port1.0/group/php5extension-1.0.tcl

    r63197 r70327  
    191191        pre-configure {
    192192            set php_version [exec ${prefix}/bin/php-config --version]
    193             if {${version} != ${php_version}} {
    194                 ui_error "${name} ${version} requires PHP ${version} but you have PHP ${php_version}."
     193            set php_branch [join [lrange [split ${php_version} .] 0 1] .]
     194            set port_branch [join [lrange [split ${version} .] 0 1] .]
     195            if {${port_branch} != ${php_branch}} {
     196                ui_error "${name} ${version} requires PHP ${port_branch}.x but you have PHP ${php_version}."
    195197                return -code error "incompatible PHP installation"
    196198            }
Note: See TracChangeset for help on using the changeset viewer.