Ignore:
Timestamp:
Aug 19, 2010, 2:42:40 PM (7 years ago)
Author:
kimuraw@…
Message:

lang/ruby19: upgrade to 1.9.2-p0

[NOTE] "lib/ruby/" path was changed from 1.9.2-p0.

1.9.1 - lib/ruby1.9/ (-nosuffix)
1.9.2 - lib/ruby/ (+-nosuffix)

we might need to reinstall port:rb19-*.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/lang/ruby19/Portfile

    r70658 r70729  
    44
    55name                            ruby19
    6 version                         1.9.1-p430
     6version                         1.9.2-p0
    77revision                        0
    88
     
    2626distname                        ruby-${version}
    2727
    28 checksums                       md5 f855103aebeb3318dccb409319b547a0 \
    29                                         rmd160 fe2afc89ea23a159536bb70345a60acb9043b930 \
    30                                         sha1 a92cf87d633817cf2aabae42f8ede2f61bd9ae3a
     28checksums                       md5 d8a02cadf57d2571cd4250e248ea7e4b \
     29                                        rmd160 dc15937c884b0f93863e9871304bae95e1233e15 \
     30                                        sha1 c0fc7e1047f1eac7e554e9818513593b0d398698
    3131use_parallel_build      yes
    3232
     
    3535                                        port:openssl \
    3636                                        port:zlib \
    37                                         port:ncurses
     37                                        port:ncurses \
     38                                        port:libyaml
    3839
    3940configure.args          --enable-shared \
     
    4243                                        --without-tk \
    4344                                        --program-suffix=1.9
    44 # [ruby-core:29427]: on some Mac, TCPServer.open("localhost", 0) raises
    45 #         SocketError "getaddrinfo: nodename nor servname provided, or not
    46 #         known (SocketError)"
    47 #         http://redmine.ruby-lang.org/issues/show/3124
    48 #         (note: 1.9.2 does not need this patch)
    49 # #25611: build failure with openssl 1.0.0
    50 #         patch from http://redmine.ruby-lang.org/issues/show/2022
    51 #         (note: 1.9.2 does not need this patch)
    52 patchfiles                      patch-ruby_core_29427.diff \
    53                                         patch-bug25611.diff
    5445
    5546# Ignore minor version for archdir, like i686-darwin9.
     
    5849
    5950post-destroot {
     51        # [NOTE] "lib/ruby/" path was changed from 1.9.2-p0
     52        #     1.9.1 - lib/ruby1.9/ (-nosuffix)
     53        #     1.9.2 - lib/ruby/    (+-nosuffix)
    6054        foreach type {site vendor} {
    61                         set libdir ${destroot}${prefix}/lib/ruby1.9/${type}_ruby
     55                        set libdir ${destroot}${prefix}/lib/ruby/${type}_ruby/1.9.1
    6256                        xinstall -m 0755 -d ${libdir}
    6357                        xinstall -m 0644 ${filespath}/${type}-specific.rb ${libdir}
Note: See TracChangeset for help on using the changeset viewer.