Changeset 71991


Ignore:
Timestamp:
Sep 29, 2010, 4:14:06 PM (10 years ago)
Author:
kimuraw@…
Message:

ruby/rb-rabbit: upgrade to 0.9.0

Location:
trunk/dports/ruby/rb-rabbit
Files:
2 added
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/ruby/rb-rabbit/Portfile

    r70583 r71991  
    44PortGroup               ruby 1.0
    55
    6 ruby.setup              rabbit 0.6.5 setup.rb {README.en sample misc}
     6ruby.setup              rabbit 0.9.0 setup.rb {README.en sample misc}
    77revision                0
    88maintainers             kimuraw
     
    2828depends_lib-append      port:rb-tweetstream port:rb-password
    2929
     30# disable source rwiki to avoid crash with openssl-1.0.0.
     31# port:glib2 is linking /usr/lib/libcrypto.0.9.8.dylib via Carbon.framework.
     32# ruby is a flat namespace program. We face problems wheh ruby loads both of
     33# libcrypto.0.9.8.dylib from MacOSX and libcrypto.1.0.0.dylib from MacPorts.
     34patchfiles                      patch-lib-rabbit-source-rwiki.rb.diff
     35
    3036post-build {
    3137        reinplace "s|^#!.*ruby|#!${ruby.bin}|" \
     
    3541                ${worksrcpath}/bin/rabrick \
    3642                ${worksrcpath}/bin/rabbirc \
    37                 ${worksrcpath}/bin/rabbitter
     43                ${worksrcpath}/bin/rabbiter
    3844}
    3945post-destroot {
     
    4248
    4349master_sites    http://www.cozmixng.org/~kou/download/
    44 checksums               md5 9d2122bdae51afa3c34f7e7406c4e2ce \
    45                                 rmd160 c7acf78ea025dc65d4e78ed94971c3fe130413b9 \
    46                                 sha1 8533d55a3ae51a05360cd2fc73cf4f80d814c969
     50checksums               md5 09a7acdf58cfbcbe47cdd2e9bc573954 \
     51                                rmd160 845c825e2d1db3a94533616d9657aa7dcadcaea1 \
     52                                sha1 da4734ac42c1c0b68ef623eb2740dcf66cd22b30
    4753
    4854livecheck.type  regex
Note: See TracChangeset for help on using the changeset viewer.