Ignore:
Timestamp:
Nov 4, 2010, 6:11:53 AM (7 years ago)
Author:
elelay@…
Message:

use supported_archs i386 ppc instead of setting configure.arch manually

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/aqua/Growl/Portfile

    r73090 r73111  
    2929xcode.destroot.path     /destroot
    3030
     31# Common/Source/LoginItemAE.c uses Carbon so can't build x86_64
     32supported_archs         i386 ppc
     33
    3134post-patch {
    3235        reinplace "s|REVISION=.*|REVISION=116|g" ${worksrcpath}/generateHgRevision.sh
     
    4447# in any case.
    4548
     49# the 10.4 SDK might not be installed, use the system's default
    4650platform darwin 10 {
    47         # Common/Source/LoginItemAE.c uses Carbon so can't build x86_64
    48         if {![variant_isset universal]} {
    49                 configure.build_arch    i386
    50         }
    51        
    52         # the 10.4 SDK might not be installed, use the system's default
    5351        patchfiles-append patch-Growl.xcodeproj__project.pbxproj.no-10.4sdk.diff
    5452}
    5553
     54# disables separate strip
    5655platform darwin 8 {
    5756        patchfiles-append patch-Growl.xcodeproj__project.pbxproj.no_separate_strip.diff
Note: See TracChangeset for help on using the changeset viewer.