Changeset 77665


Ignore:
Timestamp:
Apr 8, 2011, 6:39:26 AM (10 years ago)
Author:
ryandesign@…
Message:

dcraw: remove code designed to ease the upgrade from ufraw 0.15 to 0.16 15 months ago; see #29048

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/graphics/dcraw/Portfile

    r77536 r77665  
    5050}
    5151
    52 pre-configure {
    53     # ufraw 0.15 and earlier provided its own copy of dcraw, but 0.16 now
    54     # depends on the dcraw port instead. To prevent activation conflicts
    55     # when upgrading to ufraw 0.16, ensure an old dcraw-providing ufraw
    56     # is not active.
    57     if {[file exists ${prefix}/bin/ufraw]} {
    58         ui_debug "ufraw is installed; determining version"
    59         set ufraw_minimum_version 0.16
    60         set ufraw_installed_version [exec ${prefix}/bin/msgunfmt ${prefix}/share/locale/de/LC_MESSAGES/ufraw.mo | sed -E -n s/^.*Project-Id-Version:\ \(\[0-9.\]+\).*\$/\\1/p]
    61         if {[rpm-vercomp ${ufraw_installed_version} ${ufraw_minimum_version}] < 0} {
    62             ui_debug "ufraw ${ufraw_installed_version} is installed; needs to be deactivated first"
    63             return -code error "Please deactivate your currently-installed ufraw port, then try again"
    64         } else {
    65             ui_debug "ufraw ${ufraw_installed_version} is installed; ok"
    66         }
    67     } else {
    68         ui_debug "ufraw is not installed; ok"
    69     }
    70 }
    71 
    7252pre-build {
    7353    build.args          CC=${configure.cc} \
Note: See TracChangeset for help on using the changeset viewer.