Ignore:
Timestamp:
Jul 3, 2011, 5:32:44 PM (6 years ago)
Author:
jeremyhu@…
Message:

telepathy-gabble: Add variants to choose python25, python26, or python27

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/comms/telepathy-gabble/Portfile

    r77780 r80064  
    66name            telepathy-gabble
    77version         0.10.5
     8revision        1
    89set branch      [join [lrange [split ${version} .] 0 1] .]
    910description     The ${name} component of Telepathy - a Flexible Communications Framework
     
    2627depends_lib     port:telepathy-glib \
    2728                port:libxslt \
    28                 port:py26-twisted \
    2929                port:libsoup \
    3030                port:libnice \
     
    3333patchfiles      patch-configure.diff
    3434
    35 configure.python ${prefix}/bin/python2.6
     35configure.args  --disable-silent-rules
    3636
    37 configure.args  --disable-silent-rules
     37variant python25 conflicts python26 python27 description {Use python 2.5} {
     38    configure.python          ${prefix}/bin/python2.5
     39    depends_lib-append        port:py25-twisted
     40}
     41
     42variant python26 conflicts python25 python27 description {Use python 2.6} {
     43    configure.python          ${prefix}/bin/python2.6
     44    depends_lib-append        port:py26-twisted
     45}
     46
     47variant python27 conflicts python25 python26 description {Use python 2.7} {
     48    configure.python          ${prefix}/bin/python2.7
     49    depends_lib-append        port:py27-twisted
     50}
     51
     52if {![variant_isset python25] && ![variant_isset python26]} {
     53    default_variants +python27
     54}
    3855
    3956livecheck.type  regex
Note: See TracChangeset for help on using the changeset viewer.