Changeset 80086 for trunk/dports/comms


Ignore:
Timestamp:
Jul 4, 2011, 12:22:10 AM (8 years ago)
Author:
jeremyhu@…
Message:

telepathy-mission-control: Add variants to choose between python versions (2.5, 2.6, and 2.7)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/comms/telepathy-mission-control/Portfile

    r73628 r80086  
    66name            telepathy-mission-control
    77version         5.6.1
     8revision        1
    89categories      comms
    910maintainers     devans openmaintainer
     
    2829
    2930depends_lib     port:telepathy-glib \
    30                 port:libgnome-keyring \
    31                 port:python26
     31                port:libgnome-keyring
    3232
    3333patchfiles      patch-configure.diff
    3434
    35 configure.python ${prefix}/bin/python2.6
     35variant python26 conflicts python27 description {Use python 2.6} {
     36    configure.python          ${prefix}/bin/python2.6
     37    depends_lib-append        port:python26
     38}
     39
     40variant python27 conflicts python26 description {Use python 2.7} {
     41    configure.python          ${prefix}/bin/python2.7
     42    depends_lib-append        port:python27
     43}
     44
     45if {![variant_isset python25] && ![variant_isset python26]} {
     46    default_variants +python27
     47}
    3648
    3749configure.args  --enable-gnome-keyring
Note: See TracChangeset for help on using the changeset viewer.