Ignore:
Timestamp:
Aug 24, 2011, 10:56:08 PM (9 years ago)
Author:
raimue@…
Message:

editors/vim, editors/vim-app, editors/MacVim:
Allow use of python 2.x and 3.x at the same time.
Add +python32 variant.

Location:
trunk/dports/editors/MacVim
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/editors/MacVim/Portfile

    r82743 r83056  
    88set gitcommit       snapshot-${snapshot}
    99version             ${vim_version}.snapshot${snapshot}
     10revision            1
    1011categories          editors
    1112platforms           darwin
     
    9798}
    9899variant python requires python25 description {Compatibility variant, requires +python25} {}
    99 variant python25 conflicts python26 python27 python31 description {Enable Python scripting} {
     100variant python25 conflicts python26 python27 description {Enable Python scripting} {
    100101    configure.args-append   --enable-pythoninterp --with-python=${prefix}/bin/python2.5
    101102    patchfiles-append       patch-python.diff
     
    104105    use_autoconf yes
    105106}
    106 variant python26 conflicts python25 python27 python31 description {Enable Python scripting} {
     107variant python26 conflicts python25 python27 description {Enable Python scripting} {
    107108    configure.args-append   --enable-pythoninterp --with-python=${prefix}/bin/python2.6
    108109    patchfiles-append       patch-python.diff
     
    111112    use_autoconf yes
    112113}
    113 variant python27 conflicts python25 python26 python31 description {Enable Python scripting} {
     114variant python27 conflicts python25 python26 description {Enable Python scripting} {
    114115    configure.args-append   --enable-pythoninterp --with-python=${prefix}/bin/python2.7
    115116    patchfiles-append       patch-python.diff
     
    118119    use_autoconf yes
    119120}
    120 variant python31 conflicts python25 python26 python27 description {Enable Python scripting} {
    121     configure.args-append   --enable-python3interp --with-python=${prefix}/bin/python3.1
     121variant python31 conflicts python32 description {Enable Python scripting} {
     122    configure.args-append   --enable-python3interp --with-python3=${prefix}/bin/python3.1
    122123    patchfiles-append       patch-python3.diff
    123124    depends_lib-append      port:python31
    124125
    125126    use_autoconf yes
     127}
     128variant python32 conflicts python31 description {Enable Python scripting} {
     129    configure.args-append   --enable-python3interp --with-python3=${prefix}/bin/python3.2
     130    patchfiles-append       patch-python3.diff
     131    depends_lib-append      port:python32
     132
     133    use_autoconf yes
     134    # Overwriting autoconf.cmd above removes dependency, add it again
     135    depends_build-append port:autoconf
    126136}
    127137variant ruby description {Enable Ruby scripting} {
  • trunk/dports/editors/MacVim/files/patch-python3.diff

    r70950 r83056  
    66   dnl -- find the python3 executable
    77-  AC_PATH_PROG(vi_cv_path_python3, python3)
    8 +  AC_MSG_CHECKING(--with-python argument)
    9 +  AC_ARG_WITH(python, [  --with-python=PATH       which python to use (default: python)],
     8+  AC_MSG_CHECKING(--with-python3 argument)
     9+  AC_ARG_WITH(python3, [  --with-python3=PATH       which python to use (default: python3)],
    1010+        python_name="$withval"; AC_MSG_RESULT($python_name),
    11 +        python_name="python"; AC_MSG_RESULT(no))
    12 +  AC_SUBST(vi_cv_path_python, $python_name)
     11+        python_name="python3"; AC_MSG_RESULT(no))
     12+  AC_SUBST(vi_cv_path_python3, $python_name)
    1313   if test "X$vi_cv_path_python3" != "X"; then
    1414 
Note: See TracChangeset for help on using the changeset viewer.