Changeset 86143 for trunk


Ignore:
Timestamp:
Oct 19, 2011, 10:00:08 PM (9 years ago)
Author:
raimue@…
Message:

editors/MacVim:
Force use of llvm-gcc-4.2 if clang has been selected due to runtime problems,
closes #30985.

Location:
trunk/dports/editors/MacVim
Files:
2 added
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/editors/MacVim/Portfile

    r83186 r86143  
    88set gitcommit       snapshot-${snapshot}
    99version             ${vim_version}.snapshot${snapshot}
    10 revision            2
     10revision            3
    1111categories          editors
    1212platforms           darwin
     
    3636patchfiles          patch-src-MacVim-icons-python.diff \
    3737                    patch-MMFullScreenWindow-case-sensitive.diff \
    38                     patch-reverse-7.3.245.diff
     38                    patch-reverse-7.3.245.diff \
     39                    patch-MacVim-GCC-VERSION.diff \
     40                    patch-PSMTabBarControl-GCC-VERSION.diff
    3941
    4042pre-fetch {
     
    4345        return -code error "incompatible Mac OS X version"
    4446    }
     47}
     48
     49# does not run correctly when build with clang, see #30985
     50if {${configure.compiler} == "clang"} {
     51    configure.compiler llvm-gcc-4.2
    4552}
    4653
Note: See TracChangeset for help on using the changeset viewer.