Ignore:
Timestamp:
Nov 8, 2011, 3:09:27 AM (9 years ago)
Author:
singingwolfboy@…
Message:

iTerm2: switched to Github development, updated to v1.0.0.20111009, disabled Sparkle autoupdated. Refs #31906

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/aqua/iTerm2/Portfile

    r85068 r87017  
    55
    66name        iTerm2
    7 version     1.0.0
    8 set svn_tag v[string map {. _} $version]
     7version     1.0.0.20111009
    98categories  aqua shells
    109maintainers singingwolfboy openmaintainer
     
    1615    that make your life better.
    1716
    18 homepage    http://www.iterm2.com/
     17homepage        http://www.iterm2.com/
     18master_sites    https://github.com/gnachman/iTerm2/tarball/v${version}
    1919
    20 fetch.type  svn
    21 svn.url     https://iterm2.googlecode.com/svn/tags/${svn_tag}
    22 worksrcdir  ${svn_tag}
     20checksums       sha256  eec7c99158357721ddfb23e5050af1108fdbafa478c8bae9da646d48b503a9e2 \
     21                rmd160  70fe3448711c3edbe33ead016061c088b217250f
     22
     23# needed by dated libcurl on Leopard (and probably Tiger)
     24fetch.ignore_sslcert yes
    2325
    2426xcode.project   iTerm.xcodeproj
    2527xcode.target    iTerm
     28
     29use_configure   yes
     30configure {
     31    # disable Sparkle autoupdate
     32    reinplace "s|.*Sparkle.*||g" ${worksrcpath}/${xcode.project}/project.pbxproj
     33}
     34
     35post-extract {
     36    move [glob ${workpath}/*] ${worksrcpath}
     37    reinplace "s|^version *= *.*$|version = \"${version}\"|" ${worksrcpath}/updateVersion.py
     38}
    2639
    2740destroot {
Note: See TracChangeset for help on using the changeset viewer.