Changeset 89810


Ignore:
Timestamp:
Feb 11, 2012, 8:55:39 AM (8 years ago)
Author:
and.damore@…
Message:

ports: replacing rpm-vercomp with vercmp in portfiles

Location:
trunk/dports
Files:
46 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/aqua/FScript/Portfile

    r84550 r89810  
    4444xcode.destroot.type     ""
    4545
    46 set is_xcode_4_x [expr [rpm-vercomp $xcodeversion 4] >= 0]
     46set is_xcode_4_x [expr [vercmp $xcodeversion 4] >= 0]
    4747
    4848if !$is_xcode_4_x {
  • trunk/dports/cross/i960-rtems-binutils/Portfile

    r72086 r89810  
    130130# This target has been abandonned upstream.
    131131pre-fetch {
    132         if {${os.platform} == "darwin" && [rpm-vercomp 9.0 ${os.version}] < 0} {
     132        if {${os.platform} == "darwin" && [vercmp 9.0 ${os.version}] < 0} {
    133133                ui_warn "i960-rtems-gcc does not build on darwin 9+ (Mac OS X 10.5+) and it has been abandonned upstream."
    134134        }
  • trunk/dports/cross/i960-rtems-gcc/Portfile

    r72086 r89810  
    204204# This target has been abandonned upstream.
    205205pre-fetch {
    206         if {${os.platform} == "darwin" && [rpm-vercomp 9.0 ${os.version}] < 0} {
     206        if {${os.platform} == "darwin" && [vercmp 9.0 ${os.version}] < 0} {
    207207                error "This port does not build on darwin 9+ (Mac OS X 10.5+) and it has been abandonned upstream."
    208208        }
  • trunk/dports/devel/gmp/Portfile

    r86158 r89810  
    4242# llvm-gcc-4.2 fails make check
    4343if {${configure.compiler} == "llvm-gcc-4.2"} {
    44     if {[rpm-vercomp $xcodeversion 4.1] >= 0} {
     44    if {[vercmp $xcodeversion 4.1] >= 0} {
    4545        configure.compiler clang
    4646    } else {
  • trunk/dports/devel/valgrind-devel/Portfile

    r89015 r89810  
    5252# Force gcc, see https://bugs.kde.org/show_bug.cgi?id=275168
    5353if {![string match "gcc*" ${configure.compiler}]} {
    54     if {[rpm-vercomp $xcodeversion 3.2] >= 0 && $macosx_deployment_target != "10.4"} {
     54    if {[vercmp $xcodeversion 3.2] >= 0 && $macosx_deployment_target != "10.4"} {
    5555        configure.compiler gcc-4.2
    5656    } else {
  • trunk/dports/fuse/macfuse/Portfile

    r83484 r89810  
    6868# ensure that user is running OS X 10.5 or higher: MacFUSE requires XCode 3
    6969pre-fetch {
    70     if {${os.platform} != "darwin" || [rpm-vercomp ${os.version} 9.0.0] < 0} {
     70    if {${os.platform} != "darwin" || [vercmp ${os.version} 9.0.0] < 0} {
    7171        return -code error "MacFUSE requires at least Mac OS X 10.5 to build"
    7272    }
  • trunk/dports/gnome/atkmm/Portfile

    r86479 r89810  
    3333    if { [file exists ${prefix}/lib/pkgconfig/atkmm-1.6.pc]
    3434        && ![catch {set vers [lindex [registry_active gtkmm] 0]}]
    35         && [rpm-vercomp [lindex $vers 1] 2.22.0] < 0} {
     35        && [vercmp [lindex $vers 1] 2.22.0] < 0} {
    3636       
    3737        set deactivate_proc registry_deactivate_composite
  • trunk/dports/graphics/gdk-pixbuf2/Portfile

    r87587 r89810  
    3838    if { [file exists ${prefix}/lib/pkgconfig/gdk-pixbuf-2.0.pc]
    3939        && ![catch {set vers [lindex [registry_active gtk2] 0]}]
    40         && [rpm-vercomp [lindex $vers 1] 2.22.0] < 0} {
     40        && [vercmp [lindex $vers 1] 2.22.0] < 0} {
    4141       
    4242        set deactivate_proc registry_deactivate_composite
  • trunk/dports/graphics/minidjvu/Portfile

    r72348 r89810  
    2727
    2828patchfiles                      patch-Makefile.in.diff
    29 if {${os.platform} == "darwin" && [rpm-vercomp ${os.version} 10] < 0} {
     29if {${os.platform} == "darwin" && [vercmp ${os.version} 10] < 0} {
    3030    patchfiles-append           patch-configure.ac.diff
    3131    use_autoconf                yes
  • trunk/dports/java/tomcat5/Portfile

    r81450 r89810  
    101101                set verOutput [exec ant -version]
    102102                regexp {version (\d+(\.\d+)*)} $verOutput -> antVersion
    103                 if { [rpm-vercomp $antVersion "1.6.2"] < 0 } {
     103                if { [vercmp $antVersion "1.6.2"] < 0 } {
    104104                        return -code error "This version of tomcat requires ant version 1.6.2 or better. Please install a newer ant before proceeding."
    105105                }
  • trunk/dports/java/tomcat6/Portfile

    r84550 r89810  
    103103                set verOutput [exec ant -version]
    104104                regexp {version (\d+(\.\d+)*)} $verOutput -> antVersion
    105                 if { [rpm-vercomp $antVersion "1.6.5"] < 0 } {
     105                if { [vercmp $antVersion "1.6.5"] < 0 } {
    106106                        return -code error "This version of tomcat requires ant version 1.6.5 or better. Please install a newer ant before proceeding."
    107107                }
  • trunk/dports/kde/kdelibs4/Portfile

    r89388 r89810  
    8383    if {[file exists ${prefix}/share/locale/en_US/entry.desktop]
    8484        && ![catch {set vers [lindex [registry_active kde4-runtime] 0]}]
    85         && [rpm-vercomp [lindex $vers 1] 4.6.0] < 0} {
     85        && [vercmp [lindex $vers 1] 4.6.0] < 0} {
    8686        set deactivate_proc registry_deactivate_composite
    8787        if {[info commands registry_deactivate_composite] == {}} {
  • trunk/dports/lang/ghc/Portfile

    r89315 r89810  
    124124                        set minimum_xcodeversion 2.5
    125125                        set current_xcodeversion [exec defaults read /Developer/Applications/Xcode.app/Contents/Info CFBundleShortVersionString]
    126                         if {[rpm-vercomp ${current_xcodeversion} ${minimum_xcodeversion}] < 0} {
     126                        if {[vercmp ${current_xcodeversion} ${minimum_xcodeversion}] < 0} {
    127127                                ui_msg "On Mac OS X ${macosx_version}, ${name} ${version} requires Xcode ${minimum_xcodeversion} but you have Xcode ${current_xcodeversion}."
    128128                                return -code error "incompatible Xcode version"
     
    150150                        set minimum_xcodeversion 2.5
    151151                        set current_xcodeversion [exec defaults read /Developer/Applications/Xcode.app/Contents/Info CFBundleShortVersionString]
    152                         if {[rpm-vercomp ${current_xcodeversion} ${minimum_xcodeversion}] < 0} {
     152                        if {[vercmp ${current_xcodeversion} ${minimum_xcodeversion}] < 0} {
    153153                                ui_msg "On Mac OS X ${macosx_version}, ${name} ${version} requires Xcode ${minimum_xcodeversion} but you have Xcode ${current_xcodeversion}."
    154154                                return -code error "incompatible Xcode version"
     
    178178                        set minimum_xcodeversion 3.1.2
    179179                        set current_xcodeversion [exec defaults read /Developer/Applications/Xcode.app/Contents/Info CFBundleShortVersionString]
    180                         if {[rpm-vercomp ${current_xcodeversion} ${minimum_xcodeversion}] < 0} {
     180                        if {[vercmp ${current_xcodeversion} ${minimum_xcodeversion}] < 0} {
    181181                                ui_msg "On Mac OS X ${macosx_version}, ${name} ${version} requires Xcode ${minimum_xcodeversion} but you have Xcode ${current_xcodeversion}."
    182182                                return -code error "incompatible Xcode version"
     
    204204                        set minimum_xcodeversion 3.1
    205205                        set current_xcodeversion [exec defaults read /Developer/Applications/Xcode.app/Contents/Info CFBundleShortVersionString]
    206                         if {[rpm-vercomp ${current_xcodeversion} ${minimum_xcodeversion}] < 0} {
     206                        if {[vercmp ${current_xcodeversion} ${minimum_xcodeversion}] < 0} {
    207207                                ui_msg "On Mac OS X ${macosx_version}, ${name} ${version} requires Xcode ${minimum_xcodeversion} but you have Xcode ${current_xcodeversion}."
    208208                                return -code error "incompatible Xcode version"
  • trunk/dports/mail/cclient/Portfile

    r74864 r89810  
    7070}
    7171
    72 if {[rpm-vercomp ${os.version} 10] >= 0} {
     72if {[vercmp ${os.version} 10] >= 0} {
    7373    patchfiles-append patch-Makefile-fixpam
    7474}
  • trunk/dports/perl/p5-file-listing/Portfile

    r82547 r89810  
    2626    if {[file exists ${perl5.lib}/File/Listing.pm]
    2727      && ![catch {set vers [lindex [registry_active p5-libwww-perl] 0]}]
    28       && [rpm-vercomp [lindex $vers 1] 6.0] < 0} {
     28      && [vercmp [lindex $vers 1] 6.0] < 0} {
    2929        ui_warn "Deactivating old, pre-6.x libwww-perl to activate ${name}"
    3030        set deactivate_proc registry_deactivate_composite
  • trunk/dports/perl/p5-html-form/Portfile

    r82547 r89810  
    2828    if {[file exists ${perl5.lib}/HTML/Form.pm]
    2929      && ![catch {set vers [lindex [registry_active p5-libwww-perl] 0]}]
    30       && [rpm-vercomp [lindex $vers 1] 6.0] < 0} {
     30      && [vercmp [lindex $vers 1] 6.0] < 0} {
    3131        ui_warn "Deactivating old, pre-6.x libwww-perl to activate ${name}"
    3232        set deactivate_proc registry_deactivate_composite
  • trunk/dports/perl/p5-http-cookies/Portfile

    r82547 r89810  
    2727    if {[file exists ${perl5.lib}/HTTP/Cookies.pm]
    2828      && ![catch {set vers [lindex [registry_active p5-libwww-perl] 0]}]
    29       && [rpm-vercomp [lindex $vers 1] 6.0] < 0} {
     29      && [vercmp [lindex $vers 1] 6.0] < 0} {
    3030        ui_warn "Deactivating old, pre-6.x libwww-perl to activate ${name}"
    3131        set deactivate_proc registry_deactivate_composite
  • trunk/dports/perl/p5-http-daemon/Portfile

    r82547 r89810  
    2828    if {[file exists ${perl5.lib}/HTTP/Daemon.pm]
    2929      && ![catch {set vers [lindex [registry_active p5-libwww-perl] 0]}]
    30       && [rpm-vercomp [lindex $vers 1] 6.0] < 0} {
     30      && [vercmp [lindex $vers 1] 6.0] < 0} {
    3131        ui_warn "Deactivating old, pre-6.x libwww-perl to activate ${name}"
    3232        set deactivate_proc registry_deactivate_composite
  • trunk/dports/perl/p5-http-date/Portfile

    r82547 r89810  
    2626    if {[file exists ${perl5.lib}/HTTP/Date.pm]
    2727      && ![catch {set vers [lindex [registry_active p5-libwww-perl] 0]}]
    28       && [rpm-vercomp [lindex $vers 1] 6.0] < 0} {
     28      && [vercmp [lindex $vers 1] 6.0] < 0} {
    2929        ui_warn "Deactivating old, pre-6.x libwww-perl to activate ${name}"
    3030        set deactivate_proc registry_deactivate_composite
  • trunk/dports/perl/p5-http-message/Portfile

    r82547 r89810  
    3333    if {[file exists ${perl5.lib}/HTTP/Message.pm]
    3434      && ![catch {set vers [lindex [registry_active p5-libwww-perl] 0]}]
    35       && [rpm-vercomp [lindex $vers 1] 6.0] < 0} {
     35      && [vercmp [lindex $vers 1] 6.0] < 0} {
    3636        ui_warn "Deactivating old, pre-6.x libwww-perl to activate ${name}"
    3737        set deactivate_proc registry_deactivate_composite
  • trunk/dports/perl/p5-http-negotiate/Portfile

    r82547 r89810  
    2626    if {[file exists ${perl5.lib}/HTTP/Negotiate.pm]
    2727      && ![catch {set vers [lindex [registry_active p5-libwww-perl] 0]}]
    28       && [rpm-vercomp [lindex $vers 1] 6.0] < 0} {
     28      && [vercmp [lindex $vers 1] 6.0] < 0} {
    2929        ui_warn "Deactivating old, pre-6.x libwww-perl to activate ${name}"
    3030        set deactivate_proc registry_deactivate_composite
  • trunk/dports/perl/p5-lwp-mediatypes/Portfile

    r82547 r89810  
    2222    if {[file exists ${perl5.lib}/LWP/MediaTypes.pm]
    2323      && ![catch {set vers [lindex [registry_active p5-libwww-perl] 0]}]
    24       && [rpm-vercomp [lindex $vers 1] 6.0] < 0} {
     24      && [vercmp [lindex $vers 1] 6.0] < 0} {
    2525        ui_warn "Deactivating old, pre-6.x libwww-perl to activate ${name}"
    2626        set deactivate_proc registry_deactivate_composite
  • trunk/dports/perl/p5-lwp-protocol-http10/Portfile

    r82547 r89810  
    2626    if {[file exists ${perl5.lib}/LWP/Protocol/http10.pm]
    2727      && ![catch {set vers [lindex [registry_active p5-libwww-perl] 0]}]
    28       && [rpm-vercomp [lindex $vers 1] 6.0] < 0} {
     28      && [vercmp [lindex $vers 1] 6.0] < 0} {
    2929        ui_warn "Deactivating old, pre-6.x libwww-perl to activate ${name}"
    3030        set deactivate_proc registry_deactivate_composite
  • trunk/dports/perl/p5-lwp-protocol-https/Portfile

    r82547 r89810  
    3333    if {[file exists ${perl5.lib}/LWP/Protocol/https.pm]
    3434      && ![catch {set vers [lindex [registry_active p5-libwww-perl] 0]}]
    35       && [rpm-vercomp [lindex $vers 1] 6.0] < 0} {
     35      && [vercmp [lindex $vers 1] 6.0] < 0} {
    3636        ui_warn "Deactivating old, pre-6.x libwww-perl to activate ${name}"
    3737        set deactivate_proc registry_deactivate_composite
  • trunk/dports/perl/p5-net-http/Portfile

    r82547 r89810  
    2323    if {[file exists ${perl5.lib}/Net/HTTP.pm]
    2424      && ![catch {set vers [lindex [registry_active p5-libwww-perl] 0]}]
    25       && [rpm-vercomp [lindex $vers 1] 6.0] < 0} {
     25      && [vercmp [lindex $vers 1] 6.0] < 0} {
    2626        ui_warn "Deactivating old, pre-6.x libwww-perl to activate ${name}"
    2727        set deactivate_proc registry_deactivate_composite
  • trunk/dports/perl/p5-www-robotrules/Portfile

    r82547 r89810  
    2626    if {[file exists ${perl5.lib}/WWW/RobotRules.pm]
    2727      && ![catch {set vers [lindex [registry_active p5-libwww-perl] 0]}]
    28       && [rpm-vercomp [lindex $vers 1] 6.0] < 0} {
     28      && [vercmp [lindex $vers 1] 6.0] < 0} {
    2929        ui_warn "Deactivating old, pre-6.x libwww-perl to activate ${name}"
    3030        set deactivate_proc registry_deactivate_composite
  • trunk/dports/perl/p5-xml-sax-base/Portfile

    r87535 r89810  
    1919        # XML::SAX::Exception moved to this port from p5-xml-sax
    2020        if {![catch {set vers [lindex [registry_active p${perl5.major}-xml-sax] 0]}]
    21             && [rpm-vercomp [lindex $vers 1] 0.990] < 0} {
     21            && [vercmp [lindex $vers 1] 0.990] < 0} {
    2222            registry_deactivate_composite p${perl5.major}-xml-sax "" [list ports_nodepcheck 1]
    2323        }
  • trunk/dports/print/ghostscript/Portfile

    r82385 r89810  
    9797# gs compiled by clang/llvm-gcc-4.2 sometimes produces 'Segmentation fault: 11'
    9898#if {${configure.compiler} == "llvm-gcc-4.2"} {
    99 #    if {[rpm-vercomp $xcodeversion 4.1] >= 0} {
     99#    if {[vercmp $xcodeversion 4.1] >= 0} {
    100100#        configure.compiler clang
    101101#    } else {
  • trunk/dports/python/py-roman/Portfile

    r88422 r89810  
    3030        if {[file exists ${python.pkgd}/roman.py]
    3131            && ![catch {set vers [lindex [registry_active py${python.version}-docutils] 0]}]
    32             && [rpm-vercomp [lindex $vers 1] 0.6] < 0} {
     32            && [vercmp [lindex $vers 1] 0.6] < 0} {
    3333            set deactivate_proc registry_deactivate_composite
    3434            if {[info commands registry_deactivate_composite] == {}} {
  • trunk/dports/science/lalsimulation/Portfile

    r89107 r89810  
    4141  if {[file exists ${prefix}/include/lal/LALSimBurst.h]
    4242    && ![catch {set vers [lindex [registry_active lalburst] 0]}]
    43     && [rpm-vercomp [lindex $vers 1] 1.0.1] < 0} {
     43    && [vercmp [lindex $vers 1] 1.0.1] < 0} {
    4444      registry_deactivate lalburst "" [list ports_nodepcheck 1]
    4545  }
    4646  if {[file exists ${prefix}/include/lal/LALSimInspiral.h]
    4747    && ![catch {set vers [lindex [registry_active lalinspiral] 0]}]
    48     && [rpm-vercomp [lindex $vers 1] 1.1.0] < 0} {
     48    && [vercmp [lindex $vers 1] 1.1.0] < 0} {
    4949      registry_deactivate lalinspiral "" [list ports_nodepcheck 1]
    5050  }
  • trunk/dports/tex/dvipng/Portfile

    r83084 r89810  
    4141pre-activate {
    4242    if { ![catch {set vers [lindex [registry_active texlive-bin-extra] 0]}]
    43          && ([rpm-vercomp [lindex $vers 1] 23089] < 0
    44              || [rpm-vercomp [lindex $vers 1] 23089] == 0
     43         && ([vercmp [lindex $vers 1] 23089] < 0
     44             || [vercmp [lindex $vers 1] 23089] == 0
    4545             && [lindex $vers 2] < 1)} {
    4646        set deactivate_proc registry_deactivate_composite
  • trunk/dports/tex/latexdiff/Portfile

    r84550 r89810  
    6060    if {[file exists $prefix/bin/latexdiff]
    6161        && ![catch {set vers [lindex [registry_active texlive-bin-extra] 0]}]
    62         && [rpm-vercomp [lindex $vers 1] 19536] < 0} {
     62        && [vercmp [lindex $vers 1] 19536] < 0} {
    6363        set deactivate_proc registry_deactivate_composite
    6464        if {[info commands registry_deactivate_composite] == {}} {
  • trunk/dports/tex/texlive-basic/Portfile

    r88821 r89810  
    7575    if {[file exists $prefix/bin/etex]
    7676        && ![catch {set vers [lindex [registry_active texlive] 0]}]
    77         && [rpm-vercomp [lindex $vers 1] 2009] < 0} {
     77        && [vercmp [lindex $vers 1] 2009] < 0} {
    7878        $deactivate_proc texlive "" [list ports_nodepcheck 1]
    7979    }
     
    8282    # 2009->2010 update
    8383    if {![catch {set vers [lindex [registry_active texlive-fontutils] 0]}]
    84         && [rpm-vercomp [lindex $vers 1] 16392] < 0} {
     84        && [vercmp [lindex $vers 1] 16392] < 0} {
    8585        $deactivate_proc texlive-fontutils "" [list ports_nodepcheck 1]
    8686    }
     
    9090    # exists, causing format generation to fail (see #27339)
    9191    if {![catch {set vers [lindex [registry_active texlive-lang-mongolian] 0]}]
    92          && [rpm-vercomp [lindex $vers 1] 14727] == 0
     92         && [vercmp [lindex $vers 1] 14727] == 0
    9393         && [lindex $vers 2] < 2} {
    9494        $deactivate_proc texlive-lang-mongolian "" [list ports_nodepcheck 1]
  • trunk/dports/tex/texlive-bin/Portfile

    r89701 r89810  
    136136# llvm-gcc apparently fails on Xcode 4.0.x (#30758)
    137137if {${configure.compiler} == "llvm-gcc-4.2" &&
    138     [rpm-vercomp $xcodeversion 4.1] < 0} {
     138    [vercmp $xcodeversion 4.1] < 0} {
    139139    configure.compiler gcc-4.2
    140140}
     
    238238    if { [file exists ${texlive_texmfdist}/scripts/tex4ht/ht.sh]
    239239         && ![catch {set vers [lindex [registry_active texlive-htmlxml] 0]}]
    240          && [rpm-vercomp [lindex $vers 1] 13822] == 0
     240         && [vercmp [lindex $vers 1] 13822] == 0
    241241         && [lindex $vers 2] <3} {
    242242        set deactivate_proc registry_deactivate_composite
     
    249249    if { [file exists ${texlive_texmfmain}/scripts/tetex/updmap.pl]
    250250         && ![catch {set vers [lindex [registry_active texlive-basic] 0]}]
    251          && [rpm-vercomp [lindex $vers 1] 23152] < 0} {
     251         && [vercmp [lindex $vers 1] 23152] < 0} {
    252252        set deactivate_proc registry_deactivate_composite
    253253        if {[info commands registry_deactivate_composite] == {}} {
  • trunk/dports/tex/texlive-fonts-recommended/Portfile

    r88821 r89810  
    5454    # cmsuper moved from fonts-extra to fonts-recommended in TL2010
    5555    if {![catch {set vers [lindex [registry_active texlive-fonts-extra] 0]}]
    56         && [rpm-vercomp [lindex $vers 1] 19491] < 0} {
     56        && [vercmp [lindex $vers 1] 19491] < 0} {
    5757        set deactivate_proc registry_deactivate_composite
    5858        if {[info commands registry_deactivate_composite] == {}} {
  • trunk/dports/tex/texlive-generic-recommended/Portfile

    r88821 r89810  
    3030    # kastrup moved from texlive-latex-extra to texlive-generic-recommended
    3131    if {![catch {set vers [lindex [registry_active texlive-latex-extra] 0]}]
    32         && [rpm-vercomp [lindex $vers 1] 19548] < 0} {
     32        && [vercmp [lindex $vers 1] 19548] < 0} {
    3333        set deactivate_proc registry_deactivate_composite
    3434        if {[info commands registry_deactivate_composite] == {}} {
  • trunk/dports/tex/texlive-latex-recommended/Portfile

    r88821 r89810  
    3535    # fontspec moved from texlive-xetex in TL2011
    3636    if {![catch {set vers [lindex [registry_active texlive-xetex] 0]}]
    37         && [rpm-vercomp [lindex $vers 1] 23080] < 0} {
     37        && [vercmp [lindex $vers 1] 23080] < 0} {
    3838        set deactivate_proc registry_deactivate_composite
    3939        if {[info commands registry_deactivate_composite] == {}} {
     
    4545    # textcase moved from texlive-latex-extra in TL2011
    4646    if {![catch {set vers [lindex [registry_active texlive-latex-extra] 0]}]
    47         && [rpm-vercomp [lindex $vers 1] 22931] < 0} {
     47        && [vercmp [lindex $vers 1] 22931] < 0} {
    4848        set deactivate_proc registry_deactivate_composite
    4949        if {[info commands registry_deactivate_composite] == {}} {
  • trunk/dports/tex/texlive-latex/Portfile

    r88821 r89810  
    4646    # 2009->2010 update
    4747    if {![catch {set vers [lindex [registry_active texlive-context] 0]}]
    48         && [rpm-vercomp [lindex $vers 1] 18549] < 0} {
     48        && [vercmp [lindex $vers 1] 18549] < 0} {
    4949        set deactivate_proc registry_deactivate_composite
    5050        if {[info commands registry_deactivate_composite] == {}} {
  • trunk/dports/tex/texlive-math-extra/Portfile

    r88821 r89810  
    3939    # binomexp moved from texlive-latex-extra to texlive-math-extra in TL2010
    4040    if {![catch {set vers [lindex [registry_active texlive-latex-extra] 0]}]
    41         && [rpm-vercomp [lindex $vers 1] 19538] < 0} {
     41        && [vercmp [lindex $vers 1] 19538] < 0} {
    4242        set deactivate_proc registry_deactivate_composite
    4343        if {[info commands registry_deactivate_composite] == {}} {
  • trunk/dports/tex/texlive-pictures/Portfile

    r88821 r89810  
    4444pre-activate {
    4545    if {![catch {set vers [lindex [registry_active texlive-latex-extra] 0]}]
    46         && [rpm-vercomp [lindex $vers 1] 19538] < 0} {
     46        && [vercmp [lindex $vers 1] 19538] < 0} {
    4747        set deactivate_proc registry_deactivate_composite
    4848        if {[info commands registry_deactivate_composite] == {}} {
  • trunk/dports/textproc/chasen-base/Portfile

    r87366 r89810  
    7474    if {[file exists ${prefix}/bin/chasen]
    7575        && ![catch {set vers [lindex [registry_active chasen] 0]}]
    76         && ([rpm-vercomp [lindex $vers 1] 2.4.4] < 0 ||
    77             [rpm-vercomp [lindex $vers 1] 2.4.4] == 0
    78             && [rpm-vercomp [lindex $vers 2] 1] < 1)} {
     76        && ([vercmp [lindex $vers 1] 2.4.4] < 0 ||
     77            [vercmp [lindex $vers 1] 2.4.4] == 0
     78            && [vercmp [lindex $vers 2] 1] < 1)} {
    7979        registry_deactivate chasen "" [list ports_nodepcheck 1]
    8080    }
  • trunk/dports/textproc/mecab-base/Portfile

    r88882 r89810  
    5454    if {[file exists ${prefix}/bin/mecab]
    5555        && ![catch {set vers [lindex [registry_active mecab] 0]}]
    56         && ([rpm-vercomp [lindex $vers 1] 0.98] < 0 ||
    57             [rpm-vercomp [lindex $vers 1] 0.98] == 0
    58             && [rpm-vercomp [lindex $vers 2] 1] < 1)} {
     56        && ([vercmp [lindex $vers 1] 0.98] < 0 ||
     57            [vercmp [lindex $vers 1] 0.98] == 0
     58            && [vercmp [lindex $vers 2] 1] < 1)} {
    5959        registry_deactivate mecab "" [list ports_nodepcheck 1]
    6060    }
  • trunk/dports/textproc/pdfjam/Portfile

    r83385 r89810  
    5959    if {[file exists $prefix/bin/pdfjam]
    6060        && ![catch {set vers [lindex [registry_active texlive-bin-extra] 0]}]
    61         && [rpm-vercomp [lindex $vers 1] 19536] < 0} {
     61        && [vercmp [lindex $vers 1] 19536] < 0} {
    6262        set deactivate_proc registry_deactivate_composite
    6363        if {[info commands registry_deactivate_composite] == {}} {
  • trunk/dports/x11/pango-devel/Portfile

    r88926 r89810  
    5959    set glib_minimum_version 2.31.0
    6060    set glib_installed_version [exec ${prefix}/bin/pkg-config glib-2.0 --modversion]
    61     if {[rpm-vercomp ${glib_installed_version} ${glib_minimum_version}] < 0} {
     61    if {[vercmp ${glib_installed_version} ${glib_minimum_version}] < 0} {
    6262        ui_error "${name} ${version} requires glib2 ${glib_minimum_version} or later but you have glib2 ${glib_installed_version}."
    6363        return -code error "incompatible glib2 version"
     
    6666    set cairo_minimum_version 1.7.6
    6767    set cairo_installed_version [exec ${prefix}/bin/pkg-config cairo --modversion]
    68     if {[rpm-vercomp ${cairo_installed_version} ${cairo_minimum_version}] < 0} {
     68    if {[vercmp ${cairo_installed_version} ${cairo_minimum_version}] < 0} {
    6969        ui_error "${name} ${version} requires cairo ${cairo_minimum_version} or later but you have cairo ${cairo_installed_version}."
    7070        return -code error "incompatible cairo version"
  • trunk/dports/x11/pango/Portfile

    r87564 r89810  
    5858    set glib_minimum_version 2.24.0
    5959    set glib_installed_version [exec ${prefix}/bin/pkg-config glib-2.0 --modversion]
    60     if {[rpm-vercomp ${glib_installed_version} ${glib_minimum_version}] < 0} {
     60    if {[vercmp ${glib_installed_version} ${glib_minimum_version}] < 0} {
    6161        ui_error "${name} ${version} requires glib2 ${glib_minimum_version} or later but you have glib2 ${glib_installed_version}."
    6262        return -code error "incompatible glib2 version"
     
    6565    set cairo_minimum_version 1.7.6
    6666    set cairo_installed_version [exec ${prefix}/bin/pkg-config cairo --modversion]
    67     if {[rpm-vercomp ${cairo_installed_version} ${cairo_minimum_version}] < 0} {
     67    if {[vercmp ${cairo_installed_version} ${cairo_minimum_version}] < 0} {
    6868        ui_error "${name} ${version} requires cairo ${cairo_minimum_version} or later but you have cairo ${cairo_installed_version}."
    6969        return -code error "incompatible cairo version"
  • trunk/dports/x11/xinit/Portfile

    r81481 r89810  
    4141
    4242post-destroot {
    43         if {${os.platform} == "darwin" && [rpm-vercomp ${os.version} 10.3.0] < 0} {
     43        if {${os.platform} == "darwin" && [vercmp ${os.version} 10.3.0] < 0} {
    4444                file delete -force ${destroot}/Library/LaunchAgents/org.macports.startx.plist
    4545        }
Note: See TracChangeset for help on using the changeset viewer.