Ignore:
Timestamp:
Mar 28, 2012, 6:15:12 PM (7 years ago)
Author:
jmr@…
Message:

change rpm-vercomp to vercmp in portgroups

Location:
trunk/dports/_resources/port1.0/group
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/_resources/port1.0/group/xcode-1.0.tcl

    r77279 r91305  
    130130proc xcode::fix_resource_dependencies {} {
    131131    global xcodeversion xcode.configuration
    132     if {[rpm-vercomp $xcodeversion 2.1] >= 0} {
     132    if {[vercmp $xcodeversion 2.1] >= 0} {
    133133        set build_path "[xcode::get_project_path]/build/"
    134134        set config_build_path "[xcode::get_project_path]/build/${xcode.configuration}/"
     
    148148    global xcodeversion
    149149    if {$style != ""} {
    150         if {[rpm-vercomp $xcodeversion 2.1] >= 0} {
     150        if {[vercmp $xcodeversion 2.1] >= 0} {
    151151            return "-configuration $style"
    152152        } else {
  • trunk/dports/_resources/port1.0/group/xcodeversion-1.0.tcl

    r89688 r91305  
    5757        foreach {darwin_major minimum_xcodeversion} [join ${minimum_xcodeversions}] {
    5858            if {${darwin_major} == ${os.major}} {
    59                 if {[rpm-vercomp ${xcodeversion} ${minimum_xcodeversion}] < 0} {
     59                if {[vercmp ${xcodeversion} ${minimum_xcodeversion}] < 0} {
    6060                    ui_error "On Mac OS X ${macosx_version}, ${name} ${version} requires Xcode ${minimum_xcodeversion} or later but you have Xcode ${xcodeversion}."
    6161                    ui_error "See http://guide.macports.org/chunked/installing.xcode.html for download links."
Note: See TracChangeset for help on using the changeset viewer.