Changeset 91391 for trunk/dports/gis


Ignore:
Timestamp:
Mar 31, 2012, 4:17:06 PM (8 years ago)
Author:
vince@…
Message:

Add explicit variants to choose between postgresql90 and postgresql91 (cf. #32112).

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/gis/qgis/Portfile

    r91389 r91391  
    9999}
    100100
     101variant postgresql90            description "Use postgresql 9.0" {
     102        depends_lib-append              port:postgresql90
     103        set PGSQL_DIR   ${prefix}/lib/postgresql90
     104        configure.args-append   "-DPOSTGRES_CONFIG=${PGSQL_DIR}/bin/pg_config"
     105}
     106
     107variant postgresql91            description "Use postgresql 9.1" {
     108        depends_lib-append              port:postgresql91
     109        set PGSQL_DIR   ${prefix}/lib/postgresql91
     110        configure.args-append   "-DPOSTGRES_CONFIG=${PGSQL_DIR}/bin/pg_config"
     111}
     112
    101113variant postgis                         description "Build postgis support" {
    102114       
    103115        depends_lib-append              port:postgis
    104 
    105     pre-configure {
    106         # Always choose latest installed postgresql version
    107         set     PGSQL_DIR                       \
    108                 [lindex [lsort -dec [glob -d ${prefix}/lib postgresql*]] 0]
    109         configure.args-append   "-DPOSTGRES_CONFIG=${PGSQL_DIR}/bin/pg_config"
    110         }
    111116}
    112117
Note: See TracChangeset for help on using the changeset viewer.