Changeset 92159


Ignore:
Timestamp:
Apr 20, 2012, 5:50:24 PM (9 years ago)
Author:
jeremyhu@…
Message:

Use gcc-4.0 if using XCode 3.2 with a Tiger deployment target

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/base/src/port1.0/portconfigure.tcl

    r92109 r92159  
    430430        return {llvm-gcc-4.2 clang gcc-4.2}
    431431    } elseif {[vercmp $xcodeversion 3.2] >= 0} {
    432         return {gcc-4.2 clang llvm-gcc-4.2 gcc-4.0}
     432        if {$macosx_deployment_target == "10.4"} {
     433            # It's not the deployment target that is the issue, it's the
     434            # 10.4u SDK which base chooses if the deployment_target is set
     435            return {gcc-4.0}
     436        } else {
     437            return {gcc-4.2 clang llvm-gcc-4.2 gcc-4.0}
     438        }
    433439    } elseif {[vercmp $xcodeversion 3.0] >= 0} {
    434440        return {gcc-4.2 apple-gcc-4.2 macports-clang-3.0 gcc-4.0}
Note: See TracChangeset for help on using the changeset viewer.