Ignore:
Timestamp:
May 1, 2012, 7:16:19 PM (7 years ago)
Author:
ryandesign@…
Message:

postgis2: add autoconf, automake, libtool build dependencies needed by autogen script; wait to run the autogen script until after we've tested if the combination of universal variants is ok; use system -W

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/databases/postgis2/Portfile

    r92579 r92581  
    2929svn.revision        ${revision}
    3030svn.url             http://svn.osgeo.org/postgis/trunk
     31
     32depends_build       port:autoconf \
     33                    port:automake \
     34                    port:libtool
    3135
    3236depends_lib         port:geos\
     
    110114
    111115pre-configure {
    112     system "cd ${worksrcpath} && ./autogen.sh"
    113 
    114116    if {[variant_isset postgresql90]} {
    115117        set PGVERSION   postgresql90
     
    125127                            PostGIS must also be built universal."
    126128    }
     129
     130    system -W ${worksrcpath} "./autogen.sh"
    127131}
    128132
     
    137141        reinplace -E "s#XXX#${configure.universal_cflags}#" \
    138142                    ${worksrcpath}/ed_command
    139         system "cd ${worksrcpath}/liblwgeom && \
    140                 ed Makefile < ${worksrcpath}/ed_command"
     143        system -W ${worksrcpath}/liblwgeom \
     144                "ed Makefile < ${worksrcpath}/ed_command"
    141145    }
    142146}
Note: See TracChangeset for help on using the changeset viewer.