Changeset 92816


Ignore:
Timestamp:
May 7, 2012, 5:18:18 PM (5 years ago)
Author:
jeremyhu@…
Message:

boehmgc: Use llvm-gcc-4.2 on Xcode 4.3 and later

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/devel/boehmgc/Portfile

    r92792 r92816  
    77conflicts       boehmgc-devel
    88version         7.1
    9 revision        1
     9revision        2
    1010categories      devel
    1111license         Permissive
     
    4444patchfiles asm.patch
    4545
     46# <rdar://problem/11394446>, regression in 4.3
     47# XCode 4.3's clang triggers a static assert in 7.2alpha6.  I am forcing
     48# llvm-gcc for 7.1, which is missing the assert, just to be on the safe side.
     49if {${configure.compiler} == "clang" && [vercmp ${xcodeversion} 4.3] >= 0} {
     50    configure.compiler llvm-gcc-4.2
     51}
     52
    4653test.run        yes
    4754test.target     check
Note: See TracChangeset for help on using the changeset viewer.