Changeset 94067 for trunk/dports/java


Ignore:
Timestamp:
Jun 8, 2012, 1:36:10 PM (7 years ago)
Author:
hum@…
Message:

hadoop: prohibit installation on Mac OS X 10.5 or earlier; see #34665.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/java/hadoop/Portfile

    r93805 r94067  
    66name                hadoop
    77version             1.0.3
     8revision            1
    89categories          java devel science
    910maintainers         hum openmaintainer
     
    3839        ui_error "Java 1.6 is required, but not located at ${java_home}"
    3940        return -code error "Java 1.6 missing"
     41    }
     42
     43    # This port works on Mac OS X 10.6 or later, because 'sudo option -E'
     44    # is not available on Mac OS X 10.5 or earlier. See #34665.
     45    set os_major_version  [lindex [split ${os.version} .] 0]
     46    if {${os_major_version} <= 9} {
     47        ui_error "This port works on Mac OS X 10.6 (Snow Leopard) or later"
     48        return -code error "Mac OS X 10.6 (Snow Leopard) or later is required"
    4049    }
    4150}
     
    113122}
    114123
    115 # sudo option -E is not available on Mac OS X 10.5. Use sudo port instead. See #34665.
    116 platform darwin 9 {
    117     depends_run         port:sudo
    118 }
    119 
    120124default_variants    +pseudo
    121125
Note: See TracChangeset for help on using the changeset viewer.