Ignore:
Timestamp:
Jul 17, 2012, 8:50:09 AM (7 years ago)
Author:
vince@…
Message:

postgis2: Bump to version 2.0.1 (and get rid of the SVN stuff); add postgresql92 variant

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/databases/postgis2/Portfile

    r93205 r95593  
    88categories          databases gis
    99license             GPL
    10 revision            9656
    11 epoch                           0
    12 version             2.0.1-svn
     10epoch                           1
     11version             2.0.1
    1312platforms           darwin
    1413maintainers         vince openmaintainer
     
    2524
    2625master_sites        http://www.postgis.org/download
     26distname                        postgis-${version}
    2727
    28 fetch.type          svn
    29 svn.revision        ${revision}
    30 svn.url             http://svn.osgeo.org/postgis/trunk
     28checksums           rmd160  2c7e27aaf0b6c071254b77b118ab6d4e9b023c1f \
     29        sha256  32d181bbf0e648fe31c95b3dd23f7e4e49094d93cb4278fdf71c8feed4e9593c
     30
    3131
    3232depends_build       port:autoconf \
     
    4444                    lib/libxml2.dylib
    4545
    46 worksrcdir          trunk
    47 
    4846# PostGIS 2.0 is not compatible with PostGIS 1.5
    4947
     
    5351
    5452variant postgresql90        description {Builds with postgresql 9.0} \
    55                             conflicts postgresql91 {
     53                            conflicts postgresql91 postgresql92 {
    5654    depends_lib-append      port:postgresql90
    5755    archcheck.files-append  lib/postgresql90/libpq.dylib
     
    6361
    6462variant postgresql91        description {Builds with postgresql 9.1} \
    65                             conflicts postgresql90 {
    66     depends_lib-append      port:postgresql91
     63                            conflicts postgresql90 postgresql92 {
     64    depends_lib-append      port:postgresql91 
    6765    archcheck.files-append  lib/postgresql91/libpq.dylib
    6866    configure.args-append   --libdir=${prefix}/lib/postgresql91\
    6967                            --with-pgconfig=${prefix}/lib/postgresql91/bin/pg_config
     68    build.args-append       PGSQL_DOCDIR=${destroot}${prefix}/share/doc/postgresql91\
     69                            PGSQL_MANDIR=${destroot}${prefix}/share/man
     70}
     71
     72variant postgresql92        description {Builds with postgresql 9.2} \
     73                            conflicts postgresql90 postgresql91 {
     74    depends_lib-append      port:postgresql92
     75    archcheck.files-append  lib/postgresql92/libpq.dylib
     76    configure.args-append   --libdir=${prefix}/lib/postgresql92\
     77                            --with-pgconfig=${prefix}/lib/postgresql92/bin/pg_config
    7078    build.args-append       PGSQL_DOCDIR=${destroot}${prefix}/share/doc/postgresql91\
    7179                            PGSQL_MANDIR=${destroot}${prefix}/share/man
Note: See TracChangeset for help on using the changeset viewer.