Ignore:
Timestamp:
Aug 16, 2012, 12:00:15 PM (7 years ago)
Author:
kimuraw@…
Message:

group/ruby-1.0.tcl: Fix #34202. "Config" was obsoleted in ruby-1.9.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/_resources/port1.0/group/ruby-1.0.tcl

    r89756 r96656  
    4040proc ruby.extract_config {var {default ""}} {
    4141    global ruby.bin
    42     if {[catch {set val [exec ${ruby.bin} -e "require 'rbconfig';puts Config::CONFIG\[\"${var}\"\]"]}]} {
     42    if {[catch {set val [exec ${ruby.bin} -e "require 'rbconfig';puts RbConfig::CONFIG\[\"${var}\"\]"]}]} {
    4343        set val ${default}
    4444    }
Note: See TracChangeset for help on using the changeset viewer.