Changeset 96896 for trunk/dports/aqua


Ignore:
Timestamp:
Aug 21, 2012, 1:23:55 AM (7 years ago)
Author:
michaelld@…
Message:

qt4-mac:

  • fixes ticket #35506 : make sure QMAKE_FRAMEWORKDIR_QT is defined, to get Qt frameworks' LIBS defined correctly;
  • fixes ticket #35067 : macdeployqt should look for frameworks in the correct location;
  • equalize comment brackets;
  • use new Qt4 plugin ports instead of having them as variants here; MUCH faster to get new plugins up and running in Qt4.
Location:
trunk/dports/aqua/qt4-mac
Files:
1 added
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/aqua/qt4-mac/Portfile

    r96486 r96896  
    1313conflicts           qt3 qt3-mac qt4-mac-devel
    1414version             4.8.2
    15 revision            1
     15revision            2
    1616categories          aqua
    1717platforms           macosx
     
    212212    patchfiles-append patch-EXPERIMENTAL-ML-fixes.diff
    213213}
     214
     215# (23) fix Framework directory in MacDeployQt tool
     216
     217patchfiles-append   \
     218    patch-tools_macdeployqt_shared_shared.cpp.diff
    214219
    215220###############################################
     
    663668}
    664669
    665 variant mysql description {Enable MySQL SQL Driver} {
    666     depends_lib-append path:lib/mysql5:mysql5
    667     lunshift header_path ${prefix}/include/mysql5/mysql
    668     lunshift library_path ${prefix}/lib/mysql5/mysql
    669     configure.args-delete -no-sql-mysql
    670     configure.args-append -plugin-sql-mysql
     670variant mysql description {MySQL Qt4 Plugin Legacy Compatibility Variant} {
     671    ui_error "${name} variant +mysql has been replaced by the port 'qt4-mac-mysql55-plugin' and its subports.  Please install ${name} without +mysql, then install your desired MySQL Qt plugin."
     672    return -code error "Variant disabled"
    671673}
    672674
     
    678680
    679681variant psql83 conflicts psql84 psql90 psql91 \
    680 description {Enable Postgre SQL Driver version 8.3} {}
     682description {Postgre SQL 8.3 Qt4 Plugin Legacy Compatibility Variant} {}
    681683
    682684variant psql84 conflicts psql83 psql90 psql91 \
    683 description {Enable Postgre SQL Driver version 8.4} {}
     685description {Postgre SQL 8.4 Qt4 Plugin Legacy Compatibility Variant} {}
    684686
    685687variant psql90 conflicts psql83 psql84 psql91 \
    686 description {Enable Postgre SQL Driver version 9.0} {}
     688description {Postgre SQL 9.0 Qt4 Plugin Legacy Compatibility Variant} {}
    687689
    688690variant psql91 conflicts psql83 psql84 psql90 \
    689 description {Enable Postgre SQL Driver version 9.1} {}
     691description {Postgre SQL 9.1 Qt4 Plugin Legacy Compatibility Variant} {}
    690692
    691693if {[variant_isset psql83]} {
     
    700702
    701703if {${psql_version} != ""} {
    702     depends_lib-append port:postgresql${psql_version}
    703     lunshift header_path ${prefix}/include/postgresql${psql_version}
    704     lunshift library_path ${prefix}/lib/postgresql${psql_version}
    705     configure.args-delete -no-sql-psql
    706     configure.args-append -plugin-sql-psql
     704    ui_error "${name} variant +psql${psql_version} has been replaced by the port 'qt4-mac-postgresql91-plugin' and its subports.  Please install ${name} without +psql${psql_version}, then install your desired Postgre SQL Qt plugin."
     705    return -code error "Variant disabled"
    707706}
    708707
     
    745744
    746745# if neither +x11 or +quartz were specified, default to the latter
    747 #if {![variant_isset quartz] && ![variant_isset x11]}
     746#if {![variant_isset quartz] && ![variant_isset x11]} {
    748747    default_variants +quartz
    749748#}
  • trunk/dports/aqua/qt4-mac/files/patch-mkspecs_common_mac.conf.diff

    r94241 r96896  
    1 --- mkspecs/common/mac.conf.orig        2012-04-23 14:49:04.000000000 -0400
    2 +++ mkspecs/common/mac.conf     2012-04-17 14:38:16.000000000 -0400
    3 @@ -38,7 +38,11 @@
     1--- mkspecs/common/mac.conf.orig        2012-08-14 15:49:12.000000000 -0400
     2+++ mkspecs/common/mac.conf     2012-08-14 15:49:25.000000000 -0400
     3@@ -9,6 +9,7 @@
     4 QMAKE_LIBDIR           =
     5 QMAKE_INCDIR_QT                = $$[QT_INSTALL_HEADERS]
     6 QMAKE_LIBDIR_QT                = $$[QT_INSTALL_LIBS]
     7+QMAKE_FRAMEWORKDIR_QT  = $$[QT_INSTALL_FRAMEWORKS]
     8 QMAKE_INCDIR_OPENGL    = /System/Library/Frameworks/OpenGL.framework/Headers \
     9        /System/Library/Frameworks/AGL.framework/Headers/
     10 
     11@@ -38,7 +39,11 @@
    412 QMAKE_DEL_DIR          = rmdir
    513 QMAKE_CHK_DIR_EXISTS   = test -d
Note: See TracChangeset for help on using the changeset viewer.