Changeset 97033


Ignore:
Timestamp:
Aug 24, 2012, 8:55:00 PM (6 years ago)
Author:
ryandesign@…
Message:

mongodb: add note explaining how to install mongodb without upgrading dependencies (#35118)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/databases/mongodb/Portfile

    r96549 r97033  
    5555    set boost_version "${boost_major}.${boost_minor}.${boost_patch}"
    5656    if {[vercmp ${boost_version} 1.50] >= 0} {
    57         ui_error "mongodb ${version} requires boost 1.49.x or older but you have boost ${boost_version}."
     57        ui_error "mongodb ${version} requires boost 1.49.0 or older but you have boost ${boost_version}."
    5858        ui_error "To downgrade boost, see https://trac.macports.org/wiki/howto/InstallingOlderPort"
    5959        ui_error "or more specifically https://trac.macports.org/ticket/35118#comment:12"
     60        ui_error "After installing boost 1.49.0, install mongodb without upgrading dependencies, i.e.:"
     61        ui_error "    sudo port -n install mongodb"
    6062        return -code error "boost ${boost_version} is too new"
    6163    }
Note: See TracChangeset for help on using the changeset viewer.