Changeset 99440 for trunk/dports/aqua


Ignore:
Timestamp:
Nov 5, 2012, 8:55:41 AM (7 years ago)
Author:
ryandesign@…
Message:

iTunesMatchHelper: require OS X 10.7 or greater due to the use of NSJSONSerialization (#36870)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/aqua/iTunesMatchHelper/Portfile

    r99360 r99440  
    2727    copy ${worksrcpath}/build/Release/iTunesMatchHelper.app ${destroot}${applications_dir}
    2828}
     29
     30if {${os.platform} == "darwin" && ${os.major} < 11} {
     31    pre-fetch {
     32        ui_error "${name} ${version} requires OS X 10.7 or greater."
     33        return -code error "incompatible OS X version"
     34    }
     35}
Note: See TracChangeset for help on using the changeset viewer.