Changeset 99816 for trunk/dports/gis


Ignore:
Timestamp:
Nov 18, 2012, 10:02:33 AM (7 years ago)
Author:
vince@…
Message:

Correct py-psycopg2 and py-spatialite dependencies

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/dports/gis/qgis/Portfile

    r99807 r99816  
    5050                                                port:ld64
    5151
    52 depends_run-append              port:py-psycopg2 \
    53                                                 port:py-spatialite
    54 
    5552post-extract {
    5653        system "cd ${worksrcpath} && mkdir build && mkdir Python.framework"
     
    8481        depends_lib-append              port:py25-pyqt4
    8582        depends_build-append    port:py25-sip
     83        depends_run-append              port:py25-psycopg2 \
     84                                                        port:py25-spatialite
     85
    8686       
    8787        configure.args-append "-DPYTHON_EXECUTABLE=${prefix}/bin/python2.5"
     
    9797        depends_lib-append              port:py26-pyqt4
    9898        depends_build-append    port:py26-sip
     99        depends_run-append              port:py26-psycopg2 \
     100                                                        port:py26-spatialite
     101
    99102       
    100103        configure.args-append "-DPYTHON_EXECUTABLE=${prefix}/bin/python2.6"
     
    111114        depends_lib-append              port:py27-pyqt4
    112115        depends_build-append    port:py27-sip
     116        depends_run-append              port:py27-psycopg2 \
     117                                                        port:py27-spatialite
     118
    113119       
    114120        configure.args-append "-DPYTHON_EXECUTABLE=${prefix}/bin/python2.7"
Note: See TracChangeset for help on using the changeset viewer.