source: trunk/dports/python/py-pyqt4/Portfile

Revision Log Mode:


Legend:

Added
Modified
Copied or renamed
Diff Rev Age Author Log Message
(edit) @140993   2 years michaelld py-pyqt4: add support for Python 3.5.
(edit) @140960   2 years michaelld qt4 various: change qt_dir to ${prefix}/libexec/qt4 to allow for a …
(edit) @139661   2 years ionic misc: revbump ports that are affected by the ${qt_data_dir} (and …
(edit) @138421   2 years michaelld py*-pyqt4: + be explicit about the qsci-api-destdir; + rearrange bits …
(edit) @138326   2 years michaelld py*-pyqt4: + remove cruft from py2[4-6], py3[0-3]; + always build with …
(edit) @138149   2 years michaelld py*-pyqt4: update to 4.11.4, which changes the license to just GPL3 …
(edit) @127998   3 years michaelld py*-pyqt4: update to 4.11.3.
(edit) @127572   3 years michaelld py{24,25,26,31,32,33}-pyqt4: Replaced by py{27,34}-pyqt4.
(edit) @125439   3 years michaelld py*-pyqt4: update to 4.11.2.
(edit) @122664   3 years michaelld py*-pyqt4-devel: error out in pre-fetch, not pre-configure.
(edit) @122644   3 years michaelld py*-pyqt4: + update to 4.11.1; + redo version handling to be more …
(edit) @118446   3 years michaelld py*-pyqt4: fix pyuic, ticket #43090.
(edit) @118239   3 years ryandesign py-pyqt4: use system -W X "Y" instead of system "cd X && Y"
(edit) @117992   4 years michaelld py*-pyqt4: + enable +scintilla variant for all Python versions; + …
(edit) @117942   4 years michaelld py*-pyqt4: + update release to 4.10.4; + make -devel port replaced_by …
(edit) @117831   4 years michaelld py-pyqt4: Enable py34-pyqt4 port.
(edit) @117753   4 years michaelld py*-pyqt4-devel: fix livecheck regex.
(edit) @115713   4 years michaelld py*-pyqt4-devel: update to snapshot 595c1453ae29 (20140105).
(edit) @114328   4 years ryandesign use eq and ne instead of == and != when comparing ${os.arch}, …
(edit) @114324   4 years ryandesign python ports: use eq and ne when comparing ${subport} instead of == and !=
(edit) @113901   4 years michaelld py*-pyqt4-devel: fix livecheck; whitespace.
(edit) @113638   4 years michaelld py*-pyqt4-devel: update to snapshot e52357d82574 (20131018).
(edit) @113089   4 years michaelld py*-pyqt4-devel: update to f62fabcefe39 (20131012).
(edit) @111910   4 years michaelld py*-pyqt4-devel: update snapshot to f24cac93a1b0; do it more robustly.
(edit) @111837   4 years michaelld py*-pyqt4: * use dbus-python for 2.6/7 only; does not yet work …
(edit) @111812   4 years michaelld py*-pyqt4: * add 'devel' version for latest changes; * add configure …
(edit) @110154   4 years michaelld py*-pyqt4: rev-bump for updated SIP API, just in case.
(edit) @109911   4 years michaelld py*-pyqt4: update to 4.10.3.
(edit) @108493   4 years michaelld Add py*-sip as explicit dependency if not already there; rev-bump for …
(edit) @107373   4 years michaelld py*-pyqt4: * fix name of qt4 designer plugin to include python.version …
(edit) @107067   4 years michaelld py*-pyqt4: update to 4.10.2.
(edit) @105509   4 years michaelld py-pyqt4: * make py27-pyqt4 the default; * move dist info into the …
(edit) @105502   4 years michaelld py*-pyqt4: * update to latest (4.10.1), and tweak Portfile back to …
(edit) @104005   5 years michaelld py*-pyqt4: * better way to handle the revision (4.10; not 4.10.0); * …
(edit) @103722   5 years michaelld py*-pyqt4 : upgrade to 4.10.0.
(edit) @102584   5 years larryv python/*: Use categories-append in all {no,open}maintainer ports that …
(edit) @102256   5 years michaelld py-pyqt4: fix such that the subport for Python 2.4 or 2.5 installs …
(edit) @100839   5 years michaelld py*-pyqt4 : delete python3 code from python2 installs and vice versa, …
(edit) @100395   5 years michaelld py-pyqt4 : fix overwritten @@ variable in patchfile from prior …
(edit) @100394   5 years michaelld py-pyqt4 : upgrade to 4.9.6, which should include a fix for 10.5 …
(edit) @99575   5 years mmoll py-pyqt4, py-sip: enable support for python 3.3
(edit) @99506   5 years blair py-pyqt4: whitespace cleanup: replace tabs with spaces.
(edit) @99505   5 years blair py-pyqt4: update to 4.9.5; required for sip 4.14.1 upgrade in r99483.
(edit) @97952   5 years michaelld py-pyqt4 : upgrade to 4.9.4_0. Addresses tickets #35789 and #36183.
(edit) @96669   5 years michaelld py-pyqt4: * fixes ticket #28036 : remove port_v3 files if using …
(edit) @91559   5 years blair py-pyqt4: new upstream 4.9.1 release.
(edit) @88813   6 years phw updated py-pyqt4 to version 4.9, finally works with python32
(edit) @86554   6 years eborisch py-pyqt4: Turn off designer plugin for 24 (not built as a dylib); …
(edit) @86553   6 years eborisch py-pyqt4: Trying to fix linking error when building Designer plugin.
(edit) @86489   6 years eborisch py-pyqt4: More dependencies
(edit) @86487   6 years eborisch py-pyqt4: Fix dependency
(edit) @86486   6 years eborisch py-pyqt4: Upgrade to 4.8.6
(copy) @86484   6 years eborisch py-pyqt4: Merged in [86450:86483/users/eborisch/python]; Unifies …
copied from users/eborisch/python/py-pyqt4/Portfile:
(edit) @86483   6 years eborisch py-pyqt4: (sandboxed) Whitespace and one comment.
Note: See TracRevisionLog for help on using the revision log.