New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Custom Query (25215 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (301 - 400 of 25215)

1 2 3 4 5 6 7 8 9 10 11 12 13 14
Ticket Summary Cc Owner Type Status Priority
#51194 py26-repoze.* ports: broken since removal of py26-zopeinterface macports-tickets@… defect new Normal
Description

These ports are now broken for some time. They are un-maintained and nobody really cares. Probably they are really not needed / used any more.

So should we care of fixing them, moving them to python27, updating, etc. Or should we just retire them?

unmaintained ports:

  • py26-repoze.what
  • py26-repoze.what-pylons
  • py26-repoze.what-quickstart
  • py26-repoze.what.plugins.sql
  • py26-repoze.who
  • py26-repoze.who-friendlyform
  • py26-repoze.who-testutil
  • py26-repoze.who.plugins.sa
#51193 uhd device not found (HackRF) michaelld@… defect closed Normal
Description

MacPort does not list libhackrf

$uhd_find_devices 
Mac OS; Clang version 6.0 (clang-600.0.57); Boost_105900; UHD_003.009.003-MacPorts-Release

No UHD Devices Found

HackRF_tools run fine

#51192 [Port Abandoned] by gmail.com:lkraider+ports lkraider+ports@… defect new Normal
Description

The maintainer has not reacted to ticket #50392 for quite some time. Last activity 13 month ago.

These are the maintained ports:

  • py-pygraph-core
  • py-pygraph-dot
  • py-pyobjc-qtkit
  • py-pyobjc-quartz
#51191 libdap fails to install takeshi@… defect closed Normal
Description

Trying to do a clean install of all our macports, and grads fails on libdap. Attached log file.

#51188 Exiting python35 leaves bash in echo off mode jwa@… defect closed Normal
Description

Hi,

When exiting python35 (ctrl-D) then bash is in a non-standard state, where keyboard input is not echoed. "stty echo" fixes the issue.

Best, Jon


FN11194:~ sporring$ port info python35
python35 @3.5.1_1 (lang)
Variants:             readline, universal

Description:          Python is an interpreted, interactive, object-oriented
                      programming language.
Homepage:             http://www.python.org/

Extract Dependencies: xz
Library Dependencies: zlib, openssl, sqlite3, ncurses, bzip2, libedit, gettext,
                      xz
Runtime Dependencies: python_select, python3_select
Platforms:            darwin
License:              PSF
Maintainers:          jwa@macports.org, openmaintainer@macports.org
#51187 p5.22-email-sender requires Net::SMTP 3.07 but perl5.22 only provides 3.05 macports-tickets@… defect closed Normal
Description

When calling perl script containing

require Email::Sender::Transport::SMTP;

from p5.22-email-sender it issues

  Net::SMTP version 3.07 required--this is only version 3.05 at /opt/local/lib/perl5/vendor_perl/5.22/Email/Sender/Transport/SMTP.pm line 11.
  BEGIN failed--compilation aborted at /opt/local/lib/perl5/vendor_perl/5.22/Email/Sender/Transport/SMTP.pm line 11.
  Compilation failed in require at sendMails.pl line 29.

Net::SMTP is part of the main Perl package perl5.22 and is version 3.05:

  $ grep VERSION.= /opt/local/lib/perl5/5.22/Net/SMTP.pm
  our $VERSION = "3.05";
  $ port provides /opt/local/lib/perl5/5.22/Net/SMTP.pm
  /opt/local/lib/perl5/5.22/Net/SMTP.pm is provided by: perl5.22

The installed packages are the current ones

$ port installed perl5.22 p5.22-email-sender
The following ports are currently installed:
  p5.22-email-sender @1.300.27_0 (active)
  perl5.22 @5.22.1_1 (active)

Please upgrade perl5.22 to provide the required version 3.07 of Net::SMTP !

#51186 libcxx: archivefetch failed for libcxx @3.7.1_0 jeremyhu@… defect new Normal
Description

The terminal showed "Error: Processing of port demeter failed", when I ran "sudo port install xorg-server demeter". What can I do? Thanks.

#51184 harfbuzz 1.2.6 fetch fails ryandesign@… defect closed Normal
Description

Fetching is failing for Harfbuzz.

First it fails to get archive as it seems there is no ppc archive. (Is this a binary?)

Then it fails to get the source (distfiles) from a large set of mirrors including freedesktop.org, which is weird because I can download it manually.

It seems it's related to a SSL/CA certificate problem, that I don't know how to fix.

[rees@powermacg5 ~]$sudo port upgrade outdated
--->  Computing dependencies for harfbuzz
--->  Fetching archive for harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6_0.darwin_9.ppc.tbz2 from https://packages.macports.org/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6_0.darwin_9.ppc.tbz2 from http://sea.us.packages.macports.org/macports/packages/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6_0.darwin_9.ppc.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/harfbuzz
--->  Fetching distfiles for harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://www.freedesktop.org/software/harfbuzz/release/
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from https://distfiles.macports.org/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://ykf.ca.distfiles.macports.org/MacPorts/mpdistfiles/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://sea.us.distfiles.macports.org/macports/distfiles/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://cjj.kr.distfiles.macports.org/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://osl.no.distfiles.macports.org/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://lil.fr.distfiles.macports.org/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://aarnet.au.distfiles.macports.org/pub/macports/mpdistfiles/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://nue.de.distfiles.macports.org/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://nou.nc.distfiles.macports.org/pub/macports/distfiles.macports.org/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://jog.id.distfiles.macports.org/macports/distfiles/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://jnb.za.distfiles.macports.org/distfiles/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://her.gr.distfiles.macports.org/harfbuzz
--->  Attempting to fetch harfbuzz-1.2.6.tar.bz2 from http://svn.macports.org/repository/macports/distfiles/harfbuzz
Error: org.macports.fetch for port harfbuzz returned: fetch failed
Please see the log file for port harfbuzz for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_harfbuzz/harfbuzz/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
#51181 sqlite3 @3.12.1_0: update to 3.12.2 mww@… update closed Normal
Description

sqlite3 has been updated to version 3.12.2. See http://www.sqlite.org/releaselog/3_12_2.html for details.

#51180 crashing BLT macports-tickets@… defect new Normal
Description

The application built on BLT crashes when the zoom is triggered.

% line 1064 of ../bltGrMarker.c: Assert "extsPtr->right >= extsPtr->left" failed
Abort trap: 6
#51179 ImageMagick @6.9.3-4_1 build error ryandesign@… defect closed Normal
Description

Attempting to build ImageMagick 6.9.3-4 fails on my system (OS X 10.11.4, El Capitan, XCode 7.3). Full log is attached.

Error message:

--->  Computing dependencies for ImageMagick
--->  Building ImageMagick
Error: org.macports.build for port ImageMagick returned: command execution failed
Please see the log file for port ImageMagick for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_ImageMagick/ImageMagick/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port ImageMagick failed
#51178 graphviz-devel installation failure ryandesign@… defect closed Normal
Description

Hello -

I cannot install graphviz-devel (error below).

I can install other ports with no problem.

Could you please help?

All the best,

AJP

sudo -E port install graphviz-devel
--->  Computing dependencies for graphviz-devel
--->  Verifying checksums for graphviz-devel
Error: Checksum (rmd160) mismatch for graphviz-2.39.20160325.1353.tar.gz
Error: Checksum (sha256) mismatch for graphviz-2.39.20160325.1353.tar.gz
Error: org.macports.checksum for port graphviz-devel returned: Unable to verify file checksums
Please see the log file for port graphviz-devel for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz-devel/graphviz-devel/main.log
To report a bug, follow the instructions in the guide:
   ://guide.macports.org/#project.tickets
Error: Processing of port graphviz-devel failed
#51177 litecoin: update to version 0.10.4.0 fails macports-tickets@… defect new Normal
Description

I've tried to come up with an update for litecoin's portfile, but following its build instructions couldn't get the configure to run normally.

Configure stops due to qmake:

:debug:configure Executing command line:  cd "/opt/local/var/macports/build/_Users_okram_WC_SVN_MacPorts_finance_litecoin/litecoin/work/litecoin-0.10.4.0" && /opt/local/libexec/qt4/bin/qmake PREFIX=/opt/local QMAKE_CC=/usr/bin/clang QMAKE_CXX=/usr/bin/clang++ QMAKE_OBJC=/usr/bin/clang USE_QRCODE=1 INCLUDEPATH+="/opt/local/include/db48/" LIBS+="-L/opt/local/lib/db48" CFLAGS="-Os -arch x86_64"
:info:configure Usage: /opt/local/libexec/qt4/bin/qmake [mode] [options] [files]
:info:configure
:info:configure QMake has two modes, one mode for generating project files based on
:info:configure some heuristics, and the other for generating makefiles. Normally you
:info:configure shouldn't need to specify a mode, as makefile generation is the default
:info:configure mode for qmake, but you may use this to test qmake on an existing project
.
.
.

Since there have been issues with this port since quite a while I am giving up on this.

Removed myself as maintainer.

Please pick it up if you're interested.

#51176 New libtorrent-rasterbar 1.1.0 seems to break current deluge @1.3.12_1+python27 devans@… defect closed Normal
Description

After upgrading to libtorrent-rasterbar @1.1_0+python27 my current torrent app deluge @1.3.12_1+python27 stops downloading or uploading anything. Activating the old one libtorrent-rasterbar @1.0.9_0+python27 brings all back to work.

my OS is LION

bash-3.2$ uname -a
Darwin MACPRO11.local 11.4.2 Darwin Kernel Version 11.4.2: Thu Aug 23 16:26:45 PDT 2012; root:xnu-1699.32.7~1/RELEASE_I386 i386
#51172 arb: build failed matt.cottrell@… defect closed Normal
Description

Hi, I am trying to install arb using port, but i keep on getting an error that I cannot solve it via updating or reinstalling port or commandlinetools.

I get error:

--->  Building arb
Error: org.macports.build for port arb returned: command execution failed
Please see the log file for port arb for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_arb/arb/main.log
ProductName:	Mac OS X
ProductVersion:	10.11.4
BuildVersion:	15E65
#51171 libextractor @1.3: build failure with unpatched jpeg 9b ryandesign@… defect closed Normal
Description

Building libextractor @1.3 fails with an unpatched jpeg 9b.

Reported to developer of libextractor:

https://gnunet.org/bugs/view.php?id=4436

#51170 gcc5 internal compiler error in gcc-tree-ssa-uninit.c mww@… defect closed Normal
Description

gfortran-mp-5 causes an internal compiler error in gcc/gcc-tree-uninit.c. I created a patch based on GCC PR tree-optimization/69013.

#51169 civl new port macports-tickets@… submission new Normal
Description

This is a new port for civl

#51167 py35-nbconvert @4.2.0_0 always breaks due to missing entrypoints dependency stromnov@… defect new Normal
Description

The current nbconvert ports are unusable. Trying to run nbconvert gives this error:

Traceback (most recent call last):
  File "/opt/local/bin/jupyter-nbconvert-2.7", line 3, in <module>
    from nbconvert.nbconvertapp import main
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/nbconvert/__init__.py", line 4, in <module>
    from .exporters import *
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/nbconvert/exporters/__init__.py", line 1, in <module>
    from .export import *
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/nbconvert/exporters/export.py", line 9, in <module>
    import entrypoints
ImportError: No module named entrypoints

entrypoints is a new dependency for nbconvert, but currently not part of macports.

#51166 octave-devel @4.1.0+: error: no matching function for call to 'H5Giterate' mcalhoun@… defect closed Normal
Description

Getting a persistent build failure, apparently due to an unused variable 'st', which is causing XCode to abort. Log file attached.

#51162 Current MacPorts version of Sunwait is out of date macports-tickets@… update closed Normal
Description

Is there any chance of MacPorts providing the latest version of sunwait? The version on MacPorts (0.1) is woefully out of date and the original authors web site says he is no longer working on it and has passed responsibility to Ian Craig here;- https://sourceforge.net/projects/sunwait4windows/

The latest version of the project (0.8) is much enhanced and considerably more useful than the out of date version on MacPorts.

#51160 Can't configure virtualbox macports-tickets@… defect closed Normal
Description

While running

sudo port install virtualbox-guest-additions

I successfully installed before:

Xcode_7.3.dmg
Command_Line_Tools_OS_X_10.11_for_Xcode_7.3.dmg
MacPorts-2.3.4-10.11-ElCapitan.pkg

All done acording to https://www.macports.org/install.php for OS X 10.11 El Capitan

#51157 MongoAlchemy needs updating from 0.11 to 0.21 macports-tickets@… update new Normal
Description

In April 2016 the MacPorts MongoAlchemy is much too aged.

Docs url: http://www.mongoalchemy.org/
Src url: https://github.com/jeffjenkins/MongoAlchemy

The MacPorts version is at:

py-mongoalchemy                @0.11           python/py-mongoalchemy
py27-mongoalchemy              @0.11           python/py-mongoalchemy

which was released before: 0.11.1 -- 2011-12-08 15:00.

While the most recent release is:

MongoAlchemy-master/release-notes.rst:
0.21 -- 2015-11-13 8:45

Users will likely encounter this incompatibility as the error:

ImportError: No module named objectid

Also, Flask-MongoAlchemy (https://pypi.python.org/pypi/Flask-MongoAlchemy) is at:

py-flask-mongoalchemy          @0.5.3          python/py-flask-mongoalchemy
py27-flask-mongoalchemy        @0.5.3          python/py-flask-mongoalchemy

Whereas the last release is at 0.7.2.

Other software in the accompanying toolchain (flask, mongo) are current.

#51155 npm-devel @ 3.8.6 runtime error due to update.js patch ciserlohn@… defect closed Normal
Description

The following error is produced when running "npm update <any>":

21 verbose stack ReferenceError: what is not defined
21 verbose stack     at /opt/local/lib/node_modules/npm/lib/update.js:49:11
21 verbose stack     at Array.forEach (native)
21 verbose stack     at /opt/local/lib/node_modules/npm/lib/update.js:45:12
21 verbose stack     at /opt/local/lib/node_modules/npm/lib/outdated.js:84:53
21 verbose stack     at cb (/opt/local/lib/node_modules/npm/node_modules/slide/lib/async-map.js:47:24)
21 verbose stack     at doIt (/opt/local/lib/node_modules/npm/lib/outdated.js:329:14)
21 verbose stack     at onCacheAdd (/opt/local/lib/node_modules/npm/lib/outdated.js:423:9)
21 verbose stack     at updateDeps (/opt/local/lib/node_modules/npm/lib/outdated.js:394:16)
21 verbose stack     at saved (/opt/local/lib/node_modules/npm/lib/cache/caching-client.js:168:7)
21 verbose stack     at /opt/local/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:210:7

This is because the update.js patch in the port is no longer valid. The variable "what" no longer exists in the scope where the patch resides. It should probably be replaced with "ww.what".

#51153 Error: Failed to install p5.22-html-parser on Yosemite macports-tickets@… defect new Normal
#51152 netcdf @4.4.0_1: nc-config and netcdf.pc contain erroneous "-loptimized" and "-ldebug" takeshi@… defect closed Normal
Description

Upgrading py27-netcdf4 to 1.2.3.1 fails for me with:

/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -bundle -undefined dynamic_lookup -isysroot / -L/opt/local/lib -Wl,-headerpad_max_install_names -L/opt/local/lib/db48 -arch x86_64 -arch x86_64 build/temp.macosx-10.11-x86_64-2.7/netCDF4/_netCDF4.o -L/opt/local/lib -L/opt/local/lib -lnetcdf -lhdf5_hl -lhdf5 -lz -ldl -loptimized -lm -ldebug -lmd -lcurl -o build/lib.macosx-10.11-x86_64-2.7/netCDF4/_netCDF4.so
ld: library not found for -loptimized
clang: error: linker command failed with exit code 1 (use -v to see invocation)

This is coming from files installed by the netcdf port.

There aren't many references to this kind of problem on Google but I found this:

http://stackoverflow.com/questions/18309438/cmake-differences-between-linking-when-target-is-a-library-vs-executable

It seems to be saying the problem is quoting a cmake list variable, which causes it to be interpreted as a string.

netcdf's configure output includes these occurrences of "optimized":

-- Found HDF5: /opt/local/lib/libhdf5.dylib;/opt/local/lib/libz.dylib;/usr/lib/libdl.dylib;optimized;/usr/lib/libm.dylib;debug;/opt/local/lib/libmd.dylib;/opt/local/lib/libhdf5_hl.dylib;/opt/local/lib/libhdf5.dylib;/opt/local/lib/libz.dylib;/usr/lib/libdl.dylib;optimized;/usr/lib/libm.dylib;debug;/opt/local/lib/libmd.dylib (found version "1.10.0") 

And:

-- Linking against:      /opt/local/lib/libhdf5_hl.dylib;/opt/local/lib/libhdf5.dylib;/opt/local/lib/libz.dylib;/usr/lib/libdl.dylib;optimized;/usr/lib/libm.dylib;debug;/opt/local/lib/libmd.dylib;/opt/local/lib/libcurl.dylib

And finally:

Extra libraries:        -lhdf5_hl -lhdf5 -lz -ldl -loptimized -lm -ldebug -lmd -lcurl
#51150 texlive @2015 Does not include biblatex-chicago (or any other biblatex-*) dports@… defect closed Normal
Description

CTAN says that biblatex-chicago is included in texlive: https://www.ctan.org/pkg/biblatex-chicago?lang=en However, from looking in /opt/local/share/texmf-texlive/tex/latex/, there are none of the biblatex-* entries as seen in https://www.tug.org/svn/texlive/trunk/Master/texmf-dist/tex/latex/

I have installed texlive@2015 and texlive-latex-extra@37398 on my system, but still '\usepackage{biblatex-chicago}' fails due to the missing biblatex-* files in the content installed by the texlive ports.

#51144 libgdata fails to build with vala-0.32 update devans@… defect closed Normal
Description

libgdata is failing to compile for me on a recent from-scratch installation. I suspect this may be due to vala-0.32 changes:

make[2]: Entering directory `/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_gnome_libgdata/libgdata/work/libgdata-0.17.4'
/opt/local/bin/vapigen-0.32  --library gdata/libgdata --metadatadir ./gdata   --pkg libxml-2.0 --pkg libsoup-2.4 --pkg json-glib-1.0 gdata/GData-0.0.gir
libsoup-2.4.vapi:1134.3-1134.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1248.3-1248.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1898.3-1898.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1901.3-1901.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1904.3-1904.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1907.3-1907.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1910.3-1910.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1913.3-1913.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1916.3-1916.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1919.3-1919.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1922.3-1922.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1925.3-1925.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1958.3-1958.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1961.3-1961.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1964.3-1964.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2034.3-2034.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2038.3-2038.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2041.3-2041.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2044.3-2044.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2047.3-2047.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2050.3-2050.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2053.3-2053.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2056.3-2056.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2059.3-2059.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2062.3-2062.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2065.3-2065.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2069.3-2069.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
GData-0.0.gir:20804.55-20804.55: error: The symbol `Goa' could not be found
            <type name="Goa.Object" c:type="GoaObject*"/>
                                                      ^
GData-0.0.gir:20814.53-20814.53: error: The symbol `Goa' could not be found
          <type name="Goa.Object" c:type="GoaObject*"/>
                                                    ^
GData-0.0.gir:20829.30-20829.30: error: The symbol `Goa' could not be found
        <type name="Goa.Object"/>
                             ^
GData-0.0.gir:20829.30-20829.30: error: The symbol `Goa' could not be found
        <type name="Goa.Object"/>
                             ^
GData-0.0.gir:20829.30-20829.30: error: The symbol `Goa' could not be found
        <type name="Goa.Object"/>
                             ^
Generation failed: 5 error(s), 27 warning(s)
make[2]: *** [gdata/libgdata.vapi] Error 1
#51142 ghostscript: build fails when Xcode.app is renamed so that it contains a space macports-tickets@… defect closed Normal
Description

I just attempted a clean install of MacPorts (never installed) then ImageMagick -- Xcode 7.3 release

Install failed with ghostscript, did a clean and reinstall of ghostscript alone

Install failed with:

MBP-R:~ sgs$ sudo port install ghostscript
--->  Computing dependencies for ghostscript
--->  Building ghostscript
Error: org.macports.build for port ghostscript returned: command execution failed
Please see the log file for port ghostscript for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_print_ghostscript/ghostscript/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port ghostscript failed
#51141 Consider building Python with +ucs4 by default jwa@… enhancement new Normal
Description

From what I can tell, most distros of Linux come with a wide version of Python by default, however OS X does not. This may seem a reason to avoid building a wide version of Python as it does not match the OS built-in but I think it is better that a replacement be better than the built-in system version.

Many packages would benefit from this change. Code that uses UTF-8 characters beyond 0xffff will not throw errors that are unexpected. Packages like Unidecode will benefit from this change.

The scope of this change would be that dependent packages will need +ucs4 and if anyone uses -ucs4 they are going to have problems. Basically it would be the reverse of the current situation, where -python27_ucs4 would be required for packages like gobject-introspection. This would apply to all versions of Python in the tree.

In terms of bugs, I really would like to know what kind of issues could be run into if +ucs4 is enabled as I have not had a problem with a wide-version Python on any Linux distro or dependencies.

#51140 play @1.2.7: upgrade to 1.2.7.2 ciserlohn@… update closed Normal
Description

new play version 1.2.7.2

#51139 py-pyne hdf5 byg macports-tickets@… defect new Normal
Description

Although the port builds correctly for py27 and py34, the hdf5 database that is suppose to accompany this fails. The results of nuc_data_make-2.7 --fetch-prebuilt False are shown below:


Making nuc_data at /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pyne/nuc_data.h5
Copying AME 2012 atomic mass data.
Making atomic mass data table.
Traceback (most recent call last):
  File "/opt/local/bin/nuc_data_make-2.7", line 6, in <module>
    main()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pyne/dbgen/nuc_data_make.py", line 155, in main
    make_map[mo](args)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pyne/dbgen/atomic_mass.py", line 155, in make_atomic_mass
    make_atomic_mass_table(nuc_data, build_dir)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pyne/dbgen/atomic_mass.py", line 123, in make_atomic_mass_table
    kdb = tb.openFile(nuc_data, 'a', filters=BASIC_FILTERS)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/tables/_past.py", line 35, in oldfunc
    return obj(*args, **kwargs)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/tables/file.py", line 318, in open_file
    return File(filename, mode, title, root_uep, filters, **kwargs)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/tables/file.py", line 819, in __init__
    root._g_post_init_hook()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/tables/group.py", line 259, in _g_post_init_hook
    set_attr('FILTERS', newfilters)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/tables/attributeset.py", line 403, in _g__setattr
    self._g_setattr(self._v_node, name, stvalue)
  File "tables/hdf5extension.pyx", line 696, in tables.hdf5extension.AttributeSet._g_setattr (tables/hdf5extension.c:7549)
tables.exceptions.HDF5ExtError: HDF5 error back trace

  File "H5A.c", line 634, in H5Awrite
    not an attribute

End of HDF5 error back trace

Can't set attribute 'FILTERS' in node:
 / (RootGroup) ''.
Closing remaining open files:/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pyne/nuc_data.h5...done
#51138 [Port Abandoned] Ports maintained by rmstonecipher rmstonecipher@… defect closed Normal
Description

Macports committer rmstonecipher indicated to me via the Macports irc channel that he is retiring. Thank you Ryan for your service over the years!

#51134 vit broken by explicit perl dependency g5pw@… defect closed Normal
Description

Here's the offending change: https://trac.macports.org/browser/trunk/dports/office/vit/files/patch-vit.pl.diff

22 months ago, vit.pl was changed to use '/usr/bin/env perl5.16'. Vit depends on the perl curses module which implies p5.16-curses, but that can't be installed because it is obsoleted. The vit package was (rightfully) updated to specify p5.22-curses as its dependency last year, but the vit.pl file was not updated. New installs are now broken.

Should vit.pl really specify a perl version at all? Why not just use the selected perl?

#51132 octave-devel-release 4.0.1: doc variant has missing dependency to texlive-fonts-recommended and fails to build mcalhoun@… defect closed Normal
Description

octave-devel-release: The doc variant has a missing dependency to texlive-fonts-recommended.

Without texlive-fonts-recommended the build fails with the following messages:

:info:build mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1095
:info:build This is METAFONT, Version 2.7182818 (TeX Live 2015/MacPorts 2015_9) (preloaded base=mf)
:info:build 
:info:build kpathsea: Running mktexmf ecrm1095
:info:build 
:info:build ! I can't find file `ecrm1095'.
:info:build <*> ...ljfour; mag:=1; nonstopmode; input ecrm1095
:info:build                                                   
:info:build Please type another input file name
:info:build ! Emergency stop.
:info:build <*> ...ljfour; mag:=1; nonstopmode; input ecrm1095
:info:build                                                   
:info:build Transcript written on mfput.log.
:info:build grep: ecrm1095.log: No such file or directory
:info:build mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1095' failed to make ecrm1095.tfm.
:info:build /opt/local/bin/texi2dvi: etex exited with bad status, quitting.
:info:build make[3]: *** [octave.dvi] Error 1
:info:build make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_math_octave-devel/octave-devel-release/work/octave-5162cdfb56d8/doc/interpreter'
:info:build make[2]: *** [all-recursive] Error 1

I build this today with octave-devel-release 4.0.1 on El Capitan 10.11.4.

#51130 nsis: update to 2.51 macports-tickets@… update new Normal
Description

The NSIS package hasn't been updated in years, the current version is 2.51

#51129 pango: update to version 1.40.1 ryandesign@… update closed Normal
Description

Version 1.40.1 (minor bugfixes) has been released as part of the GNOME 3.20.1 stable release process.

Overview of changes between 1.40.0 and 1.40.1
=============================================
- Use $PKG_CONFIG consistently (#764191)
- Fix a PangoWin32FontMap memory leak (#7640890)
#51128 tesseract 3.04.01 New version is available emer@… update new Normal
Description

A minor bug fix release of Tesseract is avalable:

https://github.com/tesseract-ocr/tesseract/releases/tag/3.04.01

#51127 tesseract Training Tools install option emer@… enhancement new Normal
Description

Homebrew supports a --with-training-tools option on installation which would be nice to have in MacPorts as well.

All it needs to do is:

  make training
  make training-install

If it is better aligned with how MacPorts does things, a separate subport instead would be fine too.

#51124 h4h5tools fails to build macports-tickets@… defect new Normal
Description

h4h5tools fails to build during upgrade

#51120 libgda fails to build against vala after 0.32 update devans@… defect closed Normal
Description

vala-0.32 is not backwards compatible.

libgda5 fails to build because of this. configure fails with pkg-config failing to find vapigen-0.30 (vala 0.32 installs vapigen-0.32)

configure: error: Can't locate vapigen-0.30 >= 0.26.0 program
#51118 fswatch @1.9.2: update to 1.9.2 macports-tickets@… update closed Normal
Description

fswatch 1.9.2

#51116 ipe @7.2.2: build fails on Yosemite, undeclared identifier 'NSLayoutGuide'. m7.thon@… defect closed Normal
Description

After fixing #50704, ipe builds on 10.11 but fails on 10.10.5 with the following error

Compiling ipeui_cocoa.cpp...
/usr/bin/clang++ -arch x86_64 -mmacosx-version-min=10.8 -Wdeprecated-declarations -Wall -Wno-sign-conversion -g -Os -stdlib=libc++ -fPIC -x objective-c++ -fobjc-arc  -DIPEUI_COCOA -std=c++11 -x objective-c++ -fobjc-arc  -I/opt/local/include  -c -o ../../build/obj/ipeui/ipeui_cocoa.o ipeui_cocoa.cpp
ipeui_cocoa.cpp:89:5: error: use of undeclared identifier 'NSLayoutGuide'; did you mean 'layoutGuide'?
    NSLayoutGuide *g = [[NSLayoutGuide alloc] init];
    ^~~~~~~~~~~~~
    layoutGuide
ipeui_cocoa.cpp:84:4: note: 'layoutGuide' declared here
id layoutGuide(NSView *owner)
   ^
ipeui_cocoa.cpp:89:26: error: use of undeclared identifier 'NSLayoutGuide'; did you mean 'layoutGuide'?
    NSLayoutGuide *g = [[NSLayoutGuide alloc] init];
                         ^~~~~~~~~~~~~
                         layoutGuide
ipeui_cocoa.cpp:84:4: note: 'layoutGuide' declared here
id layoutGuide(NSView *owner)
   ^
ipeui_cocoa.cpp:89:26: error: bad receiver type 'id (*)(NSView *__strong)'
    NSLayoutGuide *g = [[NSLayoutGuide alloc] init];
                         ^~~~~~~~~~~~~
ipeui_cocoa.cpp:89:20: error: use of undeclared identifier 'g'
    NSLayoutGuide *g = [[NSLayoutGuide alloc] init];
                   ^
ipeui_cocoa.cpp:90:12: error: no visible @interface for 'NSView' declares the selector 'addLayoutGuide:'
    [owner addLayoutGuide:g];
     ~~~~~ ^~~~~~~~~~~~~~
ipeui_cocoa.cpp:92:12: error: use of undeclared identifier 'g'
    return g;
           ^
ipeui_cocoa.cpp:142:15: error: no known instance method for selector 'owningView'
    return [a owningView];  // is a layout guide
              ^~~~~~~~~~
ipeui_cocoa.cpp:256:3: error: type arguments cannot be applied to non-parameterized class 'NSMutableArray'
  NSMutableArray <NSView *> *iViews;
  ^              ~~~~~~~~~~~
8 errors generated.
make[1]: *** [../../build/obj/ipeui/ipeui_cocoa.o] Error 1
make[1]: Leaving directory `/opt/local/var/macports/build/_opt_macports_trunk_dports_graphics_ipe/ipe/work/ipe-7.2.2/src/ipeui'

The problem is that NSLayoutGuide is a new class introduced with 10.11 and so is not available on 10.10 and earlier. See NSLayoutGuide Class Reference for details.

Full build log attached.

#51112 Hexchat-2.10.2 fails to fetch raimue@… defect closed Normal
Description
NuDot:.ssh tking$ sudo port install hexchat
--->  Computing dependencies for hexchat
--->  Fetching distfiles for hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from https://distfiles.macports.org/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://dl.hexchat.net/hexchat/
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://sea.us.distfiles.macports.org/macports/distfiles/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://ykf.ca.distfiles.macports.org/MacPorts/mpdistfiles/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://cjj.kr.distfiles.macports.org/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://nue.de.distfiles.macports.org/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://nou.nc.distfiles.macports.org/pub/macports/distfiles.macports.org/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://lil.fr.distfiles.macports.org/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://aarnet.au.distfiles.macports.org/pub/macports/mpdistfiles/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://osl.no.distfiles.macports.org/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://jog.id.distfiles.macports.org/macports/distfiles/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://jnb.za.distfiles.macports.org/distfiles/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://her.gr.distfiles.macports.org/hexchat
--->  Attempting to fetch hexchat-2.10.2.tar.xz from http://svn.macports.org/repository/macports/distfiles/hexchat
Error: org.macports.fetch for port hexchat returned: fetch failed
Please see the log file for port hexchat for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_irc_hexchat/hexchat/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port hexchat failed
#51110 ipe @7.2.2 +qvoronoi fails to build on Mavericks m7.thon@… defect closed Normal
Description

Hi,

ipe currently fails to build on my Mac (OS 10.9.5). Below is the relevant part of the log. Thanks,

Jeremie

:info:build Compiling ipecanvas_cocoa.cpp...
:info:build /usr/bin/clang++ -arch x86_64 -mmacosx-version-min=10.8 -Wdeprecated-declarations -Wall -Wno-sign-conversion -g -Os -stdlib=libc++ -fPIC -DIPEUI_COCOA -std=c++11 -I../include -I../ipecairo -I/opt/local/include/cairo -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/pixman-1 -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include/libpng16 -I/opt/local/include -x objective-c++ -fobjc-arc   -c -o ../../build/obj/ipecanvas/ipecanvas_cocoa.o ipecanvas_cocoa.cpp
:info:build ipecanvas_cocoa.cpp:48:46: error: no visible @interface for 'NSGraphicsContext' declares the selector 'CGContext'
:info:build   return [[NSGraphicsContext currentContext] CGContext];
:info:build           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ^~~~~~~~~
:info:build 1 error generated.
#51108 mono @3.12.1_1 Update to 4.2.3.4 macports-tickets@… update new Normal
Description

Hi,

Mono was recently updated to version 4.2.3.4, but the version available on MacPorts is 3.12.1. This is a complex port, so while I can attempt to do it myself, I'm wondering if someone else can update the Portfile.

Thanks, Chris

#51107 gnuradio 3.7.9.1 ImportError: No module named gnuradio michaelld@… defect closed Normal
Description

Successfully installed gnuradio and companion working fine but having issues running python script through terminal.

ImportError: No module named gnuradio

Running OSX 10.11.4 and python 2.7. Following the troubleshooting steps mentioned in Ticket #28315, "ls /opt/local/lib/python2.7/site-packages" returns:

xcbgen

And "port installed | grep gnuradio" returns:

gnuradio-devel @20160331_0+docs+grc+jack+portaudio+qtgui+sdl+swig+uhd+wavelet+wxgui (active)

It appears the python modules were never installed? I appreciate the help.

#51106 Post-commit hook updating guide seems broken ryandesign@… defect closed Low
Description

I just committed r147608 with a change to the guide. Previously, changing the guide would cause the web copy at guide.macports.org to be updated almost immediately, but that does not seem to have happened this time.

Can you look into it?

#51104 Patch: removed 'file' commands from 'TCL Extensions' section of Portfile reference macports-tickets@… submission closed Normal
Description

These are standard TCL commands, not extensions

#51102 defect: openbrowser can't find com.apple.LaunchServices.plist ryandesign@… defect new Normal
Description

openbrowser reports the following error:

starting help: openbrowser /opt/local/share/doc/CalculiX/cgx_2.10/cgx/cgx.html
parse_plist_file: file [/Users/marbre/Library/Preferences/com.apple.LaunchServices.plist] does not exist! at /opt/local/bin/openbrowser line 19.

In el capitan the plist is located in ~/Library/Preferences/com.apple.LaunchServices/com.apple.launchservices.secure.plist.

#51100 octave-devel-release @4.0.0_6: update to 4.0.1 mcalhoun@… update closed Normal
Description

octave 4.0.1 was release on March 21st. I've moved the release subport to version 4.0.1.

#51099 Tomcat6 won't build on Mac OS X 10.6.8, Snow Leopard, because of missing tomcat-native.tar.gz file blair@… defect new Normal
Description
build-manifests:
    [mkdir] Created dir: /opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_java_tomcat6/tomcat6/work/apache-tomcat-6.0.35-src/output/manifests
     [copy] Copying 8 files to /opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_java_tomcat6/tomcat6/work/apache-tomcat-6.0.35-src/output/manifests

download:

testexist:
     [echo] Testing  for /opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_java_tomcat6/tomcat6/work/apache-tomcat-6.0.35-src/Repository/tomcat-native-1.1.22/tomcat-native.tar.gz

downloadfile-2:
    [mkdir] Created dir: /opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_java_tomcat6/tomcat6/work/apache-tomcat-6.0.35-src/Repository/tomcat-native-1.1.22

proxyflags:

setproxy:

trydownload.check:

trydownload:

proxyflags:

setproxy:

trydownload.check:

trydownload:

BUILD FAILED
/opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_java_tomcat6/tomcat6/work/apache-tomcat-6.0.35-src/build.xml:783: The following error occurred while executing this line:
/opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_java_tomcat6/tomcat6/work/apache-tomcat-6.0.35-src/build.xml:760: Failed to download [/opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_java_tomcat6/tomcat6/work/apache-tomcat-6.0.35-src/Repository/tomcat-native-1.1.22/tomcat-native.tar.gz]. All download sources are unavailable.

Total time: 1 second
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_java_tomcat6/tomcat6/work/apache-tomcat-6.0.35-src" && ant download -Dversion=6.0.35 -Dversion.build=35 -Dbase.path=/opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_java_tomcat6/tomcat6/work/apache-tomcat-6.0.35-src/Repository -Dnsis.exe=/opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_java_tomcat6/tomcat6/work/apache-tomcat-6.0.35-src/.bogus -Dcommons-beanutils.jar=/opt/local/share/java/commons-beanutils.jar -Dcommons-collections.jar=/opt/local/share/java/commons-collections.jar -Dcommons-launcher.jar=/opt/local/share/java/commons-launcher.jar -Dcommons-daemon.jar=/opt/local/share/java/commons-daemon.jar -Dcommons-digester.jar=/opt/local/share/java/commons-digester.jar -Dcommons-el.jar=/opt/local/share/java/commons-el.jar -Dcommons-logging.jar=/opt/local/share/java/commons-logging.jar -Dcommons-logging-api.jar=/opt/local/share/java/commons-logging-api.jar -Dcommons-modeler.jar=/opt/local/share/java/commons-modeler.jar -Dcommons-httpclient.jar=/opt/local/share/java/commons-httpclient.jar -Dcommons-pool.jar=/opt/local/share/java/commons-pool.jar -Dcommons-dbcp.jar=/opt/local/share/java/commons-dbcp.jar -Dcommons-fileupload.jar=/opt/local/share/java/commons-fileupload.jar -Dregexp.jar=/opt/local/share/java/jakarta-regexp.jar -DxercesImpl.jar=/opt/local/share/java/xercesImpl.jar -Dxml-apis.jar=/opt/local/share/java/xml-apis.jar -Dlog4j.jar=/opt/local/share/java/jakarta-log4j.jar -Djmx.lib=/opt/local/share/java -Djunit.jar=/opt/local/share/java/junit.jar -Dsaxpath.jar=/opt/local/share/java/saxpath.jar -Djasper.home=/opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_java_tomcat6/tomcat6/work/apache-tomcat-6.0.35-src/../jasper 
Exit code: 1

The eight manifests can be found, the created directory for downloadfile-2 exists, but the testexist file, tomcat-native.tar.gz obviously, does not.

#51098 Update marx macports-tickets@… update closed Normal
Description

Update port: marx (in science) from version 5.2 to 5.3 (There was an mixture of tabs and spaces in the Portfile before. My editor converted all of them to spaces when I edited the file.)

#51096 lal @6.15.2 build failure ram@… defect closed Normal
Description

I'm using OSX 10.11.4 with Xcode 7.3 and this is the error message (the log file is attached)

sudo port install lal
--->  Computing dependencies for lal
--->  Fetching archive for all
--->  Attempting to fetch lal-6.15.2_0+swig_python.darwin_15.x86_64.tbz2 from https://packages.macports.org/lal
--->  Attempting to fetch lal-6.15.2_0+swig_python.darwin_15.x86_64.tbz2 from http://fco.it.packages.macports.org/mirrors/macports-packages/lal/lal
--->  Attempting to fetch lal-6.15.2_0+swig_python.darwin_15.x86_64.tbz2 from http://her.gr.packages.macports.org/lal
--->  Fetching distfiles for lal
--->  Verifying checksums for lal
--->  Extracting lal
--->  Configuring lal
--->  Building lal
Error: org.macports.build for port lal returned: command execution failed
Please see the log file for port lal for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_lal/lal/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port lal failed

Cheers

Chris

#51095 libtool 2.4.6 doesn't seem to find the source on any of the mirrors larryv@… defect new Normal
Description

I confirmed host resolution with nslookup, but my chrome browser fails to find the directory the libtool port is looking in.

#51094 z3 New port macports-tickets@… submission new Normal
Description

This is a new port of a software that is not in macports yet. Some other ports might need this as a dependency.

#51088 Add new php module "php-meminfo" in distribution macports-tickets@… request new Normal
Description

Hi,

It's possible to add a new module of php.

https://github.com/BitOne/php-meminfo

Thanks

Bertrand

#51087 New port: asciidoctor macports-tickets@… submission closed Normal
Description

Asciidoctor is a text processor, written in Ruby, that implements the AsciiDoc syntax as originally devised by the similarly named Python project. Contrary to the Python AsciiDoc version, which seems dormant, Asciidoctor is actively being worked one and extended.

#51084 py27-pyqwt fails to compile on OSX 10.11.4 when installing gnuradio michaelld@… defect new Normal
Description

Can't get py27-pyqwt to compile. This is mainly an issue because gnuradio requires this by default.

#51082 dblatex @0.3.5 update to 0.3.7 cal@… update closed Normal
Description

Could dblatex be updated to version 0.3.7?

Here are two files to update dblatex from actual version to 0.3.7.

The file dblatex-0.3.5r4-0.3.7.diff to update the Portfile .

The patch file patch-0-3-7-setup.py-remove-debian-installer.diff modify the setup.py file of dblatex by commenting an import specific to Debian.

#51081 pango @1.40.0 - build failing ryandesign@… defect new Normal
Description

Pango build is failing (for me) with the following error:

:info:build In file included from pangocairo-coretextfont.c:32:
:info:build ./pangocairo-coretext.h:28:10: fatal error: 'cairo-quartz.h' file not found

The compile step failing is

/usr/bin/clang -arch x86_64 -DHAVE_CONFIG_H -I. -I.. -DG_LOG_DOMAIN=\"Pango\" -DPANGO_ENABLE_BACKEND -DPANGO_ENABLE_ENGINE -DSYSCONFDIR=\"/Volumes/MacHD/opt/local/etc\" -DLIBDIR=\"/Volumes/MacHD/opt/local/lib\" -I.. -I.. -DG_DISABLE_CAST_CHECKS -D_REENTRANT -I/Volumes/MacHD/opt/local/include/glib-2.0 -I/Volumes/MacHD/opt/local/lib/glib-2.0/include -I/Volumes/MacHD/opt/local/include -I/opt/X11/include -I/opt/X11/include/freetype2 -I/Volumes/MacHD/opt/local/include/freetype2 -I/Volumes/MacHD/opt/local/include -I/Volumes/MacHD/opt/local/include/libpng16 -I/opt/X11/include -I/opt/X11/include/cairo -I/Volumes/MacHD/opt/local/include/pixman-1 -I/opt/X11/include -I/opt/X11/include/freetype2 -I/Volumes/MacHD/opt/local/include/freetype2 -I/Volumes/MacHD/opt/local/include -I/Volumes/MacHD/opt/local/include/libpng16 -I/opt/X11/include -I/Volumes/MacHD/opt/local/include/harfbuzz -I/Volumes/MacHD/opt/local/include/glib-2.0 -I/Volumes/MacHD/opt/local/lib/glib-2.0/include -I/Volumes/MacHD/opt/local/include -I/Volumes/MacHD/opt/local/include/freetype2 -I/Volumes/MacHD/opt/local/include -I/Volumes/MacHD/opt/local/include/libpng16 -I/opt/X11/include -I/opt/X11/include/freetype2 -I/Volumes/MacHD/opt/local/include/freetype2 -I/Volumes/MacHD/opt/local/include -I/Volumes/MacHD/opt/local/include/libpng16 -I/Volumes/MacHD/opt/local/include -pipe -Os -arch x86_64 -Wall -MT pangocoretext-shape.lo -MD -MP -MF .deps/pangocoretext-shape.Tpo -c pangocoretext-shape.c -o pangocoretext-shape.o >/dev/null 2>&1

cairo-quartz.h does exist on my system as I have cairo @1.14.6_0+quartz+x11 installed, but this puts the file into /opt/local/include/cairo/cairo-quartz.h, which is not on the list of paths included on the compile command.

#51079 fossil @1.34_1+readline build error: does not find fuse.h ciserlohn@… defect new Normal
Description

On my installation (MacPorts 2.3.4 on OS X 10.10.5), fossil (@1.34_1+readline) does not find fuse.h. It is enough to add -I /opt/local/include/osxfuse to the Makefile.

#51078 tensix builder has stopped ryandesign@… defect closed Normal
Description

The tensix builder had an exception and is no longer working.

#51077 openmpi-devel: openmpi-dev-3727-g7523357.tar.bz2 does not exist sean@… defect new Normal
Description

hello,

updating ports when received this error

error:checksum org.macports.checksum for port openmpi-devel-clang38 returned: openmpi-dev-3727-g7523357.tar.bz2 does not exist in /opt/local/var/macports/distfiles/openmpi-devel
:debug:checksum Error code: NONE

this version "openmpi-dev-3727-g7523357" doesn't exist so there's nothing to download or checksum

https://www.open-mpi.org/nightly/master/

"Latest snapshot version: dev-3788-g7b803ac"
#51074 matio @1.5.3_2: bump revision to build against hdf5 @1.10.0 macports-tickets@… defect closed Normal
Description

matio needs to be rebuilt as the API for hdf5 has changed. A cflag has been added for backward compatibility with hdf5 1.8.x API..

#51073 squid @2.7.STABLE9 linking fails due to SSLv2 use jmr@… defect closed Normal
Description

sudo port selfupdate ; sudo port clean --dist squid ; sudo port upgrade squid fails with:

:info:build /usr/bin/clang  -pipe -Os -arch x86_64 -D_REENTRANT  -L/opt/local/lib -Wl,-headerpad_max_install_names -arch x86_64 -o squid access_log.o acl.o asn.o authenticate.o cache_cf.o CacheDigest.o cache_manager.o carp.o cbdata.o client_db.o client_side.o client_side_rewrite.o client_side_storeurl_rewrite.o comm.o comm_kqueue.o debug.o delay_pools.o disk.o dns_internal.o errorpage.o event.o errormap.o external_acl.o fd.o filemap.o forward.o fqdncache.o ftp.o gopher.o helper.o  http.o HttpStatusLine.o HttpHdrCc.o HttpHdrRange.o HttpHdrContRange.o HttpHeader.o HttpHeaderTools.o HttpBody.o HttpMsg.o HttpReply.o HttpRequest.o icmp.o icp_v2.o icp_v3.o ident.o internal.o ipc.o ipcache.o  locrewrite.o logfile.o logfile_mod_daemon.o logfile_mod_stdio.o logfile_mod_syslog.o logfile_mod_udp.o main.o mem.o MemPool.o MemBuf.o mime.o multicast.o neighbors.o net_db.o Packer.o pconn.o peer_digest.o peer_monitor.o peer_select.o peer_sourcehash.o peer_userhash.o redirect.o store_rewrite.o referer.o refresh.o refresh_check.o send-announce.o  ssl.o ssl_support.o stat.o StatHist.o String.o stmem.o store.o store_io.o store_client.o store_digest.o store_dir.o store_key_md5.o store_log.o store_rebuild.o store_swapin.o store_swapmeta.o store_swapout.o store_update.o tools.o unlinkd.o url.o urn.o useragent.o wccp.o wccp2.o whois.o  repl_modules.o auth_modules.o store_modules.o globals.o string_arrays.o -L../lib repl/libheap.a repl/liblru.a fs/libufs.a fs/libaufs.a fs/libdiskd.a fs/libcoss.a fs/libnull.a auth/libnegotiate.a auth/libntlm.a auth/libdigest.a auth/libbasic.a -L/opt/local/lib -lssl -lcrypto -lmiscutil -lpthread -lm  
:info:build Undefined symbols for architecture x86_64:
:info:build   "_SSLv2_client_method", referenced from:
:info:build       _sslCreateClientContext in ssl_support.o
:info:build   "_SSLv2_server_method", referenced from:
:info:build       _sslCreateServerContext in ssl_support.o
:info:build ld: symbol(s) not found for architecture x86_64
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build make[3]: *** [squid] Error 1
:info:build make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_squid/squid/work/squid-2.7.STABLE9/src'
:info:build make[2]: *** [all-recursive] Error 1
#51069 poppler @0.42.0_1: nss support breaks poppler on 10.6 devans@… defect closed Normal
Description

After r147476 I get this error when using poppler via py-poppler-qt4:

$ python2.7 /opt/local/share/examples/py27-poppler-qt4/demo.py file.pdf
Traceback (most recent call last):
  File "demo.py", line 3, in <module>
    import popplerqt4
ImportError: dlopen(/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/popplerqt4.so, 2): Symbol not found: _NSS_CMSSignerInfo_Verify
  Referenced from: /opt/local/lib/libpoppler.59.dylib
  Expected in: flat namespace
 in /opt/local/lib/libpoppler.59.dylib

The attached patch disables nss.

Note that, contrary to what is advertised by ./configure --help, the --disable-nss option is not recognized; instead the --disable-libnss option acts as desired. Anyway, this and the fact that among the final lines of the configure log there is

Building poppler with support for:
[...]
  use nss:             
[...]

instead of the expected

Building poppler with support for:
[...]
  use nss:             no
[...]

(i.e., the nss line is empty after the colon), make me suspect a little bug in the configure script.

Of course it would be better to fix nss support on 10.6, but having a working poppler is more important to me.

#51068 p5.22-socket6 0.270 does not build on PPC Mac OS X 10.4.11, Tiger macports-tickets@… defect new Normal
Description

The failure is:

:info:build "/opt/local/bin/perl5.22" "/opt/local/lib/perl5/5.22/ExtUtils/xsubpp" -noprototypes -typemap "/opt/local/lib/perl5/5.22/ExtUtils/typemap"  Socket6.xs > Socket6.xsc && mv Socket6.xsc Socket6.c
:info:build /opt/local/bin/gcc-apple-4.2 -c   -pipe -Os -fno-common -DPERL_DARWIN -I/opt/local/include -fno-strict-aliasing -I/opt/local/include -D_FORTIFY_SOURCE=2 -arch ppc -O3   -DVERSION=\"0.27\" -DXS_VERSION=\"0.27\"  "-I/opt/local/lib/perl5/5.22/darwin-thread-multi-2level/CORE"   Socket6.c
:info:build In file included from Socket6.xs:100:
:info:build inet_ntop.c:53: error: conflicting types for 'inet_ntop'
:info:build /usr/include/arpa/inet.h:105: error: previous declaration of 'inet_ntop' was here
:info:build Socket6.xs: In function 'XS_Socket6_inet_ntop':
:info:build Socket6.xs:544: warning: format '%d' expects type 'int', but argument 3 has type 'STRLEN'
:info:build Socket6.xs:544: warning: format '%d' expects type 'int', but argument 4 has type 'STRLEN'
:info:build Socket6.xs: In function 'XS_Socket6_unpack_sockaddr_in6':
:info:build Socket6.xs:623: warning: format '%d' expects type 'int', but argument 3 has type 'STRLEN'
:info:build Socket6.xs:623: warning: format '%d' expects type 'int', but argument 4 has type 'long unsigned int'
:info:build Socket6.xs: In function 'XS_Socket6_unpack_sockaddr_in6_all':
:info:build Socket6.xs:659: warning: format '%d' expects type 'int', but argument 3 has type 'STRLEN'
:info:build Socket6.xs:659: warning: format '%d' expects type 'int', but argument 4 has type 'long unsigned int'
:info:build Socket6.xs: In function 'XS_Socket6_getipnodebyaddr':
:info:build Socket6.xs:910: warning: format '%d' expects type 'int', but argument 3 has type 'STRLEN'
:info:build make: *** [Socket6.o] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_perl_p5-socket6/p5.22-socket6/work/Socket6-0.27'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_perl_p5-socket6/p5.22-socket6/work/Socket6-0.27" && /usr/bin/make -w all 
:info:build Exit code: 2

I reported that case to bug-Socket6 [at] rt.cpan.org, as mentioned on https://rt.cpan.org/Public/Bug/Report.html?Queue=Socket6.

#51067 port request: haskell-stack macports-tickets@… request new Normal
Description

http://docs.haskellstack.org/en/stable/README/

The Haskell Tool Stack

"stack is a cross-platform program for developing Haskell projects. It is aimed at Haskellers both new and experienced."

Supported by brew: http://docs.haskellstack.org/en/stable/install_and_upgrade/#mac-os-x

#51065 gnome-icon-theme broken on OS X 10.11.4 macports-tickets@… defect closed Normal
Description
sudo port install gnome-icon-theme
Password:
--->  Fetching distfiles for gnome-icon-theme
--->  Verifying checksums for gnome-icon-theme
--->  Extracting gnome-icon-theme
--->  Configuring gnome-icon-theme
Error: gnome-icon-theme has been replaced by gnome-themes-standard; please install that instead.
Error: org.macports.configure for port gnome-icon-theme returned: obsolete port
Please see the log file for port gnome-icon-theme for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_gnome-icon-theme/gnome-icon-theme/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port gnome-icon-theme failed
#51064 gtkglextmm port broken on OS X 10.11.4 billitch@… defect new Normal
Description
Error: org.macports.build for port gtkglextmm returned: command execution failed
Please see the log file for port gtkglextmm for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_gtkglextmm/gtkglextmm/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port gtkglextmm failed
#51063 gstreamer1-gst-plugins-bad uses qt5 without declaring a dependency on it devans@… defect closed Normal
#51062 hdf5: update to 1.10.0 mmoll@… update closed Normal
Description

HDF5 1.10.0 has been released.

#51061 Building error in gspell devans@… defect closed Normal
Description

I tried to update my packages yesterday, and got an error when updating both gedit and gedit-plugins. The error is related to the gspell package. Essentially, what the error says is:

/System/Library/Frameworks/Foundation.framework/Headers/NSObjCRuntime.h:402:19: error: unknown type name 'NSString'; did you mean 'GString'?

There are dozens of the same error in multiple files. I have attached the complete error log to this message.

For the record, I am using the latest MacPorts (2.3.4) on a El Capitan Macbook Pro with the most recent Xcode (7.3).

Does anybody have a clue on how I can fix this?

#51059 Requesting polarssl (dev) to be added to macports macports-tickets@… request new Normal
Description

Recently I had to compile a project snatched off github and it depended on the polarsssl libraries. Would it be possible to add libpolarssl-dev to macports ?

Thanks

#51056 pure 0.64 update ryandesign@… enhancement closed Normal
Description

Minor update (bump to revision 3) which adds a patch that fixes an issue with Pure running as a VST plug-in.

#51053 Allow compiling valgrind 3.11.0 on El Capitan raimue@… enhancement closed Normal
Description

According to release notes, 3.11.0 added preliminary support for OS X 10.11, and appears to compile and run OK (using 10.11.4 and Xcode 7.3). I've attached a patch based on the fix for #49155, where the version allowed is bumped to 10.11.

#51051 erlang port - broken checksums ciserlohn@… defect new Normal
Description

Mac OS X 10.10.5, Xcode-7.2.1, current Macports.

  port upgrade outdated
--->  Computing dependencies for erlang
--->  Fetching archive for erlang
--->  Attempting to fetch erlang-18.3_0+hipe+ssl+wxwidgets.darwin_14.x86_64.tbz2 from https://packages.macports.org/erlang
--->  Attempting to fetch erlang-18.3_0+hipe+ssl+wxwidgets.darwin_14.x86_64.tbz2 from http://fco.it.packages.macports.org/mirrors/macports-packages/erlang/erlang
--->  Attempting to fetch erlang-18.3_0+hipe+ssl+wxwidgets.darwin_14.x86_64.tbz2 from http://her.gr.packages.macports.org/erlang
--->  Fetching distfiles for erlang
--->  Verifying checksums for erlang
Error: Checksum (rmd160) mismatch for otp_src_18.3.tar.gz
Error: Checksum (sha256) mismatch for otp_src_18.3.tar.gz
Error: Checksum (rmd160) mismatch for otp_doc_man_18.3.tar.gz
Error: Checksum (sha256) mismatch for otp_doc_man_18.3.tar.gz
Error: Checksum (rmd160) mismatch for otp_doc_html_18.3.tar.gz
Error: Checksum (sha256) mismatch for otp_doc_html_18.3.tar.gz
Error: org.macports.checksum for port erlang returned: Unable to verify file checksums
Please see the log file for port erlang for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_erlang/erlang/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
$ 

Attaching the log file.

#51050 rtl-sdr: Fix incorrect checksums michaelld@… defect closed Normal
Description

The Portfile checksums were somehow wrong, correct checksums are attached.

#51047 Error: org.macports.activate for port py27-jupyter_core returned macports-tickets@… defect closed Normal
Description

Hi,

When I run "sudo port upgrade outdated". I got the following error. Now I cannot run jupyter. Thanks for help in advance.

--->  Computing dependencies for py27-jupyter_client
--->  Dependencies to be installed: py27-jupyter_core
--->  Activating py27-jupyter_core @4.1.0_0
Error: org.macports.activate for port py27-jupyter_core returned: Image error: /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/jupyter.py already exists and does not belong to a registered port.  Unable to activate port py27-jupyter_core. Use 'port -f activate py27-jupyter_core' to force the activation.
Error: Failed to install py27-jupyter_core
Please see the log file for port py27-jupyter_core for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-jupyter_core/py27-jupyter_core/main.log
Error: The following dependencies were not installed: py27-jupyter_core
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
#51043 [Port Abandoned] Ports maintained by josephholsten josephholsten@… defect closed Normal
Description

From what I can tell, no activity in years in trac or commit even though he has a @macports.org account since 2010

all tickets

all tickets

#51039 vte fails to build if an older version is active (builds against installed content instead of local content) devans@… defect assigned Normal
Description
$ sudo port -v -s upgrade vte
--->  Computing dependencies for vte.
--->  Building vte
Executing:  cd "/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_gnome_vte/vte/work/vte-0.44.0" && /usr/bin/make -j8 -w all CC="/usr/bin/clang -arch x86_64" 
make: Entering directory `/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_gnome_vte/vte/work/vte-0.44.0'
/Applications/Xcode.app/Contents/Developer/usr/bin/make  all-recursive
make[1]: Entering directory `/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_gnome_vte/vte/work/vte-0.44.0'
Making all in src
make[2]: Entering directory `/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_gnome_vte/vte/work/vte-0.44.0/src'
/Applications/Xcode.app/Contents/Developer/usr/bin/make  all-am
make[3]: Entering directory `/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_gnome_vte/vte/work/vte-0.44.0/src'
rm -f vte_2_91_vala.stamp && echo stamp > vte_2_91_vala.stamp-t
CDPATH="${ZSH_VERSION+.}:" && cd . && /opt/local/bin/valac --target-glib=2.38 --vapidir=. --girdir=. --pkg=posix --pkg=gio-2.0 --pkg=gtk+-3.0 --gresources app.gresource.xml  -D GTK_3_16  -C app.vala config.vapi vte-2.91.vapi
app.vala:370.5-370.40: error: Vte.Terminal.set_color_cursor_foreground is not available in vte-2.91 0.43.2. Use vte-2.91 >= 0.44
    terminal.set_color_cursor_foreground(App.Options.get_color_cursor_foreground());
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Compilation failed: 1 error(s), 0 warning(s)
make[3]: *** [vte_2_91_vala.stamp] Error 1
make[3]: Leaving directory `/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_gnome_vte/vte/work/vte-0.44.0/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_gnome_vte/vte/work/vte-0.44.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_gnome_vte/vte/work/vte-0.44.0'
make: *** [all] Error 2
make: Leaving directory `/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_gnome_vte/vte/work/vte-0.44.0'
Command failed:  cd "/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_gnome_vte/vte/work/vte-0.44.0" && /usr/bin/make -j8 -w all CC="/usr/bin/clang -arch x86_64" 
Exit code: 2
Error: Failed to build vte: command execution failed
Error: See /opt/local/var/macports/logs/_Users_jeremy_src_macports_trunk_dports_gnome_vte/vte/main.log for details.
Error: Follow http://guide.macports.org/#project.tickets to report a bug.

$ port installed vte
The following ports are currently installed:
  vte @0.43.2_0 (active)

$ port info vte
vte @0.44.0 (gnome)
Variants:             glade, universal

Description:          VTE is a library (libvte) implementing a terminal emulator widget for GTK+, and a minimal sample
                      application (vte) using that. Vte is mainly used in gnome-terminal, but can also be used to embed a
                      console/terminal in games, editors, IDEs, etc.
Homepage:             https://wiki.gnome.org/Apps/Terminal/VTE

Extract Dependencies: xz
Build Dependencies:   pkgconfig, intltool, gtk-doc, autoconf, automake, libtool
Library Dependencies: gtk3, gnutls, zlib, vala, gobject-introspection
Runtime Dependencies: gnome-themes-standard
Platforms:            darwin
License:              LGPL
Maintainers:          devans@macports.org, openmaintainer

The build succeeded after deactivating the active vte port.

#51037 nghttp2 @1.9.1_0: update to 1.9.2 macports-tickets@… update closed Normal
Description

nghttp2 has been updated to version 1.9.2. New this version:

  • nghttpx: Fix crash with backend failure
  • nghttpx: Better distribute load to backend h2 servers
  • nghttpx: Fix error messages on deprecated mode
  • nghttpx: Fix bug that logger wrote string which was not NULL-terminated
  • nghttpx: Fix bug that proxy with HTTP/1.1 CONNECT did not work
#51035 Error: Processing of port gtkglextmm failed billitch@… defect new Normal
Description

Mac OS X El Capitan (Version 10.11.1)
Port Version 2.3.4

Error: org.macports.build for port gtkglextmm returned: command execution failed
#51034 Messages while installing gcr 3.20.0 on Mac OS X 10.6.8, Snow Leopard devans@… defect closed Normal
Description

While installing for the first this package, required by something else, I could read:

Please add the files
  codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
  progtest.m4
from the /opt/local/share/aclocal directory to your autoconf macro directory
or directly to your aclocal.m4 file.
You will also need config.guess and config.sub, which you can get from
ftp://ftp.gnu.org/pub/gnu/config/.

What does that mean? What should I perform? And when?

#51030 snort @2.9.8.0: Update to 2.9.8.2 jul_bsd@… update closed Normal
Description

snort has been updated to version 2.9.8.2. New this version:

  • New additions
    • Future-flow and DNS API exposed to lua detector.
    • Double VLAN tagging support.
  • Improvements
    • Performance improvements to AppID.
    • Stability improvements to file and ftp_telnet preprocessor.
    • Fixed several issues with SDF and obfuscation.
    • Resolved an issue of improper handling of malformed DNS host in AppID.
    • HTTP PAF accepts all tokens between method and version strings in a request URI.
    • Resolved snort build issue with "--disable-perfprofiling" configure option.
    • Enhanced mime parsing by adding support for detecting files after unknown headers and no headers.
    • Fixed issue with gzip decompression. If the server response specifies Content-Encoding as GZIP, but no Content-Length field for HTTP ver 1.0.
    • End of Header(EOH) identification for HTTP response header spanning multiple packets.
    • Improved packet reassembly for HTTP.
    • Fixed Flash LZMA decompression issue.
#51025 Metis won't build with Xcode 7.3 sean@… defect assigned Normal
Description

Metis will not install from source with Xcode 7.3. It did build with Xcode 7.2.1 and it installs fine as a binary. I have attached a log file. The following two links suggest that it is actually a compiler bug in LLVM, but I don't know if they are correct or not: https://github.com/Homebrew/homebrew-science/issues/3461

https://llvm.org/bugs/show_bug.cgi?id=27059

https://groups.google.com/forum/#!topic/spack/D9qt4BDv5yI

#51024 bump p5-net-nfdump to version 1.19 devans@… update closed Normal
Description

Upgrade pf-net-nfdump to the latest version.

#51023 Libnetpbm 10.74.00 build failure ryandesign@… defect closed Normal
Description

Attempting to build libnetpbm on OS X 10.6.8 gives

:info:build Undefined symbols:
:info:build   "_strndup", referenced from:
:info:build       _pbm_loadbdffont in libpbmfont.o
:info:build ld: symbol(s) not found
:info:build collect2: ld returned 1 exit status
:info:build gnumake[1]: *** [libnetpbm.11.74.dylib] Error 1
:info:build gnumake[1]: *** Waiting for unfinished jobs....
:info:build ranlib libnetpbm.a
:info:build gnumake[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_netpbm/libnetpbm/work/advanced/lib'
:info:build gnumake: *** [lib/all] Error 2
#51022 Problem installing lgeneral during building phase. ryandesign@… defect assigned Normal
Description

I've been trying to install lgeneral recently using macports and during the building phase of the installation I always get an error that says "Error: org.macports.build for port lgeneral returned: command execution failed." I've tried cleaning and reinstalling several times and I've even tried just building lgeneral myself from its source code that I download from SourceForge, but that doesn't work and I'm definitely not computer savvy enough to make it work. I'm running Mac OS X El Capitan version 10.11.4 on a MacBook Pro with a 2.5 GHz Intel Core i5 processor. I'm pretty sure I've installed all of the missing Xcode command line tools by running "xcode-select --install." It seems that the port hasn't been updated by macports for a few years now because the version that macports downloads is something like 1.1.1, while the version available on SourceForge is 1.3.1. Maybe it just isn't compatible with modern Apple computers anymore but I remember installing lgeneral using macports probably in 2007 or 2008, and even then it could sometimes be a little buggy, but I also remember the game being an absolute blast to play so if there's anything I can do, besides installing Ubuntu and compiling and playing it there, I'd greatly appreciate it.

#51021 SSL certificate has been expired ryandesign@… defect closed High
Description

I was not able to selfupdate the subversion port tree via https. The following command let me know that the SSL certificate was valid until Apr 1 01:19:52 2016 GMT.

svn ls https://svn.macports.org/repository/macports/trunck/dports
#51017 libopenraw @0.0.9: fix build with jpeg when boolean patch is removed devans@… defect assigned Normal
Description

This patch fixes the build of libopenraw when the boolean patch is removed from the jpeg port (#51013). However, it will cause libopenraw to fail to build until that change is made to the jpeg port, so it should not be applied until after the change is made in the jpeg port.

#51016 gle-graphics @4.2.5: fix build failure with jpeg without boolean patch john@… defect closed Normal
Description

This patch fixes a build failure of gle-graphics @4.2.5 (see #51015) when the jpeg port's boolean patch is removed (see #51013).

#51015 gle-graphics: update to 4.2.5 john@… update closed Normal
Description

This patch updates gle-graphics to 4.2.5.

#51014 jpeg: update to 9b ryandesign@… update new Normal
Description

jpeg should be updated to 9b. This would also be a good time to remove the boolean patch (see #51013).

#51011 chromedriver: update to 2.21 ryandesign@… update closed Normal
Description

Bumps the minor version from 2.20 to 2.21

#51006 sqlite3 @3.11.1_1: update to 3.12.0 mww@… update closed Normal
Description

sqlite3 has been updated to version 3.12.0. See http://www.sqlite.org/releaselog/3_12_0.html for details.

#50999 py27-theano @0.8.0_0 needs update to 0.8.1 for XCode 7.3 compatibility stromnov@… update closed Normal
Description

py27-theano builds fine, but stopped working with latest XCode; just doing "import theano" in Python throws a lot of clang errors.

According to https://github.com/Theano/Theano/issues/4277 , this has recently been fixed and is part of the 0.8.1 release (see https://pypi.python.org/pypi/Theano/0.8.1 ).

#50997 protobuf3-cpp @0.0.0.2 update to beta2 blair@… update new Normal
Description

Current port is alpha-3 but beta-2 is now available. This is a simple update and also using version numbers to match i.e. beta-2 = b2, beta-3 = b3

#50995 pspp - package dependencies should contain adwaita-icon-theme dependency snc@… defect closed Normal
Description

The pspp package should contain the adwaita-icon-theme as dependency. Otherwise the psppire gui does not show the +/- signs in the variable view when editing number values. This is relevant for the pspp-0.10.0 version which uses gtk3.

See: http://savannah.gnu.org/bugs/?47252 in upstream

In Debian the adwaita-icon-theme is already contained in the gtk3, but I guess this is not the case in macports.

1 2 3 4 5 6 7 8 9 10 11 12 13 14
Note: See TracQuery for help on using queries.