Custom Query (50762 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (22 - 24 of 50762)

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
Ticket Resolution Summary Owner Reporter
#61202 invalid squid 4.13 HTTPS Sites Extremely Slow jmroot (Joshua Root) essandess (Steve Smith)
Description

squid 4.13 is extremely slow when accessing TLS-secured sites. Does anyone else observe this issue?

Troubleshooting, using the configuration /opt/local/etc/squid/squid.conf.default, with and without the directive:

always_direct allow all

I don't see any issues in access.log or cache.log.

Comparing Privoxy to squid download times using curl:

Privoxy proxy download time:

time curl --proxy localhost:8118 https://www.youtube.com/watch?v=dQw4w9WgXcQ 1> /dev/null 
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  518k    0  518k    0     0   682k      0 --:--:-- --:--:-- --:--:--  682k

real	0m0.784s
user	0m0.019s
sys	0m0.018s

Squid 4.13 proxy download time (times out with curl, eventually loads using Safari):

time curl --proxy localhost:3128 https://www.youtube.com/watch?v=dQw4w9WgXcQ 1> /dev/null 
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:04:00 --:--:--     0curl: (56) Received HTTP code 503 from proxy after CONNECT

real	4m0.493s
user	0m0.017s
sys	0m0.027s

On the other hand, HTTP access is very fast:

time curl --proxy jacquard:3128 http://earlyconifers.myspecies.info 1> /dev/null
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 46246    0 46246    0     0  5645k      0 --:--:-- --:--:-- --:--:-- 5645k

real	0m0.028s
user	0m0.005s
sys	0m0.009s
#61201 fixed root6: 10.7-10.8 build + portfile issues cjones051073 (Chris Jones) chrstphrchvz (Christopher Chavez)
Description

The 10.7-10.8 builds have been failing. In some builds such as the most recent one (2020-09-18 11:01:24), C++14 code (usage of make_unique) is trying to be compiled while using -std=c++11:

In file included from /opt/local/var/macports/build/_opt_bblocal_var_buildworker_ports_build_ports_science_root6/root6/work/root-6-22-02/core/base/v7/src/RError.cxx:17:
/opt/local/var/macports/build/_opt_bblocal_var_buildworker_ports_build_ports_science_root6/root6/work/root-6-22-02/core/base/v7/inc/ROOT/RError.hxx:142:55: error: no member named 'make_unique' in namespace 'std'
   explicit RResultBase(RError &&error) : fError(std::make_unique<RError>(std::move(error))) {}
                                                 ~~~~~^
/opt/local/var/macports/build/_opt_bblocal_var_buildworker_ports_build_ports_science_root6/root6/work/root-6-22-02/core/base/v7/inc/ROOT/RError.hxx:142:67: error: 'RError' does not refer to a value
   explicit RResultBase(RError &&error) : fError(std::make_unique<RError>(std::move(error))) {}
                                                                  ^
/opt/local/var/macports/build/_opt_bblocal_var_buildworker_ports_build_ports_science_root6/root6/work/root-6-22-02/core/base/v7/inc/ROOT/RError.hxx:76:7: note: declared here
class RError {
      ^
2 errors generated.

There are possibly other minor issues in the portfile. Why not force using clang-mp-5.0 (which first gets added to compiler.blacklist) with configure.compiler rather than compiler.fallback? There is also how MacPorts' clang is normally be added as a runtime dependency for cling, however clang-mp-5.0 is not a version that will be used for this purpose. (It is potentially confusing to set the compiler after the compiler variables have already been read.)

#61200 duplicate openscad @2015.03-3 : fatal error: 'parser.tab.h' file not found dstrubbe (David Strubbe) aliktab (Alik)
Description
--->  Computing dependencies for openscad
--->  Fetching archive for openscad
--->  Attempting to fetch openscad-2015.03-3_7.darwin_19.x86_64.tbz2 from https://packages.macports.org/openscad
--->  Attempting to fetch openscad-2015.03-3_7.darwin_19.x86_64.tbz2 from https://lil.fr.packages.macports.org/openscad
--->  Attempting to fetch openscad-2015.03-3_7.darwin_19.x86_64.tbz2 from https://nue.de.packages.macports.org/openscad
--->  Fetching distfiles for openscad
--->  Verifying checksums for openscad
--->  Extracting openscad
--->  Applying patches to openscad
--->  Configuring openscad
--->  Building openscad
Error: Failed to build openscad: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_science_openscad/openscad/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port openscad failed
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
Note: See TracQuery for help on using queries.