New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Custom Query (33983 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (20901 - 21000 of 33983)

Ticket Summary Owner Type Priority Milestone Component
#35223 php-lzf: update to 1.6.2 miwi@… update Normal ports

Reported by ryandesign@…, 21 months ago.

Description

Here's a patch to update php-lzf (and php5-lzf) to 1.6.2. The patch used in php-lzf for PHP 5.4 compatibility is no longer needed. For php5-lzf, the case of the distname is also corrected. (This was already done in php-lzf.)

#41113 php-memcache: memcache support requires ZLIB. Use --with-zlib-dir=<DIR> to specify prefix where ZLIB include and library are located ryandesign@… defect Normal ports

Reported by an0nym@…, 6 months ago.

Description

php55-memcache will not configure on Mavericks

$ sudo port clean php55-memcache && sudo port install php55-memcache 
--->  Cleaning php55-memcache
--->  Computing dependencies for php55-memcache
--->  Fetching archive for php55-memcache
--->  Attempting to fetch php55-memcache-2.2.7_0.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/php55-memcache
--->  Attempting to fetch php55-memcache-2.2.7_0.darwin_13.x86_64.tbz2 from http://packages.macports.org/php55-memcache
--->  Attempting to fetch php55-memcache-2.2.7_0.darwin_13.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/php55-memcache
--->  Fetching distfiles for php55-memcache
--->  Verifying checksums for php55-memcache
--->  Extracting php55-memcache
--->  Configuring php55-memcache
Error: Failed to configure php55-memcache, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_php_php-memcache/php55-memcache/work/memcache-2.2.7/config.log
Error: org.macports.configure for port php55-memcache returned: configure failure: command execution failed
Please see the log file for port php55-memcache for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_php_php-memcache/php55-memcache/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port php55-memcache failed
#36346 php-midgard2 portfile problem with subports jwa@… defect Normal ports

Reported by bbrodeau@…, 19 months ago.

Description

Hello,

If I type the command "sudo port -v selfupdate", I get the following message :

" $ sudo port -v selfupdate
--->  Updating MacPorts base sources using rsync
receiving file list ... done

sent 36 bytes  received 69 bytes  30.00 bytes/sec
total size is 3543040  speedup is 33743.24
receiving file list ... done

sent 36 bytes  received 76 bytes  44.80 bytes/sec
total size is 512  speedup is 4.57
MacPorts base version 2.1.2 installed,
MacPorts base version 2.1.2 downloaded.
--->  Updating the ports tree
Synchronizing local ports tree from rsync://rsync.macports.org/release/tarballs/ports.tar
receiving file list ... done

sent 36 bytes  received 70 bytes  42.40 bytes/sec
total size is 54272000  speedup is 512000.00
receiving file list ... done

sent 36 bytes  received 77 bytes  45.20 bytes/sec
total size is 512  speedup is 4.53
Creating port index in /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports
Warning: failed to open old entry for php/php-midgard2, making a new one
Adding port php/php-midgard2
Failed to parse file php/php-midgard2/Portfile with subport 'php53-midgard2': can't read "php.extension_dir": couldn't execute "/opt/local/bin/php-config53": no such file or directory
Failed to parse file php/php-midgard2/Portfile with subport 'php54-midgard2': can't read "php.extension_dir": couldn't execute "/opt/local/bin/php-config54": no such file or directory

Total number of ports parsed:	3 
Ports successfully parsed:	1 
Ports failed:			2 
Up-to-date ports skipped:	15745

--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated"
#16229 php-mode.el-1.4.0 New port ryandesign@… submission Normal ports

Reported by billitch@…, 6 years ago.

Description

Taken from http://sourceforge.net/projects/php-mode/

An Emacs major mode for editing PHP code. Features: Syntax coloring and indenting; Documentation browse and search functions; Support for Imenu and SpeedBar; Customization options

#23955 php-mode.el: update to 1.5.0 billitch@… update Normal ports

Reported by ryandesign@…, 4 years ago.

Description

php-mode.el should probably be updated to version 1.5.0

#5481 phpMyAdmin 2.6.4-pl1 fails to load "missing mysql.so" macports-tickets@… defect Normal ports

Reported by wbguild7@…, 8 years ago.

Description

I successfully ported to OS X 10.4 Apache2 PHP5 MySQL5. All of them function seperately. PHP5 plays nice with Apache2. But when I installed phpMyAdmin (not from darwinports) it complained that there was no mysql.so. I looked every where and no go. How does this get installed?

#5406 phpMyAdmin 2.6.4-pl2 joe@… defect Normal ports

Reported by joe@…, 9 years ago.

Description

update to pl2

#5474 phpMyAdmin 2.6.4-pl3 joe@… defect Normal ports

Reported by joe@…, 8 years ago.

Description

upgrade to pl3

#18823 phpmyadmin 3.1.3 version update alakazam@… update Normal ports

Reported by chris@…, 5 years ago.

Description

Update port file to pick up the latest phpmyadmin

#34047 phpmyadmin 3,4,11 update notification. ryandesign@… update Normal ports

Reported by mparchet@…, 2 years ago.

Description

Hello,

I received this update notification :

Welcome to phpMyAdmin 3.4.11, the last bugfix release in the 3.4 series.

Details will appear on http://phpmyadmin.net. In a hurry? you can visit
http://sourceforge.net/projects/phpmyadmin to download.

Marc Delisle, for the team

Can you update this port ?

Best regards

mparchet

#40414 phpmyadmin @4.0.6_0: add php55 variant ryandesign@… enhancement Normal ports

Reported by drjesacco@…, 7 months ago.

Description

Version 4.06 of phpmyadmin has been released. I tweaked the Portfile for version 4.05:

  • bumped version to 4.06
  • updated checksums
  • added php55 to the foreach loop
  • added && ![variant_isset php55] to the default_variants check

I built the package using the php55 variant. Seems OK.

-Joseph

#5202 phpmyadmin port revision patch macports-tickets@… defect Normal ports

Reported by joe@…, 9 years ago.

Description

added myself as maintainer, bumped up port revision #

#553 phpmyadmin port submission macports-tickets@… defect Normal ports

Reported by ari@…, 11 years ago.

Description

I haven't figured out how to give the user a message at the end of the process (like FreeBSD ports) to tell them to edit the file config.inc.php or to merge changes from config.inc.php.old into the new file if they are upgrading.

# $Id: $

PortSystem 1.0

name phpMyAdmin version 2.5.0 homepage http://www.phpmyadmin.net/ description administration of MySQL over the web categories databases www platforms darwin maintainers ari@… master_sites http://flow.dl.sourceforge.net/sourceforge/phpmyadmin/ \

http://us.dl.sourceforge.net/phpmyadmin/ \ http://eu.dl.sourceforge.net/phpmyadmin/

use_bzip2 yes extract.sufx .tar.bz2 distfiles ${name}-${version}-php${extract.sufx} checksums md5 d64b1e6a630ad8f218196d16c948854e depends_lib bin:httpd:apache configure {} build {}

prefix /Library/WebServer/Documents/phpmyadmin install {

file mkdir -p ${destroot}/${prefix} # save the old preference file if {[ file exists ${prefix}/config.inc.php]} {

system "cp -f ${prefix}/config.inc.php

${destroot}/${prefix}/config.inc.php.old"

} system "cp -fr ${worksrcpath}/*

${destroot}/${prefix}/"

system "chown -R www.www ${destroot}/${prefix}"

}

long_description Almost any MySQL administration function can be performed \ in this web interface, including queries, defining structures, exporting,\ importing and managing privileges.

#16571 phpmyadmin / sqlite3 failed to install macports-tickets@… defect Normal ports

Reported by mike.shaheen@…, 6 years ago.

Description

This is what I get, I'm new to MacPort not sure if this is directly related to phpmyadmin or a dependency on sqlite3

shaheenery@Little-Mac:~
] sudo port install phpmyadmin
--->  Building sqlite3 with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_sqlite3/work/sqlite-3.6.2" && gnumake all " returned error 2
Command output: sqlite3.c:80990: error: 'TK_LSHIFT' undeclared (first use in this function)
sqlite3.c:80993: error: 'TK_LT' undeclared (first use in this function)
sqlite3.c:80999: error: 'TK_GE' undeclared (first use in this function)
sqlite3.c:81002: error: 'TK_RSHIFT' undeclared (first use in this function)
sqlite3.c:81005: error: 'TK_GT' undeclared (first use in this function)
sqlite3.c:81011: error: 'TK_ILLEGAL' undeclared (first use in this function)
sqlite3.c:81020: error: 'TK_BITOR' undeclared (first use in this function)
sqlite3.c:81023: error: 'TK_CONCAT' undeclared (first use in this function)
sqlite3.c:81028: error: 'TK_COMMA' undeclared (first use in this function)
sqlite3.c:81032: error: 'TK_BITAND' undeclared (first use in this function)
sqlite3.c:81036: error: 'TK_BITNOT' undeclared (first use in this function)
sqlite3.c:81053: error: 'TK_STRING' undeclared (first use in this function)
sqlite3.c:81056: error: 'TK_ID' undeclared (first use in this function)
sqlite3.c:81068: error: 'TK_DOT' undeclared (first use in this function)
sqlite3.c:81076: error: 'TK_INTEGER' undeclared (first use in this function)
sqlite3.c:81082: error: 'TK_FLOAT' undeclared (first use in this function)
sqlite3.c:81102: warning: assignment makes integer from pointer without a cast
sqlite3.c:81106: error: 'TK_VARIABLE' undeclared (first use in this function)
sqlite3.c:81115: error: 'TK_REGISTER' undeclared (first use in this function)
sqlite3.c:81155: error: 'TK_BLOB' undeclared (first use in this function)
sqlite3.c: In function 'sqlite3RunParser':
sqlite3.c:81227: error: 'TK_SPACE' undeclared (first use in this function)
sqlite3.c:81227: warning: case label value exceeds maximum value for type
sqlite3.c:81235: error: 'TK_ILLEGAL' undeclared (first use in this function)
sqlite3.c:81235: warning: case label value exceeds maximum value for type
sqlite3.c:81242: error: 'TK_SEMI' undeclared (first use in this function)
sqlite3.c:81242: warning: case label value exceeds maximum value for type
sqlite3.c:81258: warning: comparison between pointer and integer
sqlite3.c:81259: warning: passing argument 2 of 'sqlite3Parser' makes integer from pointer without a cast
gnumake: *** [sqlite3.lo] Error 1

Error: The following dependencies failed to build: php5 apache2 apr-util sqlite3 pcre bzip2 freetype gd2 autoconf help2man p5-locale-gettext m4 automake fontconfig jpeg libpng libtool libmcrypt libxml2 libxslt mhash tiff
Error: Status 1 encountered during processing.
#20818 phpmyadmin: update to 3.2.1 alakazam@… update Normal ports

Reported by ryandesign@…, 5 years ago.

Description

phpmyadmin should be updated to 3.2.1

#26157 phpmyadmin: update to 3.3.5 alakazam@… update Normal ports

Reported by MailToArlo@…, 4 years ago.

Description

phpmyadmin should be updated to 3.3.5

#26777 phpmyadmin: update to 3.3.7 update Normal ports

Reported by toszcze@…, 4 years ago.

Description

phpMyAdmin should be updated to 3.3.7

#26900 phpmyadmin: update to 3.3.7 alakazam@… update Normal ports
#39512 php-opcache: add port ryandesign@… request Normal ports

Reported by macports.org@…, 10 months ago.

Description

PHP 5.5 introduces a new feature, OPcache:

To use it with PHP 5.5, it must be built with --enable-opcache:

However, the current php55 port does have this configured:

$ php -v
PHP 5.5.0 (cli) (built: Jun 22 2013 00:21:42) 
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.5.0-dev, Copyright (c) 1998-2013 Zend Technologies
    with Xdebug v2.2.3, Copyright (c) 2002-2013, by Derick Rethans

$ php -i | grep "^Configure Command" | fold -s
Configure Command =>  './configure'  '--prefix=/opt/local' 
'--mandir=/opt/local/share/man' '--infodir=/opt/local/share/info' 
'--program-suffix=55' '--includedir=/opt/local/include/php55' 
'--libdir=/opt/local/lib/php55' '--with-config-file-path=/opt/local/etc/php55' 
'--with-config-file-scan-dir=/opt/local/var/db/php55' '--disable-all' 
'--enable-bcmath' '--enable-ctype' '--enable-dom' '--enable-fileinfo' 
'--enable-filter' '--enable-hash' '--enable-json' '--enable-libxml' 
'--enable-pdo' '--enable-phar' '--enable-session' '--enable-simplexml' 
'--enable-tokenizer' '--enable-xml' '--enable-xmlreader' '--enable-xmlwriter' 
'--with-bz2=/opt/local' '--with-mhash=/opt/local' 
'--with-pcre-regex=/opt/local' '--with-libxml-dir=/opt/local' 
'--with-zlib=/opt/local' '--without-pear' '--disable-cgi' '--disable-fpm' 
'--enable-cli' '--with-libedit=/opt/local'

The source confirms this:

Please build the php55 port with the --enable-opcache flag.

Thanks for your consideration.

#37879 php-oracle: Maybe Enable 64-bit ryandesign@… enhancement Normal ports

Reported by dwilks@…, 15 months ago.

Description

Oracle just released a new version, 11.2.0.3.0, that might be 64-bit compatible in OSX. If so we should remove the supported_archs i386 in the oracle subport.

#34651 php-peb: non-void function should return a value macports-tickets@… defect Normal ports

Reported by ryandesign@…, 23 months ago.

Description
--->  Building php54-peb
DEBUG: Executing org.macports.build (php54-peb)
DEBUG: Building in peb_release
DEBUG: Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.7'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release" && /usr/bin/make -j4 -w all'
DEBUG: Executing command line:  cd "/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release" && /usr/bin/make -j4 -w all 
make: Entering directory `/Volumes/work/macports/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release'
/bin/sh /opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release/libtool --mode=compile /usr/bin/clang  -I. -I/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release -DPHP_ATOM_INC -I/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release/include -I/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release/main -I/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release -I/opt/local/include/php54/php -I/opt/local/include/php54/php/main -I/opt/local/include/php54/php/TSRM -I/opt/local/include/php54/php/Zend -I/opt/local/include/php54/php/ext -I/opt/local/include/php54/php/ext/date/lib -I/opt/local/include  -I/opt/local/include -I/opt/local/lib/erlang/lib/erl_interface-3.7.6//include -DHAVE_CONFIG_H  -pipe -O2 -arch x86_64   -c /opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release/peb.c -o peb.lo 
mkdir .libs
 /usr/bin/clang -I. -I/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release -DPHP_ATOM_INC -I/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release/include -I/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release/main -I/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release -I/opt/local/include/php54/php -I/opt/local/include/php54/php/main -I/opt/local/include/php54/php/TSRM -I/opt/local/include/php54/php/Zend -I/opt/local/include/php54/php/ext -I/opt/local/include/php54/php/ext/date/lib -I/opt/local/include -I/opt/local/include -I/opt/local/lib/erlang/lib/erl_interface-3.7.6//include -DHAVE_CONFIG_H -pipe -O2 -arch x86_64 -c /opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release/peb.c  -fno-common -DPIC -o .libs/peb.o
/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release/peb.c:797:5: error: non-void function '_peb_encode_term' should return a value [-Wreturn-type]
                                return;
                                ^
/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release/peb.c:849:11: error: non-void function '_peb_encode' should return a value [-Wreturn-type]
          return;
          ^
/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release/peb.c:903:5: error: non-void function '_peb_encode' should return a value [-Wreturn-type]
                                return;
                                ^
/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release/peb.c:934:5: error: non-void function '_peb_encode' should return a value [-Wreturn-type]
                                return;                          
                                ^
/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release/peb.c:943:5: error: non-void function '_peb_encode' should return a value [-Wreturn-type]
                                return;
                                ^
/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release/peb.c:1198:8: warning: incompatible pointer to integer conversion assigning to 'int' from 'void *'; 
  intp = NULL;
       ^ ~~~~
1 warning and 5 errors generated.
make: *** [peb.lo] Error 1
make: Leaving directory `/Volumes/work/macports/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release'
Command failed:  cd "/opt/local/var/macports/build/_Volumes_work_mports_dports_php_php-peb/php54-peb/work/peb_release" && /usr/bin/make -j4 -w all 
Exit code: 2
Error: org.macports.build for port php54-peb returned: command execution failed
DEBUG: Error code: NONE
DEBUG: Backtrace: command execution failed
    while executing
"$procedure $targetname"
Warning: targets not executed for php54-peb: org.macports.activate org.macports.build org.macports.destroot org.macports.install
Please see the log file for port php54-peb for details:
    /opt/local/var/macports/logs/_Volumes_work_mports_dports_php_php-peb/php54-peb/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port php54-peb failed
#20334 phppgadmin: new port ryandesign@… submission Normal ports

Reported by nefar@…, 5 years ago.

Description
# $Id $

PortSystem          1.0

name                phppgadmin
set my_name         phpPgAdmin
version             4.2.2
categories          www php databases
maintainers         openmaintainer
description         phpPgAdmin is a web-based administration tool for PostgreSQL.
long_description    phpPgAdmin is a tool written in PHP intended to handle \
                    the administration of PostgreSQL over the Web. phpPgAdmin \
                    supports a wide range of operations with PostgreSQL.
homepage            http://phppgadmin.net/
master_sites        sourceforge
distname            ${my_name}-${version}
use_bzip2           yes

checksums           md5     7716bd0b1afa8468e22b641bba8faa65 \
                    sha1    3a0b6fbed26d7faeb7a6a33525d021de941944cc \
                    rmd160  a41ce2278d09a2d791630b24db90edd0d3cc71d3

platforms           darwin freebsd

# Automatically depend on the latest mysql installed, fallback on mysql5 (r27781)
set myglob [glob -directory ${prefix}/lib -nocomplain -tails mysql*]
if {[llength ${myglob}]} {
    set mysql [lindex ${myglob} end]
} else {
    set mysql mysql5
}

depends_run         path:lib/${mysql}:${mysql} \
                    path:bin/php:php5

set docpath ${destroot}${prefix}/www

use_configure       no
build               {}

destroot {
    xinstall -d -m 0755 ${docpath}/phppgadmin
    eval copy [glob ${worksrcpath}/*] ${docpath}/phppgadmin
}

livecheck.distname  ${my_name}
livecheck.url       http://phppgadmin.sourceforge.net/index.php?page=download
livecheck.regex     "${my_name}-(\\d+(?:\\.\\d+)*)"
#30100 phpPgAdmin update to 5.0.2 ryandesign@… update Normal ports

Reported by miwi@…, 3 years ago.

Description

Hi,

here is update to 5.0.2, i've updated the homepage, also i'd like to maintain that port.

Thanks Martin

#34580 phppgadmin: update to 5.0.4 miwi@… update Normal ports
#41727 php-phalcon: A compiled PHP framework ryandesign@… request Normal ports

Reported by mark@…, 4 months ago.

Description

Phalcon provides a pretty full-featured MVC PHP framework with the speed gains of having the classes and functions compiled. The end product is a shared extension that can be included in PHP's configuration like any other. Compilation and installation are pretty straight forward with few dependancies.

Since we had ZF1 and ZF2 ports, I figured we could add this one too. I've downloaded and compiled it on 10.9 with PHP 5.5.6, and it plays well so far.

#42954 php-phalcon: Update to 1.3.1 ryandesign@… update Normal ports

Reported by mark@…, 4 weeks ago.

Description

1.3.0 dropped a few days ago: http://blog.phalconphp.com/post/79924802754/phalcon-1-3-0-released

#36434 php-postgresql: add postgresql92 variant ryandesign@… enhancement Normal ports

Reported by fly.captain@…, 19 months ago.

Description

Hi,

I have installed Postgresql 9.2, but there is no variant for this version in the php54-postgresql port (nor for php53-postgresql). Can you planned this enhancement ?

Fabien

#33954 PHP Problems with qrcode and dba ryandesign@… defect Normal ports

Reported by ajf@…, 2 years ago.

Description

I have two problems with the installation of PHP5.

Firstly 'phpqrcode' fails with a 'broken image' icon which I suspect is due to PHP not being compiled with GD?

Secondly phpinfo() for dba shows only 'flatfile' and not 'gdbm' which I would prefer.

What should I do?

Alan Fry

#42937 php-redis - Bad checksum ryandesign@… defect Normal ports

Reported by mark@…, 4 weeks ago.

Description

Bad checksum on download. It looks like it's attempting to download redis 2.2.5, but 2.8.7 looks to be the latest?:

:debug:main Executing org.macports.main (php55-redis)
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 503
:debug:main euid changed to: 504
:debug:archivefetch archivefetch phase started at Wed Mar 19 09:36:51 CDT 2014
:msg:archivefetch --->  Fetching archive for php55-redis
:debug:archivefetch Executing org.macports.archivefetch (php55-redis)
:debug:archivefetch euid/egid changed to: 0/0
:debug:archivefetch chowned /opt/local/var/macports/incoming to macports
:debug:archivefetch euid/egid changed to: 504/503
:info:archivefetch --->  php55-redis-2.2.5_0.darwin_13.x86_64.tbz2 doesn't seem to exist in /opt/local/var/macports/incoming/verified
:msg:archivefetch --->  Attempting to fetch php55-redis-2.2.5_0.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/php55-redis
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404 Not Found
:msg:archivefetch --->  Attempting to fetch php55-redis-2.2.5_0.darwin_13.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/php55-redis
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404 Not Found
:msg:archivefetch --->  Attempting to fetch php55-redis-2.2.5_0.darwin_13.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/php55-redis
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404 Not Found
:debug:archivefetch Privilege de-escalation not attempted as not running as root.
:debug:fetch fetch phase started at Wed Mar 19 09:36:52 CDT 2014
:notice:fetch --->  Fetching distfiles for php55-redis
:debug:fetch Executing org.macports.fetch (php55-redis)
:info:fetch --->  redis-2.2.5.tar.gz doesn't seem to exist in /opt/local/var/macports/distfiles/php5-redis
:notice:fetch --->  Attempting to fetch redis-2.2.5.tar.gz from https://github.com/nicolasff/phpredis/tarball/2.2.5
:debug:fetch Privilege de-escalation not attempted as not running as root.
:debug:checksum checksum phase started at Wed Mar 19 09:36:53 CDT 2014
:notice:checksum --->  Verifying checksums for php55-redis
:debug:checksum Executing org.macports.checksum (php55-redis)
:info:checksum --->  Checksumming redis-2.2.5.tar.gz
:error:checksum Checksum (rmd160) mismatch for redis-2.2.5.tar.gz
:info:checksum Portfile checksum: redis-2.2.5.tar.gz rmd160 c9518d26c671da99cc1f9e0060ef2edfd5259531
:info:checksum Distfile checksum: redis-2.2.5.tar.gz rmd160 52827b4ede0fa513010278794d9806f38857f7db
:error:checksum Checksum (sha256) mismatch for redis-2.2.5.tar.gz
:info:checksum Portfile checksum: redis-2.2.5.tar.gz sha256 e75d526ba91038cced8b034b98de7ade84a65ecdac849f4bb5e570e2b8c805b7
:info:checksum Distfile checksum: redis-2.2.5.tar.gz sha256 c1c4cccce4c140da58c00b19a41f5bd2d218811733711984fc3e8b73cd4c6b33
:info:checksum The correct checksum line may be:
:info:checksum checksums           rmd160  52827b4ede0fa513010278794d9806f38857f7db \
                    sha256  c1c4cccce4c140da58c00b19a41f5bd2d218811733711984fc3e8b73cd4c6b33
:error:checksum org.macports.checksum for port php55-redis returned: Unable to verify file checksums
:debug:checksum Error code: NONE
:debug:checksum Backtrace: Unable to verify file checksums
#34390 php: remove libtool dependency from SAPI subports ryandesign@… enhancement Normal ports

Reported by ryandesign@…, 2 years ago.

Description

A dependency on the libtool port was added to the php5 port in r39325 because "otool -L" showed that it was linked with libltdl. But that no longer seems to be the case in the SAPI subports of the new php port. It was probably due to the mcrypt extension, which is now a separate subport which itself already has a libtool dependency (which has actually been called into question by this upstream bug report). So in the interest of removing unneeded dependencies the libtool dependency should be removed from the SAPI subports.

#34391 php: remove readline dependency ryandesign@… enhancement Normal ports

Reported by ryandesign@…, 2 years ago.

Description

The PHP SAPIs currently depend on readline. PHP is under the PHP license while readline is under the GPL and these two licenses are incompatible with one another. This is a problem because it means we cannot distribute binaries of the PHP ports. So I would like to remove the readline dependency.

PHP's readline dependency is partly a holdover from when php5 was a monolithic port. In #19091 I wanted to separate all the extensions into their own ports, and php5-readline became its own port in r53781, but was merged back into the php5 port in r56346. At the time I didn't document why, but the reason was that PHP has an interactive mode, "php -a", which supports readline, but only if it is built into PHP, not if it is built as a standalone extension.

A PHP bug report was filed about this in January 2011 and it was fixed in PHP trunk in February 2011. But that fix has not been back-ported to PHP 5; I expect users won't benefit from this fix until the release of PHP 6. The fix seems to affect a lot of files and contain more than a small amount of code and I don't know the PHP source code at all so I don't feel comfortable trying to back-port it to PHP 5 myself.

Readline was already an indirect dependency of php5 via the pcre port so there was no advantage at the time to removing the direct readline dependency. And regular expressions are a central feature of PHP which most PHP web sites probably use so there was no point separating out the pcre extension. But in the past year, the pcre port has been switched from readline to libedit, in r84236, to make it distributable. So now there is benefit in removing the readline dependency from PHP, to make it distributable too.

PHP can use libedit instead of readline. There is one problem with just replacing readline with libedit in PHP: there is one function, readline_list_history(), which is only available when the readline extension is built using the readline library, and not when it is built using the libedit library. Therefore there should be variants for letting the user choose libedit or readline, with libedit being the default.

Also, there's no reason readline functionality should be available in any SAPI other than the CLI.

#41075 php-scrypt: Now in pecl, time to implement? ryandesign@… request Low ports

Reported by mark@…, 6 months ago.

Description

PECL now has scrypt: http://pecl.php.net/package/scrypt. FWIW, it's now available as an optional KDF in ZF2

#34655 phpsh: update for php53 / php54 singingwolfboy@… enhancement Normal ports

Reported by ryandesign@…, 23 months ago.

Description

phpsh should be updated to work with the new php53 / php54 ports. I'm not sure what the best approach is. Options include giving the phpsh port php53 and php54 variants or giving it php53-phpsh and php54-phpsh subports. I'm not sure which approach makes most sense for phpsh.

#32942 phpsh: use tarball singingwolfboy@… enhancement Normal ports

Reported by ryandesign@…, 2 years ago.

Description

In r89095 I updated phpsh to use the new github portgroup. Is there a reason why this port is fetching from git and not from a tarball? It seems to build fine using a tarball. Here's a patch that would do that. Let me know if there's any reason not to commit this.

#27447 php-SPL_Types: incorrect version shown in phpinfo() nox@… defect Low ports

Reported by Dormilich@…, 3 years ago.

Description

after installing php5-SPL_Types, the phpinfo() output denotes the installed version of SPL_Types as 0.1.0. However the port claims to be version 0.3.0 and according to the PECL documentation (though sparse) version 0.3.0 seems to be the correct one.

#29638 phpstylist port ryandesign@… submission Normal ports

Reported by rudloff@…, 3 years ago.

Description

A port for phpStylist

#16340 PHP throwing fork()ing error ryandesign@… defect Normal ports

Reported by cabanela@…, 6 years ago.

Description

Honestly, I think this error is in the OS (or its origin is), but I am sitting here pulling my hair out.

I have several PHP scripts that call a PHP package called JpGraph to generate graphs. I should not I had been using Apple's built-in PHP and APache servers. Since upgrading to Leopard, the following error is recorded in the Apache2 error_log

The process has forked and you cannot use this CoreFoundation functionality safely. You MUST exec().
Break on __THE_PROCESS_HAS_FORKED_AND_YOU_CANNOT_USE_THIS_COREFOUNDATION_FUNCTIONALITY___YOU_MUST_EXEC__() to debug.

I discovered that the PDFLIb folks have documented this problem a little better, copying from their documentation here

http://www.pdflib.com/fileadmin/pdflib/pdf/support/PDFlib-in-PHP-HowTo.pdf

Apple’s PHP version which is bundled with Mac OS X does not work with PDFlib DSOs. To use PHP with PDFlib on Mac OS X you need third-party PHP packages such as MAMP, XAMP[P] for Mac, or Marc Liyanage’s version from www.entropy.ch. Mac OS X 10.5 (Leopard) adds new complications. As described in developer.apple.com/releasenotes/CoreFoundation/CoreFoundation.html it is no longer possible to use CoreFoundation functions after a call to fork( ) without exec( ). However, CoreFoundation functions are required for PDFlib’s host font feature, and the critical sequence above is used in the combination of Apache and PHP.

I went ahead and installed Apache2 and PHP5 via MacPorts and configured them properly and discovered to my joy that my old graphics generating scripts were working... for 48 hours. My Mac locked up over the weekend (not sure why, it was the first time, maybe related), and when I reboot, I discovered now that the MacPorts PHP installation is now tossing the same errors.

This has really confused me:

  1. Can someone explain if the PDFLib folks were correct that you could avoid these errors with a non-Apple PHP installation or is this an unavoidable OS feature (which would make sense, I suppose)?
  1. If this is avoidable, can someone with more PHP knowledge than me explain how to configure PHP to avoid "forking" in a manner offensive to Apple?
#36994 php-timezonedb: php-timezonedb 2012.9 macports-tickets@… update Normal ports
#38348 php-timezonedb - portfile showing 2013.1; actually downloading 2012.10 ryandesign@… defect Low ports

Reported by mark@…, 14 months ago.

Description

It appears that the change to the 2013.1 version didn't quite catch. When installing the port, it is downloading the older 2012.1 version. phpinfo is also showing that it is 2012.10 version.

port install php-timezonedb
--->  Computing dependencies for php-timezonedb
--->  Dependencies to be installed: php54-timezonedb
--->  Installing php54-timezonedb @2012.10_0
--->  Activating php54-timezonedb @2012.10_0
--->  Cleaning php54-timezonedb
--->  Fetching archive for php-timezonedb
--->  Attempting to fetch php-timezonedb-2012.10_0.darwin_12.noarch.tbz2 from http://packages.macports.org/php-timezonedb
--->  Attempting to fetch php-timezonedb-2012.10_0.darwin_12.noarch.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/php-timezonedb
--->  Attempting to fetch php-timezonedb-2012.10_0.darwin_12.noarch.tbz2 from http://lil.fr.packages.macports.org/php-timezonedb
--->  Fetching distfiles for php-timezonedb
--->  Verifying checksum(s) for php-timezonedb
--->  Extracting php-timezonedb
--->  Configuring php-timezonedb
--->  Building php-timezonedb
--->  Staging php-timezonedb into destroot
--->  Installing php-timezonedb @2012.10_0
--->  Activating php-timezonedb @2012.10_0
--->  Cleaning php-timezonedb
--->  Updating database of binaries: 100.0%
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.
#37511 php-timezonedb: update to 2012.10 ryandesign@… update Normal ports
#36766 php-timezonedb: update to 2012.8 miwi@… update Normal ports
#40908 php-timezonedb: Update to 2013.7 (2013g) ryandesign@… update Low ports

Reported by mark@…, 6 months ago.

Description

The pecl repo now has 2013.7 (2013g). Minor release. Just wanted to get it on the tracker.

#37512 php-Twig: new port ryandesign@… submission Normal ports

Reported by robsonpeixoto@…, 16 months ago.

Description

Enhances the performance of the Twig runtime engine

#37723 php-Twig: update to 1.12.1 ryandesign@… update Normal ports
#38370 php-Twig: update to 1.12.2 larryv@… update Normal ports
#35092 php-uuid, php5-uuid: update to 1.0.3 pixilla@… update Normal ports

Reported by ryandesign@…, 22 months ago.

Description

See patch.

#35207 [php-xdebug] Upgrade to 2.2.1 ryandesign@… update Normal ports

Reported by robsonpeixoto@…, 21 months ago.

Description

http://xdebug.org/updates.php#x_2_2_1

#38745 php-xslcache port request ryandesign@… request Normal ports

Reported by gulios@…, 12 months ago.

Description

Hi,

Is there any news about this port in php54? Now we have only php5-xslcache @0.7.1 Pleasge give us informatin when we can expect xslcache port available for php53 and 54.

Thank you.

#40983 php-zip: zip support requires ZLIB. Use --with-zlib-dir=<DIR> to specify prefix where ZLIB include and library are located ryandesign@… defect Normal ports

Reported by bertrand.zuchuat@…, 6 months ago.

Description
Error: Failed to configure php54-zip, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_php/php54-zip/work/php-5.4.21/ext/zip/config.log
Error: org.macports.configure for port php54-zip returned: configure failure: command execution failed
Please see the log file for port php54-zip for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_php/php54-zip/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port php54-zip failed
#21652 physfs 1.0.2 fails to build on Snow Leopard macports-tickets@… defect Normal ports

Reported by domiman@…, 5 years ago.

Description

When I try to build physfs +universal it fails with ld: symbol(s) not found for architecture x86_64 and also ld: symbol(s) not found for architecture i386

Without vraint universal it just complains about symbols not found. I attached the port -v install log

#30595 physfs-2.02 does not build on Mac OS 10.7 macports-tickets@… defect Normal ports

Reported by Christoph.Ender@…, 3 years ago.

Description

Trying to install physfs-2.02 on a Lion installation results in several "deprecated" warnings, which, due to the "-Werror" flag which is used by the default physfs-build, seem to abort the build.

This appears to be rather a physfs- than a MacPorts-problem (not sure if it can / should be circumvented in the MacPorts build), but for the time being it seems that removing the -Werror flag from "CMakeLists.txt" in the physfs sources makes the build complete without errors.

#30586 physfs does not build on 10.7 luiji@… defect Normal ports

Reported by soehn@…, 3 years ago.

Description

I tried to install dosbox. Physfs+universal did not install. I have attached the log file.

#22665 physfs: missing patchfile jmr@… defect Normal ports

Reported by ryandesign@…, 4 years ago.

Description

r60803 added a reference to patchfile f254870dd7dd.diff but this file was not added. Was it this?

http://hg.icculus.org/icculus/physfs/raw-rev/f254870dd7dd

#22657 physfs should not depend on readline macports-tickets@… defect Normal ports

Reported by trent@…, 4 years ago.

Description

I think physfs has some example that requires libreadline, but install the libraries from macports should build with --disable-readline. It's particularly important on Os x 10.6 because readline depends on ncurses, and the default ncurses found by gcc will be the OS x one, which does not have a 64 bit version.

#28566 physfs: update to 2.0.2 ryandesign@… update Normal ports

Reported by luiji@…, 3 years ago.

Description

I updated the old PhysicsFS (physfs) Portfile to version 2.0.2 (the old version being 2.0.1). It no longer needs the patch, as far as I can tell.

Also, I see that no one currently maintains the physfs package. I would like to be the new maintainer of it.

#41242 physfs: update to 2.0.3 luiji@… update Normal ports

Reported by ryandesign@…, 5 months ago.

Description
$ port livecheck physfs
physfs seems to have been updated (port version: 2.0.2, new version: 2.0.3)
#25334 pianobar 0.0.0 console-based pandora.com player macports-tickets@… submission Normal ports

Reported by aguynamedryan+macports@…, 4 years ago.

Description

From the readme:

pianobar is a console client for the personalized web radio pandora (http://www.pandora.com).

  • play and manage (create, add more music, delete, rename, ...) your stations
  • rate played songs and let pandora explain why they have been selected
  • show upcoming songs/song history
  • configure keybindings
  • last.fm scrobbling support (external application)
  • proxy support for listeners outside the USA

I've created a Portfile and patch for the Makefile to get pianobar to compile under Mac OS X 10.6.4. The upstream doesn't seem to have a version number, so I used '0.0.0' as the version and will use the revision number to track future updates.

#30841 pianobar @2011.07.09_0 Segmentation fault aguynamedryan+pianobar@… defect Normal ports

Reported by grrr@…, 3 years ago.

Description

On Lion 10.7.1 pianobar builds, but does not run:

Welcome to pianobar (2011.07.09)! Press ? for a list of commands.
Segmentation fault: 11

Discussion of a fix: https://github.com/PromyLOPh/pianobar/issues/138

#32027 pianobar @2011.11.11-1 Update pianobar to 2011.11.11 build aguynamedryan+pianobar@… update Normal ports

Reported by zheaton@…, 2 years ago.

Description

Update pianobar to the most recent github release, which fixes authentication errors, makes TLS connections the default, and embeds the Pandora certificate fingerprint. Note that this is more recent than the 2011.11.11 snapshot posted on the Pianobar homepage.

#39180 pianobar @2012.12.01_1 +universal dyld: Library no loaded aguynamedryan+pianobar@… defect Normal ports

Reported by igeek1@…, 11 months ago.

Description

When I try to run pianobar on Mac in zsh, I get this error:

dyld: Library not loaded: /opt/local/lib/libgnutls.26.dylib
  Referenced from: /usr/local/bin/pianobar
  Reason: image not found
zsh: trace trap  pianobar

I have uninstalled and reinstalled, and I get the same problem.

#32896 pianobar: add libpiano subport aguynamedryan+pianobar@… enhancement Normal ports

Reported by ryandesign@…, 2 years ago.

Description

Here's a patch that adds a libpiano subport to pianobar. Builds for me on Snow Leopard. Look ok to commit?

#32115 pianobar: fails to build with clang macports-tickets@… defect Normal ports

Reported by aguynamedryan+macports@…, 2 years ago.

Description

I just upgraded to Lion and decided to do a fresh install of MacPorts. pianobar failed to build with the following error:

:info:build In file included from src/settings.c:38:
:info:build In file included from src/settings.h:28:
:info:build src/libwaitress/waitress.h:30:10: fatal error: 'gnutls/gnutls.h' file not found
:info:build #include <gnutls/gnutls.h>
:info:build          ^

Looks like pianobar isn't seeing the /opt/local files. I've patched the Portfile so that it sets a -I and -L flag for the compiler. I also drop the now-unsused LIB*_INCLUDE variables

#26755 pianobar: fix livecheck aguynamedryan+pianobar@… defect Normal ports

Reported by ryandesign@…, 4 years ago.

Description

The attached patch fixes pianobar's livecheck. Before:

$ port livecheck
Error: cannot check if pianobar was updated (The requested URL returned error: 406)

After:

$ port livecheck
pianobar seems to have been updated (port version: 2010.08.21, new version: 2010.10.07)

May I commit this patch?

#37927 pianobar hotkey improvement macports-tickets@… enhancement Normal ports

Reported by louisoel@…, 15 months ago.

Description

Allow users to exit out of prompts

for example, when I hit s or =, allow users to exit out of the prompt instead of forcing the user to choose a choice.

#27729 pianobar powerpc support aguynamedryan+pianobar@… defect Normal ports

Reported by ryandesign@…, 3 years ago.

Description

pianobar doesn't work on powerpc, but the patch to fix this is easy and is attached. May I commit it?

Here's the upstream bug report.

#30802 pianobar: simplify setting -arch flags aguynamedryan+pianobar@… enhancement Normal ports

Reported by ryandesign@…, 3 years ago.

Description

The attached patch simplifies how pianobar builds for the correct architecture(s). May I commit it?

#27655 pianobar: unrecognized option '-shared' aguynamedryan+pianobar@… defect Normal ports

Reported by ryandesign@…, 3 years ago.

Description

pianobar fails to build on Tiger:

/usr/bin/gcc-4.0 -arch i386 -shared -Wall -g -std=c99 -pedantic libpiano/src/crypt.lo libpiano/src/piano.lo libpiano/src/xml.lo libwaitress/src/waitress.lo \
                libezxml/src/ezxml.lo -o libpiano.so.0.0.0
i686-apple-darwin8-gcc-4.0.1: unrecognized option '-shared'
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: Undefined symbols:
_main
collect2: ld returned 1 exit status
make: *** [libpiano] Error 1
make: *** Waiting for unfinished jobs....
shell command " cd "/opt/local/var/macports/build/_Users_rschmidt_macports_dports_audio_pianobar/work/pianobar-2010.11.06" && /usr/bin/make -j2 all CC="/usr/bin/gcc-4.0 -arch i386" PREFIX=/opt/local LIBAO_INCLUDE=/opt/local/include LIBFAAD_INCLUDE=/opt/local/include LIBMAD_INCLUDE=/opt/local/include " returned error 2
Error: Target org.macports.build returned: shell command failed (see log for details)
DEBUG: Backtrace: shell command failed (see log for details)
Warning: the following items did not execute (for pianobar): org.macports.activate org.macports.build org.macports.destroot org.macports.install

"-shared" is a flag that is used on other UNIX systems, but on Mac OS X, "-dynamiclib" is used instead. Recent versions of Mac OS X allow "-shared" as a synonym for "-dynamiclib", but Tiger is not recent enough for that. The attached patch fixes this.

However, the dynamic library that's being built here doesn't actually end up getting installed -- and pianobar works fine without it. So I'm unsure why the dynamic library is being built at all, and maybe a better patch would be one that disables building the dynamic library.

#26620 pianobar: update to 2010.08.21 aguynamedryan+pianobar@… update Normal ports

Reported by ryandesign@…, 4 years ago.

Description

The pianobar port is at version "6a0f620" but the current version seems to be "2010.08.21" so the port should probably be updated.

#26754 pianobar: update to 2010.10.07 aguynamedryan+pianobar@… update Normal ports

Reported by ryandesign@…, 4 years ago.

Description

Pandora changed their protocol; pianobar had to release a new version to accommodate this. The attached patch works for me. May I commit it?

#27179 pianobar: update to 2010.11.06 ryandesign@… update Normal ports

Reported by aguynamedryan+macports@…, 3 years ago.

Description

Pandora changed their protocol; pianobar has a new release to accommodate this. The attached patch works for me.

#28115 pianobar: update to 2011.01.24 ryandesign@… update Normal ports

Reported by aguynamedryan+macports@…, 3 years ago.

Description

pianobar has a new update. It incorporates the patch from #27729 among other fixes/changes.

https://github.com/PromyLOPh/pianobar/blob/2011.01.24/ChangeLog

#29311 pianobar: update to 2011.04.27 aguynamedryan+pianobar@… update Normal ports

Reported by macports@…, 3 years ago.

Description

pianobar has updated twice since the last release, most recently to update the RPC protocol (since Pandora changed it again, breaking pianobar). Please update the port!

https://github.com/PromyLOPh/pianobar/blob/2011.04.27/ChangeLog

#30098 pianobar: update to 2011.07.09 aguynamedryan+pianobar@… update Normal ports

Reported by neil@…, 3 years ago.

Description

The maintainer of pianobar has updated libpiano to support another(!) change to the pandora protocol.

https://github.com/PromyLOPh/pianobar/blob/master/ChangeLog

#32591 pianobar: update to 2011.12.11 aguynamedryan+pianobar@… defect Normal ports

Reported by ryandesign@…, 2 years ago.

Description

This patch updates pianobar to 2011.12.11.

#32879 pianobar: update to 2012.01.10 ryandesign@… defect Normal ports

Reported by aguynamedryan+macports@…, 2 years ago.

Description

This patch updates pianobar to 2012.01.10

#34210 pianobar: update to 2012.04.24 aguynamedryan+pianobar@… update Normal ports

Reported by cowboycodur@…, 2 years ago.

Description

Error:

"Welcome to pianobar (2012.01.10)! Press ? for a list of commands.
(i) Login... Error: Protocol incompatible. Please upgrade libpiano."
New release available on github

+Release 2012.04.24
+
+- Fix format string crash
+- Fix sync response parser
+- Fix possible stdin close on error
+- Fix undefined behavior (mutex unlock)
+- Use TLS for every request with new setting force_tls
+- New error codes EXCESSIVE_ACTIVITY and DAILY_SKIP_LIMIT_REACHED
+- Autoselect last remaining item of filtered list, disable with autoselect = 0
+- Warn if control fifo is not a fifo
+- Code cleanup
#34365 pianobar: update to 2012.05.06 ryandesign@… defect Normal ports

Reported by aguynamedryan+macports@…, 2 years ago.

Description

pianobar has released an update

#34969 pianobar: update to 2012.06.24 ryandesign@… defect Normal ports

Reported by aguynamedryan+macports@…, 22 months ago.

Description

pianobar has released an update

#37211 pianobar: update to 2012.12.01 aguynamedryan+pianobar@… update Normal ports

Reported by ryandesign@…, 17 months ago.

Description

May I commit this update? It works for me.

#39532 pianobar: update to 2013.09.15 aguynamedryan+pianobar@… update Normal ports

Reported by ryandesign@…, 10 months ago.

Description
$ port livecheck pianobar
pianobar seems to have been updated (port version: 2012.12.01, new version: 2013.05.19)
#39206 pianod portfile update - r145 larryv@… update Normal ports

Reported by perette@…, 11 months ago.

Description

Attached portfile moves to r145 of pianod. Thanks!

Perette

#40235 pianod: update to 149 ryandesign@… update Normal ports

Reported by perette@…, 8 months ago.

Description

Attached patch upgrades to use pianod 149.

#40784 pianod update to r150 ryandesign@… update Normal ports

Reported by perette@…, 6 months ago.

Description

Patch to portfile to latest release (pianod r150) is attached.

#23728 picocom 1.4 macports-tickets@… submission Normal ports

Reported by ranauei@…, 4 years ago.

Description

Picocom was designed to serve as a simple, manual, modem configuration, testing, and debugging tool. It has also served (quite well) as a low-tech terminal-window to allow operator intervention in PPP connection scripts (something like the ms-windows open terminal window before / after dialing feature). It could also prove useful in many other similar tasks. http://code.google.com/p/picocom

#27028 picocom from 1.4 to 1.6 ryandesign@… update Normal ports

Reported by ranauei@…, 3 years ago.

Description

Hi this is the update port for picocom. The patches are about the maximum baudrate that picocom want to use, it pretent to go above 230400 bps which is the maximum defined in sys/termios.h at leas in Snow Leopard 10.6.4 full patched. So I managed to change the maximum value above which the baudrate is capped and I removed the switch cases regarding the (2) undefined baudrates. See attached patches for details.

#33373 picocom: update to version 1.7 macports-tickets@… update Normal ports

Reported by ranauei@…, 2 years ago.

Description

Latest release of this minimal dumb-terminal emulation program.

#23592 pict2pdf fails to build 64-bit macports-tickets@… defect Normal ports

Reported by prahl@…, 4 years ago.

Description

This is because the required functions are 32-bit, not 64 bit

The fix is to add -m32 to CFLAGS and LDFLAGS

#16289 PIDA 0.5.1_0 buid/linker failure macports-tickets@… defect Normal ports

Reported by schwank@…, 6 years ago.

Description

The port for PIDA 0.5.1_0 fails with

ld: duplicate symbol __PyGtk_API in build/temp.macosx-10.3-i386-2.5/moo/moo-stub.o and build/temp.macosx-10.3-i386-2.5/moo/moo-pygtk.o

collect2: ld returned 1 exit status
error: command '/usr/bin/gcc-4.0' failed with exit status 1

Fix: add #define NO_IMPORT_PYGTK to the file moo/moo-stub.c

I would submit a patch, but I don't know how...

#15071 PIDA 0.5.1 Missing dependencies: py25-gnome, librsvg, py25-zlib macports-tickets@… defect Normal ports

Reported by trevor@…, 6 years ago.

Description

The devel/PIDA 0.5.1 port is missing the following dependencies:

  • py25-gnome: Provides the Python gconf bindings. Required during startup.
  • librsvg: Provides SVG support within GTK+. Required during startup.
  • py25-zlib: Provides the Python zlib module, used to download plugins. Required during runtime.

(In addition, PIDA requires a GTK+-enabled build of vim and emacs, +gtk2 and +gtk, respectively. Unfortunately specifying variant dependencies isn't supported.)

I've attached a patch that makes these changes.

#27610 PIDA: pygtk-codegen-2.0: command not found ryandesign@… defect Normal ports

Reported by ndhaubanjar@…, 3 years ago.

Description

I am trying to install PIDA on mac using macports. All the dependencies installs fine but when it tries to build PIDA, it fails with the following message:

--->  Building PIDA
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for PIDA is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_PIDA/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

The log file shows the following message:

:info:build running build_py
:info:build running build_ext
:info:build pygtk-codegen-2.0 --prefix _moo_stub \
:info:build 		--register `pkg-config --variable=defsdir pygtk-2.0`/gtk-types.defs \
:info:build 		--register `pkg-config --variable=defsdir pygtk-2.0`/gdk-types.defs \
:info:build 		--override moo.override \
:info:build 		--outfilename moo-pygtk.c \
:info:build 		moo.defs > moo-pygtk.c.tmp && \
:info:build 		mv moo-pygtk.c.tmp moo-pygtk.c
:info:build /bin/sh: pygtk-codegen-2.0: command not found
:info:build make: *** [moo-pygtk.c] Error 127
:info:build Traceback (most recent call last):
:info:build   File "setup.py", line 100, in <module>
:info:build     description = PIDA_SHORT_DESCRIPTION,
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/core.py", line 152, in setup
:info:build     dist.run_commands()
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 987, in run_commands
:info:build     self.run_command(cmd)
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 1007, in run_command
:info:build     cmd_obj.run()
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/command/build.py", line 134, in run
:info:build     self.run_command(cmd_name)
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/cmd.py", line 333, in run_command
:info:build     self.distribution.run_command(command)
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 1007, in run_command
:info:build     cmd_obj.run()
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/command/build_ext.py", line 340, in run
:info:build     self.build_extensions()
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/command/build_ext.py", line 449, in build_extensions
:info:build     self.build_extension(ext)
:info:build   File "setup.py", line 35, in build_extension
:info:build     raise RuntimeError()
:info:build RuntimeError
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_PIDA/work/PIDA-0.5.1" && /opt/local/Library/Frameworks/Python.framework/Versions/2.6/bin/python2.6 setup.py --no-user-cfg build " returned error 1
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for PIDA): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for PIDA is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_PIDA/main.log
#41115 pidgin @2.10.7_1: Tcl development headers not found nefar@… defect Normal ports

Reported by an0nym@…, 6 months ago.

Description

pidgin @2.10.7_1 +no_x11+quartz will not configure on Mavericks

$ sudo port clean pidgin && sudo port install pidgin +no_x11+quartz 
Password:
--->  Cleaning pidgin
--->  Computing dependencies for pidgin
--->  Fetching archive for pidgin
--->  Attempting to fetch pidgin-2.10.7_1+no_x11+quartz.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/pidgin
--->  Attempting to fetch pidgin-2.10.7_1+no_x11+quartz.darwin_13.x86_64.tbz2 from http://packages.macports.org/pidgin
--->  Attempting to fetch pidgin-2.10.7_1+no_x11+quartz.darwin_13.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/pidgin
--->  Fetching distfiles for pidgin
--->  Verifying checksums for pidgin
--->  Extracting pidgin
--->  Applying patches to pidgin
--->  Configuring pidgin
Error: Failed to configure pidgin, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_pidgin/pidgin/work/pidgin-2.10.7/config.log
Error: org.macports.configure for port pidgin returned: configure failure: command execution failed
Please see the log file for port pidgin for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_pidgin/pidgin/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port pidgin failed
#38994 pidgin @2.10.7 Chatlogs folder not found macports-tickets@… defect Not set ports

Reported by poulpette.delamare@…, 12 months ago.

Description

Hi,

I’ve installed Macports to run Pidgin on Mountain Lion, so that I can use my chatlogs on Mac OS and Linux (Ubuntu). Everything seems to be OK, but I don’t understand where those chatlogs go. I’ve made a test and I can read previous conversations directly from Pidgin, so that means they’re stored somewhere… but could somebody tell me where, please? I’ve made several researches on the Internet and found nothing about that. I also tried to find some files on my Mac and got the same result: nothing.

Thanks by advance.

#15521 [pidgin] [2.3.1] compile error macports-tickets@… defect Normal ports

Reported by zweistein12@…, 6 years ago.

Description

I want to install pidgin. But: Can any help me?

bash-3.2$ sudo port install pidgin ---> Building pidgin with target all Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_pidgin/work/pidgin-2.3.1" && make all " returned error 2 Command output: make all-recursive Making all in libpurple make all-recursive Making all in gconf LC_ALL=C ../../intltool-merge -s -u -c ../../po/.intltool-merge-cache ../../po purple.schemas.in purple.schemas Possible unintended interpolation of @INTLTOOL_ICONV in string at ../../intltool-merge line 96. Global symbol "@INTLTOOL_ICONV" requires explicit package name at ../../intltool-merge line 96. BEGIN not safe after errors--compilation aborted at ../../intltool-merge line 263. make[4]: * [purple.schemas] Error 255 make[3]: * [all-recursive] Error 1 make[2]: * [all] Error 2 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

Error: Status 1 encountered during processing.

#13847 pidgin 2.3.1 does not start (old gtk-x11 version) macports-tickets@… defect Normal ports

Reported by sydbarrett74@…, 6 years ago.

Description

Did %> sudo port install pidgin and it built with no problems. However, when I go to run it, I get this:

dyld: Library not loaded: /opt/local/lib/libgtk-x11-2.0.0.dylib
  Referenced from: /opt/local/bin/pidgin
  Reason: Incompatible library version: pidgin requires version 1201.0.0 or later, but libgtk-x11-2.0.0.dylib provides version 1001.0.0
Trace/BPT trap

I'm using Leopard|Intel 10.5.1 and MacPorts 1.6.0.

#15968 Pidgin 2.4.3 fails patching from gtkdocklet-quartz.diff simon@… defect Normal ports

Reported by jonathan@…, 6 years ago.

Description

I received several patching errors during the port installation of pidgin 2.4.3. They stemmed mostly from trying to remove sections of code no longer present in 2.4.3. I attached a patch to the gtkdocklet-quartz.diff from the "files" directory of ports/net/pidgin/. This removes those sections and includes an updated function definition.

#16760 Pidgin 2.5.1 fails to compile simon@… defect Normal ports

Reported by tafinho@…, 6 years ago.

Description

Pidgin 2.5.1 fails to compile on a brand new port instalation.

log:

--->  Building pidgin with target all
/bin/sh ./config.status --recheck
running CONFIG_SHELL=/bin/sh /bin/sh ./configure  --prefix=/opt/local --disable-avahi --disable-consoleui --disable-gstreamer --disable-gtkspell --disable-meanwhile --disable-nm --disable-perl --disable-screensaver --disable-sm --disable-startup-notification --enable-nss --mandir=/opt/local/share/man --with-nspr-includes=/opt/local/include/nspr --with-nspr-libs=/opt/local/lib --with-nss-includes=/opt/local/include/nss --with-nss-libs=/opt/local/lib CC=/usr/bin/gcc-4.0 CFLAGS=-O2 LDFLAGS=-L/opt/local/lib -bind_at_load CPPFLAGS=-I/opt/local/include -no-cpp-precomp CPP=/usr/bin/cpp-4.0 CXX=/usr/bin/g++-4.0 CXXFLAGS=-O2 FFLAGS=-O2  --no-create --no-recursion
checking build system type... i386-apple-darwin9.5.0
checking host system type... i386-apple-darwin9.5.0
checking target system type... i386-apple-darwin9.5.0
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... ./install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... yes
checking for sed... /usr/bin/sed
checking for gcc... /usr/bin/gcc-4.0
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /usr/bin/gcc-4.0 accepts -g... yes
checking for /usr/bin/gcc-4.0 option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of /usr/bin/gcc-4.0... gcc3
checking whether /usr/bin/gcc-4.0 and cc understand -c and -o together... yes
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ld used by /usr/bin/gcc-4.0... /usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld
checking if the linker (/usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld) is GNU ld... no
checking for /usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -p
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... /usr/bin/cpp-4.0
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking whether we are using the GNU C++ compiler... yes
checking whether /usr/bin/g++-4.0 accepts -g... yes
checking dependency style of /usr/bin/g++-4.0... gcc3
checking how to run the C++ preprocessor... /usr/bin/g++-4.0 -E
checking for g77... no
checking for xlf... no
checking for f77... no
checking for frt... no
checking for pgf77... no
checking for cf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for xlf90... no
checking for f90... no
checking for pgf90... no
checking for pghpf... no
checking for epcf90... no
checking for gfortran... no
checking for g95... no
checking for xlf95... no
checking for f95... no
checking for fort... no
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for ftn... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether  accepts -g... no
checking the maximum length of command line arguments... 196608
checking command to parse /usr/bin/nm -p output from /usr/bin/gcc-4.0 object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if /usr/bin/gcc-4.0 supports -fno-rtti -fno-exceptions... no
checking for /usr/bin/gcc-4.0 option to produce PIC... -fno-common
checking if /usr/bin/gcc-4.0 PIC flag -fno-common works... yes
checking if /usr/bin/gcc-4.0 static flag -static works... no
checking if /usr/bin/gcc-4.0 supports -c -o file.o... yes
checking whether the /usr/bin/gcc-4.0 linker (/usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin9.5.0 dyld
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by /usr/bin/g++-4.0... /usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld
checking if the linker (/usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld) is GNU ld... no
checking whether the /usr/bin/g++-4.0 linker (/usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld) supports shared libraries... yes
checking for /usr/bin/g++-4.0 option to produce PIC... -fno-common
checking if /usr/bin/g++-4.0 PIC flag -fno-common works... yes
checking if /usr/bin/g++-4.0 static flag -static works... no
checking if /usr/bin/g++-4.0 supports -c -o file.o... yes
checking whether the /usr/bin/g++-4.0 linker (/usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin9.5.0 dyld
checking how to hardcode library paths into programs... immediate
appending configuration tag "F77" to libtool
checking for a BSD-compatible install... /usr/bin/install -c
./configure: line 19796: AC_PROG_INTLTOOL: command not found
./configure: line 19797: PKG_PROG_PKG_CONFIG: command not found
checking for working alloca.h... yes
checking for alloca... yes
checking for res_query in -lresolv... yes
checking CoreFoundation/CoreFoundation.h usability... yes
checking CoreFoundation/CoreFoundation.h presence... yes
checking for CoreFoundation/CoreFoundation.h... yes
checking IOKit/IOKitLib.h usability... yes
checking IOKit/IOKitLib.h presence... yes
checking for IOKit/IOKitLib.h... yes
./configure: line 20521: AM_GLIB_GNU_GETTEXT: command not found
configure: error:

The msgfmt command is required to build libpurple.  If it is installed
on your system, ensure that it is in your path.  If it is not, install
GNU gettext to continue.

If you have msgfmt installed, but for some reason this error message
is still displayed, you have encountered what appears to be a bug in
third-party configure macros.  Try setting the MSGFMT environment
variable to the absolute path to your msgfmt binary and trying
configure again, like this:

MSGFMT=/path/to/msgfmt ./configure ...

make: *** [config.status] Error 1
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_pidgin/work/pidgin-2.5.1" && make all " returned error 2
Command output: checking how to hardcode library paths into programs... immediate
appending configuration tag "F77" to libtool
checking for a BSD-compatible install... /usr/bin/install -c
./configure: line 19796: AC_PROG_INTLTOOL: command not found
./configure: line 19797: PKG_PROG_PKG_CONFIG: command not found
checking for working alloca.h... yes
checking for alloca... yes
checking for res_query in -lresolv... yes
checking CoreFoundation/CoreFoundation.h usability... yes
checking CoreFoundation/CoreFoundation.h presence... yes
checking for CoreFoundation/CoreFoundation.h... yes
checking IOKit/IOKitLib.h usability... yes
checking IOKit/IOKitLib.h presence... yes
checking for IOKit/IOKitLib.h... yes
./configure: line 20521: AM_GLIB_GNU_GETTEXT: command not found
configure: error:

The msgfmt command is required to build libpurple.  If it is installed
on your system, ensure that it is in your path.  If it is not, install
GNU gettext to continue.

If you have msgfmt installed, but for some reason this error message
is still displayed, you have encountered what appears to be a bug in
third-party configure macros.  Try setting the MSGFMT environment
variable to the absolute path to your msgfmt binary and trying
configure again, like this:

MSGFMT=/path/to/msgfmt ./configure ...

make: *** [config.status] Error 1

Warning: the following items did not execute (for pidgin): org.macports.activate org.macports.build org.macports.destroot org.macports.install
#16785 pidgin-2.5.1 Will not build simon@… defect Normal ports

Reported by kioarthurdane@…, 6 years ago.

Description

First run results:

--->  Verifying checksum(s) for dbus-glib
--->  Extracting dbus-glib
--->  Configuring dbus-glib
--->  Building dbus-glib with target all
--->  Staging dbus-glib into destroot
--->  Installing dbus-glib 0.76_0
--->  Activating dbus-glib 0.76_0
--->  Cleaning dbus-glib
--->  Fetching pidgin
--->  Attempting to fetch pidgin-2.4.3.tar.bz2 from http://downloads.sourceforge.net/pidgin
--->  Verifying checksum(s) for pidgin
--->  Extracting pidgin
--->  Applying patches to pidgin
--->  Configuring pidgin
--->  Building pidgin with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_pidgin/work/pidgin-2.4.3" && make all " returned error 2
Command output: pidgin/plugins/Makefile.am:68:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
pidgin/plugins/Makefile.am:68:   to `configure.ac' and run `aclocal' and `autoconf' again.
pidgin/plugins/Makefile.am:68:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
pidgin/plugins/Makefile.am:68:   its definition is in aclocal's search path.
pidgin/plugins/cap/Makefile.am:9: Libtool library used but `LIBTOOL' is undefined
pidgin/plugins/cap/Makefile.am:9:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
pidgin/plugins/cap/Makefile.am:9:   to `configure.ac' and run `aclocal' and `autoconf' again.
pidgin/plugins/cap/Makefile.am:9:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
pidgin/plugins/cap/Makefile.am:9:   its definition is in aclocal's search path.
pidgin/plugins/gestures/Makefile.am:7: Libtool library used but `LIBTOOL' is undefined
pidgin/plugins/gestures/Makefile.am:7:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
pidgin/plugins/gestures/Makefile.am:7:   to `configure.ac' and run `aclocal' and `autoconf' again.
pidgin/plugins/gestures/Makefile.am:7:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
pidgin/plugins/gestures/Makefile.am:7:   its definition is in aclocal's search path.
pidgin/plugins/gevolution/Makefile.am:7: Libtool library used but `LIBTOOL' is undefined
pidgin/plugins/gevolution/Makefile.am:7:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
pidgin/plugins/gevolution/Makefile.am:7:   to `configure.ac' and run `aclocal' and `autoconf' again.
pidgin/plugins/gevolution/Makefile.am:7:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
pidgin/plugins/gevolution/Makefile.am:7:   its definition is in aclocal's search path.
pidgin/plugins/musicmessaging/Makefile.am:14: Libtool library used but `LIBTOOL' is undefined
pidgin/plugins/musicmessaging/Makefile.am:14:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
pidgin/plugins/musicmessaging/Makefile.am:14:   to `configure.ac' and run `aclocal' and `autoconf' again.
pidgin/plugins/musicmessaging/Makefile.am:14:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
pidgin/plugins/musicmessaging/Makefile.am:14:   its definition is in aclocal's search path.
pidgin/plugins/ticker/Makefile.am:10: Libtool library used but `LIBTOOL' is undefined
pidgin/plugins/ticker/Makefile.am:10:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
pidgin/plugins/ticker/Makefile.am:10:   to `configure.ac' and run `aclocal' and `autoconf' again.
pidgin/plugins/ticker/Makefile.am:10:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
pidgin/plugins/ticker/Makefile.am:10:   its definition is in aclocal's search path.
make: *** [Makefile.in] Error 1

Further attempts:

sudo port install pidgin
--->  Building pidgin with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_pidgin/work/pidgin-2.5.1" && make all " returned error 1
Command output: sh: line 0: cd: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_pidgin/work/pidgin-2.5.1: No such file or directory
#17052 pidgin-25.2 build error simon@… defect Normal ports

Reported by michaelgoerz@…, 5 years ago.

Description
bash-3.2$ sudo port clean pidgin
--->  Cleaning pidgin
bash-3.2$ sudo port install pidgin +quartz +no_x11
--->  Fetching pidgin
--->  Verifying checksum(s) for pidgin
--->  Extracting pidgin
--->  Applying patches to pidgin
--->  Configuring pidgin
--->  Building pidgin with target all
§Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_pidgin/work/pidgin-2.5.2" && make all " returned error 2
Command output: eggtrayicon.c:462: error: dereferencing pointer to incomplete type
eggtrayicon.c:464: error: dereferencing pointer to incomplete type
eggtrayicon.c:468: error: dereferencing pointer to incomplete type
eggtrayicon.c: In function 'egg_tray_icon_send_message':
eggtrayicon.c:522: error: dereferencing pointer to incomplete type
eggtrayicon.c:522: error: 'None' undeclared (first use in this function)
eggtrayicon.c:528: error: dereferencing pointer to incomplete type
eggtrayicon.c:532: error: 'Window' undeclared (first use in this function)
eggtrayicon.c:532: error: syntax error before 'gtk_plug_get_id'
eggtrayicon.c:539: error: 'XClientMessageEvent' undeclared (first use in this function)
eggtrayicon.c:539: error: syntax error before 'ev'
eggtrayicon.c:540: error: 'Display' undeclared (first use in this function)
eggtrayicon.c:540: error: 'xdisplay' undeclared (first use in this function)
eggtrayicon.c:547: error: 'ev' undeclared (first use in this function)
eggtrayicon.c:547: error: 'ClientMessage' undeclared (first use in this function)
eggtrayicon.c:548: error: syntax error before 'gtk_plug_get_id'
eggtrayicon.c:551: error: 'False' undeclared (first use in this function)
eggtrayicon.c:565: error: dereferencing pointer to incomplete type
eggtrayicon.c:565: error: 'StructureNotifyMask' undeclared (first use in this function)
eggtrayicon.c:565: error: 'XEvent' undeclared (first use in this function)
eggtrayicon.c:565: error: syntax error before ')' token
eggtrayicon.c: In function 'egg_tray_icon_cancel_message':
eggtrayicon.c:581: error: 'Window' undeclared (first use in this function)
eggtrayicon.c:581: error: syntax error before 'gtk_plug_get_id'
eggtrayicon.c: In function 'egg_tray_icon_get_orientation':
eggtrayicon.c:590: error: dereferencing pointer to incomplete type
make[3]: *** [eggtrayicon.o] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Status 1 encountered during processing.

Other variants fail as well.

#20080 pidgin 2.5.5 -> 2.5.7 macports-tickets@… update Normal ports

Reported by nefar@…, 5 years ago.

Description

update pidgin. includes fix for broken yahoo authentication.

#18759 Pidgin 2.5.5 Crashes on load nefar@… defect Normal ports

Reported by jonathan@…, 5 years ago.

Description

After upgrading from Pidgin 2.5.4, the application crashes during startup. The password and buddy list windows do appear briefly, but do not have any contents. Shortly after, I am notified that "The application pidgin quit unexpectedly," following Pidgin closing.

This continues to occur after an uninstall and clean installation. I am using the +no_x11 +quartz variants on Mac OS X 10.5.6.

Note: See TracQuery for help on using queries.