Opened 14 years ago

Closed 14 years ago

#10063 closed defect (worksforme)

xrender config error

Reported by: justboy27@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: markd@…
Port:

Description

I am trying to install scribus and when it gets to configuring xrender I get this error:

---> Configuring xrender Error: Target com.apple.configure returned: configure failure: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_x11_xrender/work/libXrender-0.9.0" && CC=/usr/bin/gcc-4.0 CPP=/usr/bin/cpp-4.0 CXX=/usr/bin/g++-4.0 ./configure --prefix=/opt/local" returned error 1 Command output: checking if /usr/bin/gcc-4.0 supports -fno-rtti -fno-exceptions... no checking for /usr/bin/gcc-4.0 option to produce PIC... -fno-common checking if /usr/bin/gcc-4.0 PIC flag -fno-common works... yes checking if /usr/bin/gcc-4.0 supports -c -o file.o... yes checking whether the /usr/bin/gcc-4.0 linker (/usr/bin/ld) supports shared libraries... yes checking dynamic linker characteristics... darwin8.7.1 dyld checking how to hardcode library paths into programs... immediate checking whether stripping libraries is possible... yes checking if libtool supports shared libraries... yes checking whether to build shared libraries... yes checking whether to build static libraries... yes configure: creating libtool appending configuration tag "CXX" to libtool checking for ld used by /usr/bin/g++-4.0... /usr/bin/ld checking if the linker (/usr/bin/ld) is GNU ld... no checking whether the /usr/bin/g++-4.0 linker (/usr/bin/ld) supports shared libraries... yes checking for /usr/bin/g++-4.0 option to produce PIC... -fno-common checking if /usr/bin/g++-4.0 PIC flag -fno-common works... yes checking if /usr/bin/g++-4.0 supports -c -o file.o... yes checking whether the /usr/bin/g++-4.0 linker (/usr/bin/ld) supports shared libraries... yes checking dynamic linker characteristics... darwin8.7.1 dyld checking how to hardcode library paths into programs... immediate checking whether stripping libraries is possible... yes appending configuration tag "F77" to libtool checking for pkg-config... /opt/local/bin/pkg-config checking pkg-config is at least version 0.9.0... yes checking for X_CFLAGS... checking for X_LIBS... checking for X... no configure: error: X is required, but it was either disabled or not found.

Error: The following dependencies failed to build: cairo xrender cups-headers ghostscript lcms tiff libart_lgpl gettext libiconv libxml2 openssl qt3 Xft2 perl5.8 Error: /opt/local/bin/port: Status 1 encountered during processing.

Change History (2)

comment:1 Changed 14 years ago by blb@…

Do you have both X11 packages installed (X11SDK, from the Xcode install; X11User, from the 10.4 DVD)? It looks like you may only have one.

comment:2 Changed 14 years ago by markd@…

Cc: markd@… added
Resolution: worksforme
Status: newclosed

No feedback. Presumed not a full X11 install. Closing.

Note: See TracTickets for help on using tickets.