Opened 14 years ago

Closed 14 years ago

#10102 closed defect (fixed)

BUG: cannot build csound port on 10.4.7 with latest Xcode

Reported by: jan@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: markd@…
Port:

Description

sudo port install csound---> Fetching csound ---> Verifying checksum(s) for csound ---> Extracting csound ---> Configuring csound ---> Building csound with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_audio_csound/work/csound-4.23f13gbs.0" && make all" returned error 2 Command output: vectorial.c: In function 'vexp': vectorial.c:679: warning: operation on 'vector' may be undefined vectorial.c: In function 'vpowv': vectorial.c:789: warning: operation on 'vector1' may be undefined vectorial.c: In function 'vexpv': vectorial.c:800: warning: operation on 'vector1' may be undefined vectorial.c: In function 'vmap': vectorial.c:811: warning: operation on 'vector1' may be undefined vectorial.c: In function 'vlimit': vectorial.c:837: warning: operation on 'vector' may be undefined vectorial.c: In function 'vport': vectorial.c:901: warning: operation on 'yt1' may be undefined vectorial.c:901: warning: operation on 'vector' may be undefined vectorial.c: In function 'vwrap': vectorial.c:922: warning: operation on 'vector' may be undefined vectorial.c:924: warning: operation on 'vector' may be undefined /bin/sh ../libtool --mode=link --tag=CC gcc -g -O2 -Wall -falign-loops=4 -falign-jumps=4 -ffast-math -fomit-frame-pointer -finline-functions -funroll-loops -I/opt/local/include -I/opt/local/include -o vectorial.la -rpath /opt/local/lib/csound -module -avoid-version -no-undefined vectorial.lo -L/opt/local/lib -lfltk -framework Carbon -framework ApplicationServices -lsupc++ -lstdc++ -lpthread -framework CoreAudio ar cru .libs/vectorial.a vectorial.o ranlib .libs/vectorial.a creating vectorial.la (cd .libs && rm -f vectorial.la && ln -s ../vectorial.la vectorial.la) if g++ -DHAVE_CONFIG_H -I. -I. -I. -I.. -I.. -g -O2 -Wall -I/opt/local/include -MT csound-ccsound.o -MD -MP -MF ".deps/csound-ccsound.Tpo" -c -o csound-ccsound.o test -f 'ccsound.cpp' || echo './'ccsound.cpp; \ then mv -f ".deps/csound-ccsound.Tpo" ".deps/csound-ccsound.Po"; else rm -f ".deps/csound-ccsound.Tpo"; exit 1; fi /bin/sh ../libtool --mode=link --tag=CXX g++ -fno-exceptions -fno-rtti -g -O2 -Wall -I/opt/local/include -o csound csound-ccsound.o libcsound.la -L/opt/local/lib -lfltk -framework Carbon -framework ApplicationServices -lsupc++ -lstdc++ -lpthread -framework CoreAudio g++ -fno-exceptions -fno-rtti -g -O2 -Wall -I/opt/local/include -o csound csound-ccsound.o -framework Carbon -framework ApplicationServices -framework CoreAudio -Wl,-bind_at_load ./.libs/libcsound.a -L/opt/local/lib -lfltk -lsupc++ -lstdc++ -lpthread /usr/bin/ld: can't locate file for: -lfltk collect2: ld returned 1 exit status make[2]: * [csound] Error 1 make[1]: * [all] Error 2 make: * [all-recursive] Error 1

Error: /opt/local/bin/port: Status 1 encountered during processing.

Change History (2)

comment:1 Changed 14 years ago by markd@…

Cc: markd@… added

This may have been caused by a problem with fltk, which was just updated. Please remove and re-install fltk, then reinstall csound. It builds fine for me on a MacBook Pro / Xcode 2.4 using the new fltk 1.1.7.

comment:2 Changed 14 years ago by markd@…

Resolution: fixed
Status: newclosed

After looking again at the build error I can see it is defintely caused by the fltk problem that was fixed in 1.1.7. Errors in 1.1.6 caused it to not install anything in the /lib directory so csound failed to install. Marking this as fixed.

Note: See TracTickets for help on using tickets.