Opened 18 years ago

Closed 18 years ago

Last modified 17 years ago

#1030 closed defect (duplicate)

glib2 needs gettext... listed as a dependency but not retrieved or installed

Reported by: leimy@… Owned by: ranger@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

This is a weird bug. I had to manually install gettext to make glib2 build even though it is listed as a dependency for glib2.

This came up when trying to build KDE on a clean G5 system running 7B74 but it should definitely affect other systems I would think.

Change History (6)

comment:1 Changed 18 years ago by mww@…

Owner: changed from darwinports-bugs@… to mij@…

reassinged to port owner mij@

comment:2 Changed 18 years ago by mij@…

I can't replicate this this locally--gettext gets installed as it should. Can anyone else reproduce this (even though the bug is kind of old now)?

I'll give it a few days and if I don't hear anything, I'll close it.

  • jim

comment:3 Changed 18 years ago by ssen@…

Owner: changed from mij@… to ranger@…

I've run into this too. I figured it out.

The problem is that kdelibs3 has a dependency "lib:libiconv.2:gettext". Note that gettext does not install libiconv itself, but since gettext depends on libiconv, it tends to get installed whenever gettext is.

The problem here is that libiconv.2 regex will match against /usr/lib/libiconv.2.dylib, and something marks off "gettext" as satisfied. Any other port in the dependency chain of kdelibs3 that requires gettext will not trigger a build, because darwinports base things that gettext is installed.

This is a really bogus dependency implementation. The short term fix is for kdelibs3 to be fixed.

comment:4 Changed 18 years ago by ssen@…

I've reproduced this. You need to start with a clean system and to "port install kdelibs3"

comment:5 Changed 18 years ago by ranger@…

I'm not in any way set up to test this, but I've committed a change to the deps that will at least make it less wrong.

If this doesn't work, I'll see if I can get my machine put together into a mode (and get enough room) to re-set-up a dports sandbox and build. If it does, let me know and I'll close this bug. =)

comment:6 Changed 18 years ago by toby@…

Resolution: duplicate
Status: newclosed

* This bug has been marked as a duplicate of 1667 *

Note: See TracTickets for help on using tickets.