Opened 14 years ago

Closed 14 years ago

#10320 closed defect (duplicate)

BUG: readline-5.1 unable to fetch

Reported by: garlandkr@… Owned by: digdog@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: eric@…, markd@…
Port:

Description

I'm actually using DarwinPorts 1.310

root# port install readline ---> Fetching readline ---> Attempting to fetch readline51-001 from ftp://ftp.cwru.edu/pub/bash/readline-5.1-patches/ ---> Attempting to fetch readline51-001 from http://distfiles-od.opendarwin.org/readline ---> Attempting to fetch readline51-001 from http://distfiles-msn.opendarwin.org/readline ---> Attempting to fetch readline51-001 from http://distfiles-bay13.opendarwin.org/readline ---> Attempting to fetch readline51-001 from http://distfiles-od.opendarwin.org/ ---> Attempting to fetch readline51-001 from http://distfiles-msn.opendarwin.org/ ---> Attempting to fetch readline51-001 from http://distfiles-bay13.opendarwin.org/ Error: Target com.apple.fetch returned: fetch failed Error: Status 1 encountered during processing.

I have had no problems with installing other ports, probably around 30+ so far.

Change History (10)

comment:1 Changed 14 years ago by garlandkr@…

(In reply to comment #0)

I'm actually using DarwinPorts 1.310

root# port install readline ---> Fetching readline ---> Attempting to fetch readline51-001 from ftp://ftp.cwru.edu/pub/bash/readline-5.1-patches/ ---> Attempting to fetch readline51-001 from http://distfiles-od.opendarwin.org/readline ---> Attempting to fetch readline51-001 from http://distfiles-msn.opendarwin.org/readline ---> Attempting to fetch readline51-001 from http://distfiles-bay13.opendarwin.org/readline ---> Attempting to fetch readline51-001 from http://distfiles-od.opendarwin.org/ ---> Attempting to fetch readline51-001 from http://distfiles-msn.opendarwin.org/ ---> Attempting to fetch readline51-001 from http://distfiles-bay13.opendarwin.org/ Error: Target com.apple.fetch returned: fetch failed Error: Status 1 encountered during processing.

I have had no problems with installing other ports, probably around 30+ so far.

I was able to get it working by downloading the patch files myself from ftp://ftp.cwru.edu/pub/bash/readline-5.1-patches (readline51-00[1-4]) and put them in /opt/local/var/db/dports/distfiles/readline

comment:2 Changed 14 years ago by ekoontz@…

having same problem; thanks to reporter for providing workaround, which works fine.

comment:3 Changed 14 years ago by markd@…

Cc: eric@… added
Owner: changed from macports-tickets@… to digdog@…
Summary: readline unable to fetchBUG: readline-5.1 unable to fetch

I think Eric is digdog, if not I'm cc'ing also.

comment:4 Changed 14 years ago by digdog@…

FYI: I am not eric, I am Kevin Fyure.

comment:5 Changed 14 years ago by markd@…

Oh sorry Kevin. Well I had some trouble couple of weeks ago or so but now it is fetching fine. Is this solved for you now?

comment:6 Changed 14 years ago by markd@…

Cc: markd@… added

comment:7 Changed 14 years ago by markd@…

Resolution: worksforme
Status: newclosed

comment:8 Changed 14 years ago by trac.macosforge.org@…

Resolution: worksforme
Status: closedreopened

this ended up being Ticket #10832

comment:9 Changed 14 years ago by markd@…

So why keep a bug open on readline? I'd guess there are at least hundreds of ports that exhibit the same behavior.

comment:10 Changed 14 years ago by markd@…

Resolution: duplicate
Status: reopenedclosed

Or maybe you meant it should be marked duplicate of #10832. That's what I think.

Note: See TracTickets for help on using tickets.