Opened 14 years ago

Closed 14 years ago

#10379 closed enhancement (wontfix)

RFE: 'port upgrade foo' installs foo if it wasn't installed, rather than fail the upgrade

Reported by: jaris@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.2
Keywords: Cc: markd@…
Port:

Description

It seems 'upgrade' installs non-present, non-dependency ports, which seems semantically wrong. Being used to slackpkg, i ran "port upgrade all" which started installing every package available.

IMO it should either bork on that command, or only install a new port if it is a dependency of a port being upgraded.

Change History (7)

comment:1 Changed 14 years ago by jberry@…

Hehe. You really wanted "port upgrade installed" I guess.

So I suppose the issue is: should upgrade refuse to upgrade a port that is uninstalled. (Processing of the pseudo-portname all is at a level that the upgrade target doesn't even see).

comment:2 Changed 14 years ago by danielluke (Daniel J. Luke)

(In reply to comment #1)

Hehe. You really wanted "port upgrade installed" I guess.

or even better, port upgrade outdated

So I suppose the issue is: should upgrade refuse to upgrade a port that is uninstalled. (Processing of the pseudo-portname all is at a level that the upgrade target doesn't even see).

Note that the current upgrade installs ports it's asked to upgrade that aren't installed because it calls itself recursively for each ports's dependencies when it upgrades them (this way, when a port adds a new dependency, it gets installed on upgrade).

comment:3 Changed 14 years ago by jaris@…

I assume this would be possible to fix by passing a flag similar to -n when upgrading dependencies, which allows installing non-installed packages on upgrade. This would also handle the cases where the user actually wants the old behavior.

comment:4 Changed 14 years ago by markd@…

Type: defectenhancement

comment:5 Changed 14 years ago by markd@…

Summary: port upgrade all has unexpected behaviorRFE: 'port upgrade foo' installs foo if it wasn't installed, rather than fail the upgrade

comment:6 Changed 14 years ago by markd@…

So should this be closed as "wontfix"?

comment:7 Changed 14 years ago by markd@…

Cc: markd@… added
Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.