Opened 14 years ago

Closed 14 years ago

#10624 closed enhancement (fixed)

RFE: imageMagick-6.2.7 should provide x11 support by default or warn of no X11 support

Reported by: j.van_den_hoff@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: markd@…
Port:

Description

the current version (imagemagick @6.2.7-5_0) installs by default without x11 support. the user is not notified of this change relative to previous behaviour (either from ports or, e.g. `display' itself. as a result, starting display as

`display' or `display {some_image}'

does only send the display -help' output to the terminal and nothing helps happens. if not a bug, it's definitely at least confusing. I personally would opt for restoring the default to x11 support. if this is not wanted, I would propose to either change the port info imagemagick' output or propose to the imageMagick people to at least issue a resonable message if `display' does not find a graphic device.

Change History (4)

comment:1 Changed 14 years ago by markd@…

Summary: imageMagick installed without x11 support by defaultRFE: imageMagick-6.2.7 should provide x11 support by default or warn of no X11 support
Type: defectenhancement

comment:2 Changed 14 years ago by markd@…

Cc: markd@… added

comment:3 Changed 14 years ago by markd@…

Imagemagick is now unmaintained. Any chance you'd want to be maintainer?

comment:4 Changed 14 years ago by markd@…

Resolution: fixed
Status: newclosed

Committed a fix for this. X11 support now on by default; a nox11 variant is available to turn it off. Thanks.

Note: See TracTickets for help on using tickets.