Opened 14 years ago

Closed 14 years ago

#10931 closed defect (fixed)

gaim 2.0.0beta3.1 missing dependency to p5-xml-parser

Reported by: david@… Owned by: mij@…
Priority: High Milestone:
Component: ports Version: 1.3.2
Keywords: gaim configure dependency Cc: mij@…, markd@…
Port:

Description

i've been having some trouble getting gaim to compile. here are the steps to reproduce the error: download darwinports-1.3.2. do a port sync. don't selfupdate (since i was up to date when i did it). install gaim:

sudo port install gaim

here's the relevant error message:

--->  Configuring gaim
Error: Target com.apple.configure returned: configure failure: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_net_gaim/work/gaim-2.0.0beta3.1" && LDFLAGS="-L/opt/local/lib -bind_at_load" CPPFLAGS="-no-cpp-precomp" ./configure --prefix=/opt/local --disable-gtkspell --disable-screensaver --disable-sm --mandir=/opt/local/share/man --disable-perl" returned error 1
Command output: checking for ranlib... ranlib
checking for strip... strip
[...]
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

Error: Status 1 encountered during processing.

it seems to be a problem with the XML::Parser perl module missing.

i've already got the following installed:

  atk @1.12.2_0 (active)
  audiofile @0.2.6_0 (active)
  autoconf @2.60_0 (active)
  automake @1.9.6_0 (active)
  cairo @1.2.4_1 (active)
  esound @0.2.36_0 (active)
  expat @2.0.0_1 (active)
  flac @1.1.2_0 (active)
  fontconfig @2.3.2_2+macosx (active)
  freetype @2.1.10_1 (active)
  gettext @0.15_0 (active)
  glib2 @2.12.4_0 (active)
  gnutls @1.4.1_0+darwin_8 (active)
  gtk2 @2.10.3_0 (active)
  id3lib @3.8.3_0 (active)
  jpeg @6b_1 (active)
  libao @0.8.6_1 (active)
  libgcrypt @1.2.2_0+darwin_8 (active)
  libgpg-error @1.3_0 (active)
  libiconv @1.11_0+darwin_8 (active)
  libid3tag @0.15.1b_0 (active)
  libmad @0.15.1b_0 (active)
  libogg @1.1.3_0 (active)
  libpng @1.2.10_2+darwin_8 (active)
  libtasn1 @0.3.4_0 (active)
  libtool @1.5.22_0 (active)
  madplay @0.15.2b_0 (active)
  opencdk @0.5.8_0 (active)
  pango @1.14.3_0 (active)
  perl5.8 @5.8.8_0+darwin_8 (active)
  pkgconfig @0.21_0 (active)
  render @0.9_0 (active)
  tiff @3.8.2_0+darwin_8 (active)
  unrar @3.6.5_0 (active)
  Xft2 @2.1.7_0 (active)
  xrender @0.9.0_0+darwin_8 (active)
  zlib @1.2.3_0 (active)

i'm running mac os x 10.4.8 and have xcode tools installed with apples X11.

i looked up what XML::Parser is and saw the port "p5-xml-parser". fairly enough that's what was missing for the build to succeed, now i got some progress.

then i get the following at the clean stage:

sudo port install gaim
--->  Configuring gaim
--->  Building gaim with target all
--->  Staging gaim into destroot
--->  Installing gaim 2.0.0beta3.1_0+msn
--->  Activating gaim 2.0.0beta3.1_0+msn
--->  Cleaning gaim
couldn't change working directory to "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_net_gaim/work/gaim-2.0.0beta3.1": no such file or directory
    while executing
"cd $savedir"
    (procedure "foreachport" line 17)
    invoked from within
"foreachport $portlist {
         set target $action

         # If we have a url, use that, since it's most specific
         # otherwise try to map the portname to a url
..."
    (procedure "action_target" line 4)
    invoked from within
"$action_proc $action $portlist [array get global_options]"
    (procedure "process_cmd" line 49)
    invoked from within
"process_cmd $remaining_args"
    invoked from within
"if { [llength $remaining_args] > 0 } {

        # If there are remaining arguments, process those as a command

        # Exit immediately, by default, unless we'r..."
    (file "/opt/local/bin/port" line 2564)

and yea the above directory does not exist. at least i'm able to get it running.

Change History (3)

comment:1 Changed 14 years ago by markd@…

Assign to maintainer.

comment:2 Changed 14 years ago by markd@…

Cc: mij@… markd@… added

Oh yeah, I've heard cc'ing may be necessary also.

comment:3 Changed 14 years ago by markd@…

Resolution: fixed
Status: newclosed

Added p5-xml-parser dependency. I saw no problems at clean stage.

Note: See TracTickets for help on using tickets.