Opened 14 years ago

Closed 4 years ago

#10962 closed defect (fixed)

incorrect encoding in log message sent by source_changes@macosforge.org

Reported by: vinc17@… Owned by: admin@…
Priority: Low Milestone:
Component: server/hosting Version:
Keywords: Cc: ryandesign (Ryan Schmidt)
Port:

Description

The mail sent for revision 20216 contained:

Log Message:
-----------
New port stardict-xmlittre: XMLittr?\195?\169 dictionary for stardict (bug 10867).

There's a problem with the encoding of non-ASCII characters (the encoding of the log message in the Subversion repository is fine, according to "svn log", so the problem is in the generation of the mail).

Change History (9)

comment:1 Changed 13 years ago by nox@…

Priority: ExpectedNormal

comment:2 Changed 13 years ago by wsiegrist@…

Owner: changed from kvv@… to wsiegrist@…
Priority: NormalLow

various charset options to svnnotify dont seem to help. svn log on the local machine also shows the incorrect characters, so its more of a server issue. I'll investigate further, but right now Im setting low priority since the data is correct in the repo, its just not being translated correctly in the shell/hooks/etc.

comment:3 Changed 13 years ago by wsiegrist@…

Status: newassigned

comment:4 Changed 12 years ago by raimue (Rainer Müller)

Milestone: Website & Documentation

comment:5 Changed 12 years ago by (none)

Milestone: Website & Documentation

Milestone Website & Documentation deleted

comment:6 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Has duplicate #23809.

comment:7 Changed 6 years ago by jmroot (Joshua Root)

Cc: vinc17@… removed
Owner: changed from wsiegrist@… to admin@…
Status: assignednew

comment:8 Changed 4 years ago by ryandesign (Ryan Schmidt)

Owner: changed from admin@… to admin@…
Status: newassigned

comment:9 Changed 4 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: assignedclosed

We've moved off of both svn and macosforge, so I can't imagine this is still relevant.

Note: See TracTickets for help on using tickets.